PDA

View Full Version : New 6.5.1 Install Doesn't Work



vamythguy
2007-02-04, 14:45
Ok, I'm at a loss. A new 6.5.1 install is not working. First, I have to
manually run scanner.pl. It will find the music, but trying to play it
fails out immediately. It had been reporting permissions errors, but no
longer does so. Internet radio works fine, but album art no longer does.
Any ideas?

mherger
2007-02-04, 14:52
> Any ideas?

Do you know what operating system this is? And what /tmp/slimserver.log
says?

--

Michael

-----------------------------------------------------------------
http://www.herger.net/SlimCD - your SlimServer on a CD
http://www.herger.net/slim - AlbumReview, Biography, MusicInfoSCR

vamythguy
2007-02-04, 14:57
On 2/4/07, Michael Herger <slim (AT) herger (DOT) net> wrote:
>
> > Any ideas?
>
> Do you know what operating system this is? And what /tmp/slimserver.log
> says?
>
> --
>
> Michael
>
> -----------------------------------------------------------------
> http://www.herger.net/SlimCD - your SlimServer on a CD
> http://www.herger.net/slim - AlbumReview, Biography, MusicInfoSCR
>

Robin Bowes
2007-02-04, 16:10
vamythguy wrote:
>
> It's a new FC6 install. The og shows:
>
> 2007-02-01 12:31:14.4181 About to look for files in /media/music
> 2007-02-01 12:31:14.4464 For files with extensions in:
> [(?i-xsm:\.(?:ape|wma|shn|wav|wave|mp3|mp2|flc|flac|m4a |mov|m4b|mp4|mp+|mpc|ogg|aif|aiff|cue)$)]
>
> 2007-02-04 10:10:45.0203 ERROR: Cannot write to preferences file
> /etc/slimserver.conf, any changes made will not be preserved for the
> next startup of the server

That means the slimserver user does not have permission to write to that
file.

How did you do the install?

Have you, at any stage, run slimserver.pl as root?

> 2007-02-04 10:39:09.5718 [/media/music/10,000 Maniacs/MTV Unplugged/01
> These Are The Days.flac] does not exist or cannot be read: Permission
> denied at /usr/local/slimserver/lib/Audio/FLAC/Header.pm line 59.
> 2007-02-04 10:39:09.5727 ERROR: FLAC: Couldn't open file:
> [/media/music/10,000 Maniacs/MTV Unplugged/01 These Are The Days.flac]
> for reading: Permission denied
>
> Which reflects a rescan and then an attempt to play a song. FWIW:
>
> # ls -l "/media/music/10,000 Maniacs/MTV Unplugged/01 These Are The
> Days.flac"
> -rw-r--r-- 1 slimserver slimserver 35315083 Jan 25 00:01
> /media/music/10,000 Maniacs/MTV Unplugged/01 These Are The Days.flac

/media is where Fedora automounts CDs, flash cards, etc. So, it might
not like you putting your music there.

Do you have SELinux enabled?

Try:

ls -ld /media
ls -ld /media/music
ls -ld /media/music/10,000\ Maniacs
etc.

Check permissions. Specifically, make sure directories have at least
read and execute attributes set, e.g.:

dr-xr-xr-x

R.

vamythguy
2007-02-05, 11:18
On 2/4/07, Robin Bowes <robin-lists (AT) robinbowes (DOT) com> wrote:
>
> vamythguy wrote:
> >
> > It's a new FC6 install. The og shows:
> >
> > 2007-02-01 12:31:14.4181 About to look for files in /media/music
> > 2007-02-01 12:31:14.4464 For files with extensions in:
> >
> [(?i-xsm:\.(?:ape|wma|shn|wav|wave|mp3|mp2|flc|flac|m4a |mov|m4b|mp4|mp+|mpc|ogg|aif|aiff|cue)$)]
> >
> > 2007-02-04 10:10:45.0203 ERROR: Cannot write to preferences file
> > /etc/slimserver.conf, any changes made will not be preserved for the
> > next startup of the server
>
> That means the slimserver user does not have permission to write to that
> file.
>
> How did you do the install?
>
> Have you, at any stage, run slimserver.pl as root?
>
> > 2007-02-04 10:39:09.5718 [/media/music/10,000 Maniacs/MTV Unplugged/01
> > These Are The Days.flac] does not exist or cannot be read: Permission
> > denied at /usr/local/slimserver/lib/Audio/FLAC/Header.pm line 59.
> > 2007-02-04 10:39:09.5727 ERROR: FLAC: Couldn't open file:
> > [/media/music/10,000 Maniacs/MTV Unplugged/01 These Are The Days.flac]
> > for reading: Permission denied
> >
> > Which reflects a rescan and then an attempt to play a song. FWIW:
> >
> > # ls -l "/media/music/10,000 Maniacs/MTV Unplugged/01 These Are The
> > Days.flac"
> > -rw-r--r-- 1 slimserver slimserver 35315083 Jan 25 00:01
> > /media/music/10,000 Maniacs/MTV Unplugged/01 These Are The Days.flac
>
> /media is where Fedora automounts CDs, flash cards, etc. So, it might
> not like you putting your music there.
>
> Do you have SELinux enabled?
>
> Try:
>
> ls -ld /media
> ls -ld /media/music
> ls -ld /media/music/10,000\ Maniacs
> etc.
>
> Check permissions. Specifically, make sure directories have at least
> read and execute attributes set, e.g.:
>
> dr-xr-xr-x
>
> R.
>
>

Robin Bowes
2007-02-05, 11:47
vamythguy wrote:

> Turns-out it was missing execute permissions on the directories. Weird
> - but thanks!

You probably did something like:

chmod -R 666 /media/music

Glad it's working.

R.

vamythguy
2007-02-05, 12:01
On 2/5/07, Robin Bowes <robin-lists (AT) robinbowes (DOT) com> wrote:
>
> vamythguy wrote:
>
> > Turns-out it was missing execute permissions on the directories. Weird
> > - but thanks!
>
> You probably did something like:
>
> chmod -R 666 /media/music
>
> Glad it's working.
>
> R.
>
>

AudioCat
2007-02-11, 17:13
FWIW, I cannot get Slimserver 6.5.1 to run on Mac OSX 10.4.8. Player firmware is 64.

After installation, Slimserver starts momentarily and then stops. The slimserver log shows the following:

2007-02-11 18:28:56.5002 SlimServer settings effective user and group if requested...
2007-02-11 18:28:56.5013 SlimServer settings init...
2007-02-11 18:28:57.8258 SlimServer strings init...
2007-02-11 18:28:58.4725 SlimServer Setup init...
2007-02-11 18:28:58.5493 SlimServer setting language...
2007-02-11 18:28:58.5495 SlimServer MySQL init...
2007-02-11 18:29:00.1531 Firmware init...
2007-02-11 18:29:00.2096 SlimServer Info init...
Database error: Duplicate column name 'contributor' at /Users/blackbook/Library/PreferencePanes/SlimServer.prefPane/Contents/server/CPAN/DBIx/Migration.pm line 115.
2007-02-11 18:29:01.4085 Got to the END.


I've tried direct upgrade of 6.5.0 and I've tried removing all versions and installing cleanly but it always fails. I'm back to using 6.5.0. Would like to get 6.5.1 installed to see if its buffering feature eliminates stuttering that occurs on one radio stream (KPIG - all other streams work fine).

Thanks.

Triode
2007-02-11, 17:29
You need to manually delete the database as the automatic migration scripts have not worked:

If don't have your own mysql - delete the contents of the "Cache" folder.

If you have your own mysql - drop and create database slimserver.

AudioCat
2007-02-13, 17:22
You need to manually delete the database as the automatic migration scripts have not worked:

If don't have your own mysql - delete the contents of the "Cache" folder.

If you have your own mysql - drop and create database slimserver.

Are these steps relevant for Macintosh? The only "Cache" and "MySQL" folders I have are on the boot camp partition for Windows and I cannot remove these when I'm booted into OSX (which is where I'm trying to install 6.5.1). Is it possible that the presence of these folders is interfering with the OSX installation even though they are for a Windows installation?

BTW, I decided to boot into the Windows partition and uninstall Slimserver from there and manually delete all Slimserver files under \program files. Now, when I search for Cache and MySQL nothing is found on any paritions (pertaining to slimserver) but the 6.5.1 upgrade still exhibits the same behavior reported in my above post.

The next step I will try is to completely remove Slimserver so nothing is left in either OSX or Windows partitions and try a clean 6.5.1 installation. If this fails, then I give up on 6.5.1 for good. :-(

AudioCat
2007-02-13, 18:10
Ok, completed the clean removal of Slimserver from both OSX and Windows partitions. Searched drives for evidence of slim*, cache and mysql files and found nothing except those in the Trash that I had deleted. Ran a clean install of 6.5.1 and it still doesn't work.

At this point, I don't know what else I can do other than use 6.5.0 and hope that future releases of slimserver are less problematic. I'm not the type who wants to mess with daily releases but I did try the Feb 13th daily build and it too fails.

danco
2007-02-14, 01:14
Looks as if you hadn't found the SlimServer cache.

Inside your Library folder is a folder named Caches and inside that is a SlimServer folder,. That's what you should try deleting (or at least, moving it to the Desktop so you can put it back if you want).

I think the clue is that you say "when I search for Cache" you don't find anything. You probably used Spotlight, and there are various places that Spotlight does not search - I forget exactly what is omitted, but most probably the Library folder isn't included.

AudioCat
2007-02-14, 05:58
Looks as if you hadn't found the SlimServer cache.

Inside your Library folder is a folder named Caches and inside that is a SlimServer folder,. That's what you should try deleting (or at least, moving it to the Desktop so you can put it back if you want).

I think the clue is that you say "when I search for Cache" you don't find anything. You probably used Spotlight, and there are various places that Spotlight does not search - I forget exactly what is omitted, but most probably the Library folder isn't included.

Thanks, you are right about that so, after manually deleting it, I tried once again to install 6.5.1 and now the following error occurs trying to start Slimserver:

2007-02-14 07:23:04.7909 SlimServer settings effective user and group if requested...
2007-02-14 07:23:04.7932 SlimServer settings init...
2007-02-14 07:23:07.5267 SlimServer strings init...
2007-02-14 07:23:08.2952 SlimServer Setup init...
2007-02-14 07:23:08.3627 SlimServer setting language...
2007-02-14 07:23:08.3630 SlimServer MySQL init...
2007-02-14 07:23:38.0534 ERROR: MySQLHelper: createSystemTables() Couldn't connect to database: [Can't connect to local MySQL server through socket '/Users/blackbook/Library/Caches/SlimServer/slimserver-mysql.sock' (2)]

I searched for this and found several threads in threads about "Debian" and other things of which I know nothing about. I also found a thread that suggested restoring an errmsg file but, I don't see that on my system.

These types of problems are the things that will prevent Squeezebox from ever going "mainstream". Not all of us are programmers or know anything at all about things like MySql, Unix, etc. Don't get me wrong, I love the Squeezebox and have pretty much had it working flawlessly until installing 6.5.1. I understand that someone who wants to setup a music server needs to have an understanding of networking etc and I have been able to resolve the occasional glitches that pop up with the router interfering with SB. But, problems like what I've encountered in this thread are another thing entirely and it would be nice if the installation program could handle an upgrade properly whenever one is requested.

Thanks for your help. I'm interested in finding root cause on this to help others who may hit the same error so if someone wants to make other suggestions, I'll try them but, at some point, I'll have to give up on this build and hope that future upgrades are smoother.