PDA

View Full Version : Music IP question.... sigh.....sigh... :)



Zevs
2007-01-31, 10:46
Hi!

I'm fairly new to SS and also to MusicIP and don't really understand all the lingo round how these are to be connected to work perfectly. I have followed the Wiki though for this and set up everything as said there. I also have followed some threads about the use of headless MusicIP and got the service started, However, I don't seem to get any dependancy from SS on MusicIP when I check running services.msc...

Anyhow, when using 6.5.0 I did get my mm symbols when checking on SS in the browser mode. Then I upgraded to the offical 6.5.1 and then I had problems with scanning of my library. It seemed to die midway so I couldn't update. Trying to clear and do a full rescan just didn't do antyhing it seemed. I saw other people had problems with this also, so then I yesterday upgraded to the last 6.5.2 version (6.5.2 - 11310), and then rescanning my library worked fine again. A relief! But... I don't see any more mm symbols in the web browser, indicating that SS and MusicIP doesn't talk to each other any more.

So my questions are, could someone in layman terms please explain how to make the SS and the headless version of MuscIP be dependent on each other, and why doesn't SS and Music IP communicate any longer even after having the MusicIP GUI running.

Grateful for help on these things! I know you might be really tired of answering these questions from beginners, but still ....:)

Very, very grateful for help!!
Zevs

thing-fish
2007-01-31, 15:27
So my questions are, could someone in layman terms please explain how to make the SS and the headless version of MuscIP be dependent on each other, and why doesn't SS and Music IP communicate any longer even after having the MusicIP GUI running.

I'm no pro, but love the SlimServer/MusicIP combination and have been running it for a while. The big thing is that MusicMagicMixer has to have its API service turned on (regardless of whether it's the headless or GUI version), and it needs to be running before SlimServer starts.

However! At least as a temporary workaround, you can go to the Server Settings->Plugins page and tell Slimserver to load plugins on the fly instead of at startup only. Make sure MusicMagic is checked. In the event that SlimServer loads before MusicMagic, you just navigate to server settings->plugins after MusicMagic has started, and SlimServer will start using it again.

For a more permanent fix, I'm assuming you're running on Windows since you talked about services.msc. I did find a site that describes how to edit the registry to make one service dependent on another: http://www.boyce.us/windows/servertipcontent.asp?ID=7. However, I don't know if slimserver runs as a service on Windows, someone else will have to jump in on that!

Ron Olsen
2007-01-31, 18:17
Are you sure the MusicIP Server is running? Point your browser to http://localhost:10002/; you should get the MusicIP Server page.

If you don't get anything at this URL, then you need to restart the MusicIP Server so it can communicate with SlimServer.

Zevs
2007-02-01, 09:56
The big thing is that MusicMagicMixer has to have its API service turned on (regardless of whether it's the headless or GUI version), and it needs to be running before SlimServer starts.

Thanks for the reply!! I tried to test this by disabling the autostart of SS when rebooting Windows, and then starting it manually after I had started MusicIP. Unfortunately nothing changed and no MM symbols are visble.


However! At least as a temporary workaround, you can go to the Server Settings->Plugins page and tell Slimserver to load plugins on the fly instead of at startup only. Make sure MusicMagic is checked.

I did try this also, but again nothing changed no M symbols showing up.


For a more permanent fix, I'm assuming you're running on Windows since you talked about services.msc. I did find a site that describes how to edit the registry to make one service dependent on another: http://www.boyce.us/windows/servertipcontent.asp?ID=7. However, I don't know if slimserver runs as a service on Windows, someone else will have to jump in on that!

Well, it seems this ref is more or less telling how to make one service wait on something else, and since the manual way of starting slimserver after MusicIP has started didn't work, I don't think this might work either. I guess also it was a bit too technical so I I felt unsafe to test it out :) I did find though something with this instuction at:

http://forums.slimdevices.com/showthread.php?t=24457&highlight=musicip
1. Install the service of MusicIP in Dos Box.
Open a Command Prompt and change directory to "C:\Program Files\MusicIP\MusicIP Mixer" and type "MusicmagicServer install"

2. Add the following value to your Registry using regedit (Edit, New, Multi-String Value):

Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\slimsvc\
Value Name: DependOnService
Value Type: REG_MULTI_SZ
Value Data: MusicIP Server

3. Reboot

I tried this also and both servers are running after rebooting but there is no dependancey and still no M icons showing up....

Zevs

Zevs
2007-02-01, 10:00
Are you sure the MusicIP Server is running? Point your browser to http://localhost:10002/; you should get the MusicIP Server page.

If you don't get anything at this URL, then you need to restart the MusicIP Server so it can communicate with SlimServer.

Yes Ron, the MusicIP server is for sure running, and I do get to a correct page when trying to do what you suggested...

Zevs

Ron Olsen
2007-02-01, 10:06
Try stopping and restarting SlimServer. Sometimes that helps get in into sync with MusicIP Server. Also verify that "MusicMagic" is checked in SlimServer's Server Settings/Plugins, and that MusicMagic shows up on the menu for SlimServer's Server Settings. Make sure the MusicMagic HTTP Port is set to 10002.

Zevs
2007-02-01, 10:35
Hi Ron thanks for helping!!!

Yes for sure all these things you mention I have done and checked or they are running and showing up as supposed to. The only difference is that my MusicIP is set to 10040, but that is also what it says in the Slimserver setting for its HTTP port.... would this be a problem..... ??

Zevs

Ron Olsen
2007-02-01, 12:26
Hi Ron thanks for helping!!!

Yes for sure all these things you mention I have done and checked or they are running and showing up as supposed to. The only difference is that my MusicIP is set to 10040, but that is also what it says in the Slimserver setting for its HTTP port.... would this be a problem..... ??

Zevs
If both SlimServer and MusicIP have the port set to 10040, and you can access the MusicIP Server at http://localhost:10040, then you are good to go.

When you look at the MusicMagic Server webpage at http://localhost:10040, what are the counts for Total songs, Mixable songs, and Songs to validate?
How does the count of Total Songs in MusicMagic Server compare to the count of songs in SlimServer?

On SlimServer/Server Settings/Music Magic, what is the MusicMagic Reload Interval set to? It should be non-zero.

Try the "Test Connection" button at the bottom of the http://localhost:10040 web page; you should get "Server connection is OK".

If all of this looks good, try stopping and restarting SlimServer.

Siduhe
2007-02-01, 12:31
Sorry to mention the obvious here - but you have checked "Use Music Magic" in the Server Settings Page of Slimserver have you ?

Sometimes, uninstalling MIP will cause Slimserver to default to "no" - and you need to manually reset Slimserver to look for MusicIP.

Zevs
2007-02-01, 13:25
Hi again Ron!

I noticed something strange that I don't really understand. I tried to change the port values and realized I couldn't change the port in Music IP to 10002. The program said I needed to try another port. Using services.mcs I then looked at the MusicIP service and stopped that. Then I could change the port number in the program to 10002, and also then restarting the service in service.mcs worked fine. So it seemed that when I reboot windows I have one service atrributed to MusicIP running on port 10002 and then when I start the actual MusicIp GUI program then that runs a service at anoter port, I had it set to 10040 for example. Then if I follow the link http://localhost:10002 I get to a MusicIP page where I can see the number of songs and such, but when I go to the http://localhost:10040 page then I get to a page that just say Active service API (where API is a link) ..... so not sure what is going on with this. But it seems irrespective if I have SS set for port 10040 or 10002 I still don't connect to MusicIP and get any M icons. Sorry for the long winded explanation, but something doesn't seem right...

Zevs

Zevs
2007-02-01, 13:26
Hi Siduhe!

yes for sure I have that set, I always control that this checked, and never seems to have ahd any trouble with it uncheking itself.

Zevs

Siduhe
2007-02-01, 13:54
Hi again Ron!

I noticed something strange that I don't really understand. I tried to change the port values and realized I couldn't change the port in Music IP to 10002. The program said I needed to try another port. Using services.mcs I then looked at the MusicIP service and stopped that. Then I could change the port number in the program to 10002, and also then restarting the service in service.mcs worked fine. So it seemed that when I reboot windows I have one service atrributed to MusicIP running on port 10002 and then when I start the actual MusicIp GUI program then that runs a service at anoter port, I had it set to 10040 for example. Then if I follow the link http://localhost:10002 I get to a MusicIP page where I can see the number of songs and such, but when I go to the http://localhost:10040 page then I get to a page that just say Active service API (where API is a link) ..... so not sure what is going on with this. But it seems irrespective if I have SS set for port 10040 or 10002 I still don't connect to MusicIP and get any M icons. Sorry for the long winded explanation, but something doesn't seem right...

Zevs

Zevs, it seems to me from your last long post that you may have two versions of MusicIP running as a service - one headless and one with the GUI.

Couple of suggestions if you can bear it ?

Change your Slimserver MusicMagic port setting to whichever port you want the headless version to use. Save the change. Stop Slimserver (right click the Slimserver Icon and select stop Slimserver). Go into the Slimserver folder and delete the Cache file entirely.

Open up the user interface for MusicIP (not the headless webpage, double click the MIP icon). Stop the communication API in the user interface (File, Preferences, Services), click stop and make sure the API checkbox is unchecked.

Open a command window (Start, Run, cmd) and type [net stop "MusicIP Server"] [deleting the square brackets]

Open up the "mmm.ini" file in the MusicIP folder using a text editor. What does the line "port=" say ? Change it to whichever port you want MusicIP headless to use (same as the one you gave to Slimserver, save file, close.

Open a command window (Start, Run, cmd) and type [net start "MusicIP Server"] [deleting the square brackets]

Check you can access the API at http://localhost:10002/
Right click the Slimserver icon, start Slimserver. When it opens up, you should see it starting a completely fresh scan. It will only add the MM icons at the end of the scan, so you'll have to wait until it builds the Slimserver database first.

Let us know if any of this helps.

Ron Olsen
2007-02-01, 13:58
Hi again Ron!

I noticed something strange that I don't really understand. I tried to change the port values and realized I couldn't change the port in Music IP to 10002. The program said I needed to try another port. Using services.mcs I then looked at the MusicIP service and stopped that. Then I could change the port number in the program to 10002, and also then restarting the service in service.mcs worked fine. So it seemed that when I reboot windows I have one service atrributed to MusicIP running on port 10002 and then when I start the actual MusicIp GUI program then that runs a service at anoter port, I had it set to 10040 for example. Then if I follow the link http://localhost:10002 I get to a MusicIP page where I can see the number of songs and such, but when I go to the http://localhost:10040 page then I get to a page that just say Active service API (where API is a link) ..... so not sure what is going on with this. But it seems irrespective if I have SS set for port 10040 or 10002 I still don't connect to MusicIP and get any M icons. Sorry for the long winded explanation, but something doesn't seem right...

Zevs

Just make sure that SlimServer and MusicIP are set for the same port; use 10002 if you can. If you can't use 10002 for some reason, try 10040. Make sure there are no other services on your machine using that port. I don't run Windows, so I can't help you with that.

Run the "Test Connection" button at the bottom of the MusicIP http://localhost:10002|10040 page to make sure the connection is OK.

Zevs
2007-02-01, 21:41
Thanks Siduhe for the detailed and clear instructions!!

I went through them and SS is now rescanning the library. The only thing that surpised me a bit was that the icon for SS disappeared from the tray as soon as the scan started. It is for sure scanning though! Will let you know the result when ready, will take several hours though I suspect.

Zevs

Zevs
2007-02-02, 09:16
Thanks Siduhe!!

You solved the problem! After re-scanning the library there the MM icons are again!! I guess it was some conflict due to the two MusicIP services running at the same time. So the lesson is don't try to run MusicIP in headless mode as well as running the API from the MusicIP GUI!

Thanks so very much Siduhe and Ron for all help!!!

Zevs

Siduhe
2007-02-02, 11:39
Zevs,

Glad to hear it's working for you.

ezkcdude
2007-02-21, 20:53
I read this thread after attempting to install 6.5.X for what will probably be the last time for me. I still can't get MusicIP (used to be MusicMagic) to work. I had it working with 6.3, and tried several months ago to upgrade to 6.5. I never got it to work then, but I thought time would heal all the problems. It hasn't. I'm still unable to get this stuff to work. Oh, well. Back to 6.3.

fairyliquidizer
2007-02-22, 14:08
I vaguely remember having a problem when I upgraded. As MusicIP is a new process name I think I had the old one set up to run in the the MMM.ini file or something like that. Double check your ini file settings and Service settings. I fixed the problem quite easily. Sorry my recollection is so vague.

Fairy

hdarwen
2007-02-22, 14:16
I read this thread after attempting to install 6.5.X for what will probably be the last time for me. I still can't get MusicIP (used to be MusicMagic) to work. I had it working with 6.3, and tried several months ago to upgrade to 6.5. I never got it to work then, but I thought time would heal all the problems. It hasn't. I'm still unable to get this stuff to work. Oh, well. Back to 6.3.

I have MIP 1.7 working with SS 6.5.1 on Win XP. Though I can't say it was easy. I don't run the headless mode, but this is what I had to do to get it working:

Select "Use Music Magic"
Clear the Music Folder path in Slim (when it was set it caused havoc with library info, even though it pointed to the same location as MIP)
Don't start Slim at startup
Manually start MIP first on boot
Manually start Slim once MIP has stopped scanning for new stuff
If the library has changed since last time (or if it's your first time), do a clear library and rescan everything

That worked for me anyway. If MIP starts scanning new stuff while it's running with Slim though, all bets are off.

Thx.

ezkcdude
2007-02-22, 17:12
I have MIP 1.7 working with SS 6.5.1 on Win XP. Though I can't say it was easy. I don't run the headless mode, but this is what I had to do to get it working:

Select "Use Music Magic"
Clear the Music Folder path in Slim (when it was set it caused havoc with library info, even though it pointed to the same location as MIP)
Don't start Slim at startup
Manually start MIP first on boot
Manually start Slim once MIP has stopped scanning for new stuff
If the library has changed since last time (or if it's your first time), do a clear library and rescan everything

That worked for me anyway. If MIP starts scanning new stuff while it's running with Slim though, all bets are off.

Thx.

Do you have the "MM" icons appear in SlimServer? That's what I can't get to work. I can send mixes made in MusicIP to SS, so that's what I've been doing as a workaround. I'd like to run MusicIP headless, though, as I was with SS 6.3. I'll try your suggestions. Thanks.

hdarwen
2007-02-22, 18:16
Do you have the "MM" icons appear in SlimServer? That's what I can't get to work. I can send mixes made in MusicIP to SS, so that's what I've been doing as a workaround. I'd like to run MusicIP headless, though, as I was with SS 6.3. I'll try your suggestions. Thanks.

I have the MM icons.

From memory I had to rescan/restart a few times. Plus, you need to start MM first, and make sure it's not analyising before you start Slim. Suggest you try setting use MM first in Slim, and clear the music folder location in the server settings to nothing. Then don't worry about getting it to work this time, just close Slim, close MM, and restart your PC. When it boots again, start MM, let it settle down, then start Slim. Go to server settings and do a clear library and rescan everything. Then don't touch it until it's finished.

You have to be a little persistent I recall. It should be easier, but it's not.

Ta.

h.

bchesterman
2007-05-05, 11:57
OK. I think I've cracked this now. It shows MM icons every time I boot my XP machine.

I've done the following:
1. Edited the registry using regedit to add the 'MusicIP Server' dependency:
Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\slimsvc\
Value Name: DependOnService
Value Type: REG_MULTI_SZ
Value Data: MusicIP Server

2. Just to be safe I edited the service using control panel -> Services and ensured the 'MusicIP Server' was running 'Automatically' every time I boot.

3. I changed slimserver to 'Automatically run at LOGON' instead of 'system start' (by right clicking on the system tray icon after I'd stopped it).

Hope this helps