PDA

View Full Version : SB2 Error with FLAC: Connection unable to work



elo
2007-01-31, 09:33
What The Heck!?

My SB2 has worked great for years. Now, with a spanking new server It won't directly decode FLAC streams. The weirdest part, is that it worked for about an hour. Then decided to stop working. I contacted support@slimdevices, got a response from logitech-customer-support. I have active communication with them, but I figured I'd ping the forum. Go to what you know, I guess. Does anyone have a suggestion?

Symptoms:

- When asked to play a FLAC file, I get the "connection unable to work" error on the SB2's screen, then it goes to "stopped" mode.

- Connecting to Squeeze networks works fine.

- Configuring via the Web GUI for Rate limit makes the problem go away.

- Streaming FLACs to Softsqueeze work as expected, fantastically.

- The only debug flag that produces a hint of a problem is the d_directstream flag. Output below.

- I've tried Factory reset and confirmed the MAC address reported on the sticker is the same as reported in the "current settings" stanza.

- I've "rpm -e" the slimserver package, and reinstalled... didn't help.

Do I have busted HW?

Further details:

Player FW: 72
Using Wireless with WPA.

[elo@eloslimserver slimserver]$ ls
SlimServer_v6.5.1.noarch.rpm

[root@eloslimserver elo]# uname -a
Linux eloslimserver 2.6.19-1.2895.fc6 #1 SMP Wed Jan 10
19:28:18 EST 2007 i686 i686 i386 GNU/Linux

[root@eloslimserver elo]# /sbin/service slimserver status
slimserver.pl (pid 3856) is running...
[root@eloslimserver elo]# ps -ef | grep 3856
501 3856 1 3 07:31 ? 00:00:01 /usr/bin/perl -w /usr/local/slimserver/slimserver.pl --daemon - --prefsfile=/etc/slimserver.conf --logfile=/tmp/slimserver.log 501 3858 3856 0 07:31 ? 00:00:00
/usr/local/slimserver/Bin/i386-linux/mysqld
- --defaults-file=/usr/local/slimserver/Cache/my.cnf
root 3914 3660 0 07:32 pts/2 00:00:00 grep 3856


From /tmp/slimserver.log when I hit play:

2007-01-28 07:59:48.3215 processing headers for direct streaming:
HTTP/1.0 200 OK
Date: Sun, 28 Jan 2007 15:59:48 GMT
Server: SlimServer (6.5.1 - 11206)
Connection: close
Content-Type: audio/mpeg
Set-Cookie: SlimServer-player=00%3A04%3A20%3A05%3Abc%3Af6; path=/;
expires=Mon, 28-Jan-2008 15:59:48 GMT

2007-01-28 07:59:48.4507 Oh, well failed to do a direct stream for: [Connection is no longer able to work]
2007-01-28 07:59:48.4510 Backtrace:

frame 0: Slim::Player::Source::errorOpening
(/usr/local/slimserver/Slim/Player/Squeezebox2.pm line 579)
frame 1: Slim::Player::Squeezebox2::failedDirectStream
(/usr/local/slimserver/Slim/Networking/Slimproto.pm line 527)
frame 2: Slim::Networking::Slimproto::_disco_handler
(/usr/local/slimserver/Slim/Networking/Slimproto.pm line 387)
frame 3: Slim::Networking::Slimproto::client_readable
(/usr/local/slimserver/Slim/Networking/Select.pm line 238)
frame 4: (eval) (/usr/local/slimserver/Slim/Networking/Select.pm
line 238)
frame 5: Slim::Networking::Select::select
(/usr/local/slimserver/slimserver.pl line 492)
frame 6: main::idle (/usr/local/slimserver/slimserver.pl line 445)
frame 7: main::main (/usr/local/slimserver/slimserver.pl line 1071)

ceejay
2007-01-31, 11:33
Wireless interference? That would explain why you can play low-rate internet radio and bit-rate limited streams, but not FLAC.

What happens if you try it in wired mode?

In wireless, try changing the channel on your wireless router.

HTH
Ceejay.

elo
2007-01-31, 11:40
I'll give it a try.

The softsqueeze client that has no problem playing the FLACs is on the same SSID. But I think it's worth a try... Will try later tonight.

Thanks for the idea.