View Full Version : SB3 will not work with Belkin wireless ethernet bridge

2007-01-29, 15:57
Help! Has anyone successfully networked their SB3 with a Belkin F5D7330 wireless ethernet bridge?

I bought two wired versions of the SB3, because the house had CAT6 throughout. Now having moved house, one of these SB3 had to be made wireless, hence the bridge. (or, if someone wants to buy the used wired model ...)

I cannot get these two boxes to talk to one another, in order to allow the SB3 to connect through the bridge to the network. I read a post on another forum that there was a trick to the Belkin settings, but it did not elaborate and I cannot find that post in order to ask for more detail.

I am using a BT Home Hub modem/router updated with firmware
The Belkin firmware is also updated to 1.00.09
SB3 is updated to firmware version 72.

The SB3 will connect to the router successfully through a direct ethernet connection (either static or DHCP addressing).

The bridge connects wirelessly to the router using WPA-PSK security - no problems pinging it and getting the configuration screen. Again, either static or DHCP - no difference. (Curiously, the MAC addresses for both the WLAN and LAN adapter components show up on the router.)

I can plug a laptop (with its wireless network card disabled) into the bridge and it connects to the network fine - the bridge no longer shows up independently on the router - the router only sees what is plugged into the bridge.

So, the bridge appears to do its job, but ...

Now, try plugging the SB3 into the bridge, and -- nothing. SB3 cannot find network for DHCP; try static IP for SB3, cannot ping it, etc.

Tried messing around with MAC address of the SB3 but no luck.

Could be that the router does nto like this combination of device and bridge - I will try a different brand although I am not hopeful.

Any ideas anyone? Would be fantastic if this could work as it seems it should, otherwise left with expensive pieces of kit that are no use to me.

Very grateful for any help.


Mark Lanctot
2007-01-30, 09:39
I would think that such a device would have auto-switching ports, and I'm not sure what type is required in this situation, but perhaps you're using the wrong cable (ordinary patch where crossover is required or vice-versa).

You can tell if you're using the wrong cable if the bridge has port lights. If you use the wrong type of cable they won't light up indicating not even basic electrical continuity.

So try swapping cables and swapping cable types.

OTOH, the wired models were recently discontinued. You would probably get almost what you paid for it if you sold it. If you return the wireless bridge and sell the wired version for almost what you paid for it, you could get a wireless Squeezebox...

2007-01-30, 12:27
Thanks the reply Mark.

Yes, I thought of the cross-over/patch cable. I have tried other cables, will track down a cross-over. The laptop connected OK though with a patch cable(it might have auto-switching already). The ethernet light on the bridge shows connectivity with the SB3 plugged into it, so I suspect that this is not the issue.

Unless anyone has had success, I think the best thing is to take offers on the SB3 as you suggest ...