PDA

View Full Version : How to stop auto firmware update after 6.5.1?



tonyptony
2007-01-27, 10:05
I just installed 6.5.1. It all went fine, but I want to continue to use the firmware vesion that was already installed on my SB3. How do I tell Slimserver to stop alerting me to install the latest firmware?

seanadams
2007-01-27, 10:37
I want to continue to use the firmware vesion that was already installed on my SB3.

The firmware and the server software are closely coupled, so it is strongly recommended not to try running an older rev of the firmware with a new version of the server. Why would you want to anyway?

tyler_durden
2007-01-27, 11:42
I know why this happens, at least on my machine.

I dual boot between windoze and Linux. The Linux server is updated to 6.5.1, but the windoze server is still 6.5.0.

When I change OS, the server tells me that the firmware in the player needs to be updated.

The problem is solved by getting both server installs to the same version. In Linux I get a notification that a new version is available, so I DL and install it. Under windoze, you don't get the notification (is there some way to do this?) so unless you check periodically, you don't know there is a new version.

Of course, when I DL and install the Linux version I should know there's a new windoze version too, but since I'm booted into Linux, I don't bother to DL the windows version, and I forget the next time I boot into windoze until the SB3 reminds me by displaying the cryptic "firmware needs to be updated" message.

TD

tonyptony
2007-01-27, 12:26
Well, I edited the squeezebox2.version file and fixed the problem.

Marc Sherman
2007-01-27, 12:56
tonyptony wrote:
> Well, I edited the squeezebox2.version file and fixed the problem.

No, you really didn't. What you did was silenced the alert about the
problem. Running the wrong firmware will cause you problems in the long run.

- Marc

tonyptony
2007-01-28, 06:37
Perhaps, but not yet. When it does I'll use the SB FW Selector tool to install the one that works best for me.

Mark Lanctot
2007-01-29, 11:34
Under windoze, you don't get the notification (is there some way to do this?) so unless you check periodically, you don't know there is a new version.

Home - Server Settings - Behavior - Software Updates (4th item).

Meatwad650
2007-01-29, 13:11
Just out of curiosity, what is your reason for wanting to keep running the old firmware? Is there a removed feature you're trying to keep around or a buggy feature you're trying to avoid?