View Full Version : bitrate limiting for streaming players

Philip Meyer
2007-01-26, 02:51
It's been a little while since I tried to play music across the web using a remote streaming player.

I pointed Windows Media Player 11 at my home slimserver http://<my IP address>:9000/stream.mp3.

I then logged into the WebUI, located the player, gave it a decent name, and turned on bitrate limiting to 128kbps (+lame quality 5).

I stopped and restarted the WMP stream, and music started to play. WMP reported the bitrate as 256kbps though, which was the original music file encoding.

I tried changing my url to: http://<my IP address>:9000/stream.mp3?bitrate=128 and ?bitrate=128kbps (I seem to recall that the bitrate limiting feature could be overriden in the url query string, but I couldn't find any documentation for the format of this parameter). However, WMP still reported 256kbps.

I wondered if WMP was just reporting an incorrect bitrate for some reason, so I tried to play another song. I added a lower quality mp3 track to the playlist and pressed play on the track. The first track continued to stream, even though the webUI was indicating that the second track was now playing. I guess there's some buffering going on with the stream - is it not possible to clear the buffer and start playback of the second track immediately? I achieved this by stopping and restarting the player and the stream. The stream then reported the correct bitrate.

So it seems that the bitrate limit (when set through the WebUI player settings) does not immediately take. The stream bitrate override (?bitrate=) doesn't seem to work anymore either, unless I got the format wrong.

Incidentally, new stream players seems to have Repeat=ALL by default. Is that configurable?

I thought of a neat solution to make this process easier for newcomers. When connecting a new remote stream player to slimserver, Slimserver could detect this and automatically start streaming a configurable song/playlist. By defauly this could be configured to play a low-quality mp3 track that has some audible instructions on how to configure the web UI and how to queue up music for the stream.

Therefore, when a user wants to stream into a remote player, all they would need to be told is the url. They would instantly hear something, and know that it was working, and would hear instructions for how to select some music to play and limit the music bitrate.


2007-01-26, 03:27
Does that happen for every track, or are you repeating your tests using the same track?

Were the mp3s encoded using CBR, ABR, or VBR?

2007-01-26, 08:59
Is it related to this bug? http://bugs.slimdevices.com/show_bug.cgi?id=4266.

See also this thread from way back: http://forums.slimdevices.com/showthread.php?t=27996

It seems that the bit limiting no longer works as it used to in 6.3.1

Philip Meyer
2007-01-26, 14:15
>Does that happen for every track, or are you repeating your tests using
>the same track?
>Were the mp3s encoded using CBR, ABR, or VBR?
I tried again today.

I've now tried several different tracks, encoded in different ways. I've tried 128kbps tracks, 250kbps tracks (CBR) and VBR trakcs. I've also tried FLAC tracks.

If I set bitrate limiting to 128kbps via player settings, it seems to always stream everything at 250kbps.

I tried setting bitrate limiting via the querystring stream.mp3?bitrate=128, and WMP reported streaming at 96kbps.

Today, I heard absolutely nothing. No errors, WMP said buffering, and got to 100% and started playing for all types of music that I selected to stream, but all I got was silence.

Potentially there may be a problem due to bandwidth, but I'd expect to see problems maintaining the buffer, timeouts, etc. The fact that WMP reports a different bitrate to what I requested tends to suggest that remote streaming is broken in 6.5.1.


Philip Meyer
2007-01-26, 14:16
>Is it related to this bug?
>See also this thread from way back:
I don't think so - that appears to be to do with trying to stream internet music remotely. I can't get it to stream local music (from my library) remotely.

>It seems that the bit limiting no longer works as it used to in 6.3.1


Philip Meyer
2007-01-26, 14:30
I noticed that a change was added to 6.5.2 today for mp3 streaming. Is this likely to fix my issue too?