PDA

View Full Version : No audio from Squeezebox



Jason
2003-12-24, 23:15
You might want to load up ethereal and run a sniff and see what is leaving
your server as far as network traffic goes.

It's possible you have a hardware problem, but from my experience with the
slim and squeeze and the numerous people who have them it is highly unlikely
that is the trouble.

Do you have a PC that you can run on the network from the server to play an
audio stream remotely for testing purposes?

-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of Jason Dixon
Sent: Wednesday, December 24, 2003 11:10 PM
To: Slim Devices Discussion
Subject: [slim] No audio from Squeezebox

On Thu, 2003-12-25 at 01:06, Jason wrote:
> Are you running IP Chains, AKA a firewall on the server? It could be
> killing the remote audio stream.

The server is running iptables. I've allowed tcp:3483 and
udp:3483/1069, per the FAQ.

--
Jason Dixon, RHCE
DixonGroup Consulting
http://www.dixongroup.net

Jason Dixon
2003-12-24, 23:20
On Thu, 2003-12-25 at 01:15, Jason wrote:
> You might want to load up ethereal and run a sniff and see what is leaving
> your server as far as network traffic goes.

I've already dumped it with tcpdump and verified plenty of traffic
to/from ports 9000 and 3483 and the Squeezebox. A 5 second sample
(tcpdump -ni wlan0 host <squeezebox_address>) resulted in ~500 packets.

> It's possible you have a hardware problem, but from my experience with the
> slim and squeeze and the numerous people who have them it is highly unlikely
> that is the trouble.

My guess isn't that it's a manufacturing defect, but a shipping issue.

> Do you have a PC that you can run on the network from the server to play an
> audio stream remotely for testing purposes?

Yeah, I'll test from the wife's WinXP box in the morning. Time for
Santa to get some sleep. I'll report back my results.


Thanks,

--
Jason Dixon, RHCE
DixonGroup Consulting
http://www.dixongroup.net

Jason Dixon
2003-12-25, 11:24
On Thu, 2003-12-25 at 01:15, Jason wrote:

> Do you have a PC that you can run on the network from the server to play an
> audio stream remotely for testing purposes?

In order to avoid any weirdness on my wireless laptop, I've moved the
slimserver on to a Red Hat 8.0 server. I can listen to the audio from
other hosts, just not the squeezebox. At this point, I have the
following setup:

Red Hat 8.0 server
Slimserver 5.0.1
10/100 to 3com switch
192.168.0.10

Linksys WAP11
SSID, no WEP

Squeezebox
Firmware rev. 5
192.168.0.54

I can listen to the server with xmms or mplayer from my RH9 wireless
laptop. I can see traffic from the squeezebox to the server (and vice
versa). I can modify the playlist via the squeezebox remote or web
browser to the server. Everything appears to be working correctly, I'm
simply not getting any audio from the squeezebox.

--
Jason Dixon, RHCE
DixonGroup Consulting
http://www.dixongroup.net