PDA

View Full Version : 6.5.1 refresh



cpd
2007-01-20, 20:48
Just upgraded to 6.5.1, and have two problems/questions.

1 - my refresh is set at 30 seconds. But, it doesn't seem to be completing the refresh. Instead, I hear three quick clicks (same as when you click on a web link or click back), and nothing changes. Even during scanning (I read somewhere about a scanning progress status that was added, but I'm not seeing it). I'm running avast antivirus, and I do notice that icon becomes active during the refresh. Any suggestions?

2 - I cleared and rescanned my library, and now every artist that begins with "the" AND every artist/folder in my library that comes alphabetically after those that begin with "the" is being skipped. For example, "the allman brother band" is the first artist not to show up. But neither is Tom Waits, or Wilco. I'm not a complete idiot (I hope), I know artists that begin with "the" don't all show under the letter "T." Regardless, they're not showing up at all, even if I search my music. And they used to before I installed 6.5.1 and cleared and rescanned.

Help?

mherger
2007-01-21, 00:37
> during scanning (I read somewhere about a scanning progress status that
> was added, but I'm not seeing it).

That will be available in the future, but _not_ in 6.5.

> I'm running avast antivirus, and I
> do notice that icon becomes active during the refresh. Any
> suggestions?

Turn off its script blocker, web shield etc. which might block javascripts
and/or cookies.

--

Michael

-----------------------------------------------------------------
http://www.herger.net/SlimCD - your SlimServer on a CD
http://www.herger.net/slim - AlbumReview, Biography, MusicInfoSCR

davep
2007-01-21, 03:10
2 - I cleared and rescanned my library, and now every artist that begins with "the" AND every artist/folder in my library that comes alphabetically after those that begin with "the" is being skipped. For example, "the allman brother band" is the first artist not to show up. But neither is Tom Waits, or Wilco. I'm not a complete idiot (I hope), I know artists that begin with "the" don't all show under the letter "T." Regardless, they're not showing up at all, even if I search my music. And they used to before I installed 6.5.1 and cleared and rescanned.

Help?

Just check that you have "The" in the box under ARTICLES TO IGNORE WHEN SORTING on the Behaviour Settings page of SlimServer.

davep

cpd
2007-01-21, 12:21
> during scanning (I read somewhere about a scanning progress status that
> was added, but I'm not seeing it).

That will be available in the future, but _not_ in 6.5.

> I'm running avast antivirus, and I
> do notice that icon becomes active during the refresh. Any
> suggestions?

Turn off its script blocker, web shield etc. which might block javascripts
and/or cookies.

--

Michael

-----------------------------------------------------------------
http://www.herger.net/SlimCD - your SlimServer on a CD
http://www.herger.net/slim - AlbumReview, Biography, MusicInfoSCR


Thanks for the help. But, it'd be nice not have to disable antivirus whenever I'm running slimserver. Do you know what slimserver is doing during the refresh, and maybe I can "allow" that behavior in avast antivirus?

cpd
2007-01-21, 12:25
Just check that you have "The" in the box under ARTICLES TO IGNORE WHEN SORTING on the Behaviour Settings page of SlimServer.

davep

Thanks. But, if I DO include "the" in the ARTICLES TO IGNORE WHEN SORTING, the music scanning COMPLETELY skips all artists starting with "the" AND everything after them. They don't show up anywhere at all. If I delete "the" from the ARTICLES TO IGNORE WHEN SORTING box, everything scans (which is nice), but obviously it now sorts by "the" which isn't how I'd like it.

This didn't happen with 6.5.0. Any other thoughts?

Thanks!

ceejay
2007-01-21, 15:54
Thanks. But, if I DO include "the" in the ARTICLES TO IGNORE WHEN SORTING, the music scanning COMPLETELY skips all artists starting with "the" AND everything after them. They don't show up anywhere at all. If I delete "the" from the ARTICLES TO IGNORE WHEN SORTING box, everything scans (which is nice), but obviously it now sorts by "the" which isn't how I'd like it.

This didn't happen with 6.5.0. Any other thoughts?

Thanks!

Very odd - I'm not seeing that in my 6.5.1.

What OS are you using? What types of files?

Ceejay

cpd
2007-01-21, 19:47
running WinXP, sp2, all audio files are flac files. some stored on external, some on main CPU (via shortcuts folder on external).

I just re-installed 6.5.0 and everything works perfectly, then tried 6.5.1 again and the problem returns. odd

ceejay
2007-01-22, 01:01
If you feel like investigating (it probably won't get fixed unless you do, since it isn't obviously reproducible) you might want to try setting up a small test library with just a few albums in it and then scanning with some debug logging turned on and see if you can spot anything in the logs).

Ceejay

cpd
2007-01-22, 21:39
... and then scanning with some debug logging turned on and see if you can spot anything in the logs).

Ceejay

Where can I find some instructions on how to do that? I'm a newbie, sorry.

Also, as I test I dropped copies of about 4 of the artists beginning with "t" into a second music folder on my laptop drive that I was already using as additional storage (it was already shortcutted to from the main external HD folder I use), rescanned to see what would happen, and it picked up ALL the "t"s, AND the ones alphabetically after "t", AND the original "t"s that were being skipped in the first place! So I got some duplicates, plus everything that came alphabetically after "t" that was being skipped. Then I deleted the copies of the "t" artists on my laptop, rescanned, and once again it skipped the external HD "t"s and everything after them. So strange.

ceejay
2007-01-23, 01:13
No need to apologise for being a newbie, especially in a beginners forum!

In the web interface, go to Server Settings / Debugging. Tick a box or two - start with d_scan . Unfortunately there isn't AFAIK a useful list of what all the options do, and there probably never will be as this is one of the areas that is being reworked for 7.0.

To see the log file click the understated "here" link in the para at the top of that page.

HTH

Ceejay

stephenkca
2007-01-23, 06:58
I don't think the articles are being ignored for me (I'm on the road and can't look until I get back in a couple days) but the 6.5.1 official has messed up sort order for me as well. In my case, the ARTISTSORT tags are being ignored almost without exception.

Here's a link to the thread on that topic:

http://forums.slimdevices.com/showthread.php?t=31867