View Full Version : Fast Forwarding not working. Ideas?

2007-01-16, 14:39
I use iTunes and have all my tracks ripped using the Apple Lossless format and from what I understand I cannot use the Fast Forward or Rewind functionality with that format.

However, even if I rip tracks in AIFF or WAV formats, the Fast Forward and Rewind functions still aren't working for me with tracks in those formats either...

Any suggestions?

SlimServer 6.5.0 on WindowsXP
iTunes 7

2007-01-16, 16:45
Probably because in Server settings/file types the server is set to transcode both of those types to FLAC, which would stop ff/RW working. Uncheck the boxes for AIFF to FLAC and WAV to FLAC.


2007-01-16, 18:35
Thanks ceejay. I think I'm confused as to what is really going on there with those settings ... why is the same format selected multiple times? How does the SlimServer then decide which one to use? Aren't we just telling SlimServer which format to convert the file TO before it is streamed to the SqueezeBox?

2007-01-17, 01:57
Because the various player types have different capabilities, and you might have more than one connected to your server.

Each player type has a set priority order - for an SB3 for example FLAC is top of the list - so that's what SS will send it if allowed. An SB1 however can't play FLAC so has a different first choice.

So for a given input type, the server looks down the player's priority list and serves up the first one that it finds which is allowed in the configuration table.


2007-01-17, 09:55
Thanks ceejay, unchecking AIFF -> FLAC did the trick. It didn't FF or REW very smoothly and so I've decided it really isn't a high priority, so I think I'll just stick with Apple Lossless with no FF/REW ability.

Just to experiment, I also unchecked Apple Lossless -> FLAC to see what would happen and as expected FF and REW still didn't work with Apple Lossless files but there was also a noticable "pop" between tracks.

So I've returned everything back to the way it was and all is well again. Life is full of compromises!

Thanks again.