View Full Version : Slim.exe crashes

2007-01-16, 13:21
Hi All

There was another thread (http://forums.slimdevices.com/showthread.php?t=28032&) that seems to begin to address this issue but then gets lost amongst other issues that are raised within the same thread. So was going to start a new thread in the hope that there is a resolution to the issue!

I received my squeezbox 3 shortly before xmass and have been very pleased with it. However sometime last week Slimserver would just stop. You would then restart it and 15 minutes later again it would just stop.

By executing slim.exe at the command prompt the following error message appears at the time of the crash:
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\WINDOWS>"C:\Program Files\SlimServer\server\slim.exe"
2007-01-16 20:13:39.2173 UPnP: Read search result failed: recvfailed: Unknown error at /PerlApp/Slim/Networking/UPnP/ControlPoint.pm line 106.

2007-01-16 20:13:40.9546 Terminating on signal SIGALRM(14)


However, if I start slim.exe at the command prompt using "slim.exe --noupnp" then the problem disappears.

My system information is:

SlimServer Version: 6.5.1 - 11196 - Windows XP - EN - cp1252
Server IP address:
Perl Version: 5.8.8 MSWin32-x86-multi-thread
MySQL Version: 5.0.22-community-nt

The problem began while I had 6.5.0 installed. Iíve tried re-installing it (fresh) and installing 6.5.1.

I have not made any changes to my PC at all in recent weeks however, and this may be a coincidence, I changed the file name of some MP3s and then went and played them on SB3 without re-indexing them in slimserver. Once I realised what I had done I then re-scanned the folder. That is the only thing out of the norm I can think of that happened around the time the problem appeared.

Is there a solution out there? Besides having to manually start slim at the cmd prompt!


Mark Lanctot
2007-01-17, 15:15
Do you have SlimServer running as a service or through SlimTray?

If you have it running as a service I believe there's a way to specify startup parameters. However on mine the dialog box indicates the startup parameters are only used when the service is started from the Services dialog box. Also I see a path but it's not editable.

2007-01-17, 16:20
Hi Mark

Yes, initially/by default it is via SlimTray when I log into XP, however it crashes after about 15 minutes. If I then right click ST and select 'start slimserver' it will restart but again crashes after about 15 minutes or so.

I've tried going into services.msc and manually entering the --noupnp into the SlimServer service but, as you say, it is only valid from that dialogue box and you cant edit the path.

hmmm... I might PM the person in the other thread and see if (s)he found a resolution.