View Full Version : Can't downgrade from 6.5.1 to 6.5.0

2007-01-11, 10:15
After having problems with 6.5.1 I have been trying to downgrade to 6.5.0. Although I am able then to run slimserver 6.5.0, as soon as I turn on my SB3 it causes ss to crash, and so does not give me the option of downgrading the firmware. I have tried doing a factory reset, but that does not help.

2007-01-11, 11:41
You probably need to delete the contents of the database when going backwards (and possibly other files too.)

Try deleting the contents of the directory "Cache" under Program Files\SlimSever\server and restarting the server.

2007-01-11, 13:43
Have now done a complete uninstall before re-installing 6.5.0. It worked but is a pain as have to enter all the config changes made over time.

2007-01-11, 15:03
Oops, you threw out the baby with the bathwater. You only needed to delete the database, ie, the files under "Cache", like triode suggested. But anyway, for future reference you can make a backup of your slimserver.pref (might be slimserver.conf on some systems) and keep it when you change versions. In fact, it's a good idea to make a backup whenever upgrading, just in case something goes wrong.

2007-01-13, 11:05
Actually, deleting the cache (ie everything uder server\Cache) did not help. I just tried again, and this time, even though I had not bothered to upgrade the firmware, when I backed out to 6.5.0, as soon as the SB3 tried to connect SS crashed. I again had to a complete uninstall and re-install of 6.5.0. There is something odd with the current nightly build me thinks.

But your advice to keep a copy of the slimserver.pref proved useful.