View Full Version : Initial Slim Server "starting" problems

2007-01-09, 18:11
I'm having issues with my initial setup of my SliMP3. The slimserver is in a constant state of "starting" and I can't access it via the browser.

I've checked and have no firewalls/antivirus/antispy on, and
I ran the netstat and nothing is on 9000, and
I can ping my slimp3 fine,

When I run "slim" from the command prompt, I get this:

C:\Program Files\SlimServer\server>slim
2007-01-07 21:49:47.5781 Warning: Migrating from 6.3.x used with MySQL!
2007-01-07 21:49:47.6815 Database error: Can't create table '.\slimserver\metain
formation.frm' (errno: 121) at /PerlApp/DBIx/Migration.pm line 115.
2007-01-07 21:49:47.6828 ERROR: forceCommit: Trying to commit transactions befor
e DB is initialized!

Any idea what my problem might be?


Ross L
2007-01-09, 19:53
Maybe try this:

- click start
- click run, type CMD and hit enter
- in the dos promt, type : "C:\Program Files\SlimServer\server\slim.exe" -remove
NOTE: type in everything after type in:, including the quotes!
- type in: "C:\Program Files\SlimServer\server\slim.exe" -install
- hit enter, and reboot

2007-01-10, 18:47
Thanks Ross.

I get this result (regardless whether slim.exe is running or not):

C:\>"C:\Program Files\SlimServer\server\slim.exe" -remove
OpenService failed: The specified service does not exist as an installed service

C:\>"C:\Program Files\SlimServer\server\slim.exe" -install
slimsvc installed as SlimServer.

Rebooting in a few minutes (have some files copying) to see if that fixed it.

2007-01-10, 19:15
That didn't fix it (didn't think so after the -remove command line response).

Still in the "starting" stage...

Any other suggestions?

2007-01-10, 19:48
Seems this is old hat. I was looking in the wrong forum.

An uninstall, then a reinstall fixed it. Thanks.