PDA

View Full Version : SlimServer Process Crash



scnewton
2007-01-09, 15:02
Not really a crash, more like it just stops - apparently at random. I'm trying to run:
SlimServer Version: 6.5.0 - 9916 - Windows XP - EN - cp1252
Server IP address: 192.168.2.105
Perl Version: 5.8.7 MSWin32-x86-multi-thread
MySQL Version: 5.0.22-community-nt
on a Sony VAIO Media Center PC - dual core, 1GB RAM.

It runs fine for a while, then the process just stops. In Windows System Event Viewer I get an Error entry with Event ID 7034. Following the link out to Windows XP support, the webiste helpfully points out that 7034 is an Event Crash event.

I tried the sc query slimsvc command suggested, and get
SERVICE_NAME: slimsvc
TYPE : 10 WIN32_OWN_PROCESS
STATE : 4 RUNNING
(STOPPABLE,PAUSABLE,ACCEPTS_SHUTDOWN)
WIN32_EXIT_CODE : 0 (0x0)
SERVICE_EXIT_CODE : 0 (0x0)
CHECKPOINT : 0x0
WAIT_HINT : 0x0

Not sure what any of that means...

Any help is appreciated.

Thanks,
SCN

scnewton
2007-01-09, 15:14
The previous results from sc query were from when the process was running. Once it crashed again, I got these results:

SERVICE_NAME: slimsvc
TYPE : 10 WIN32_OWN_PROCESS
STATE : 1 STOPPED
(NOT_STOPPABLE,NOT_PAUSABLE,IGNORES_SHUTDOWN)
WIN32_EXIT_CODE : 1067 (0x42b)
SERVICE_EXIT_CODE : 0 (0x0)
CHECKPOINT : 0x0
WAIT_HINT : 0x0

kdf
2007-01-09, 16:12
Quoting scnewton <scnewton.2k5yeb1168380301 (AT) no-mx (DOT) forums.slimdevices.com>:

>
> Not really a crash, more like it just stops - apparently at random. I'm
> trying to run:
> SlimServer Version: 6.5.0 - 9916 - Windows XP - EN - cp1252
> Server IP address: 192.168.2.105
> Perl Version: 5.8.7 MSWin32-x86-multi-thread
> MySQL Version: 5.0.22-community-nt
> on a Sony VAIO Media Center PC - dual core, 1GB RAM.
>
> It runs fine for a while, then the process just stops. In Windows
> System Event Viewer I get an Error entry with Event ID 7034.

What is the message in the event viewer? It will usually explain what
caused the crash. If you are running a virus scanner, you'll need to
tell it to ignore *.MYI and *.MYD files. This is a common cause of
server stoppage, as mysql and scanners don't seem to get along.
-kdf

Diana
2007-01-09, 16:17
...I'm trying to run:
SlimServer Version: 6.5.0 - 9916 - Windows XP - EN - cp1252

Looks like you're running the basic 6.5.0 from the download page; try installing the most recent nightly update at

http://www.slimdevices.com/downloads/nightly/latest/6.5/

You'll need to download and run the 'Windows Executable' installation file.

scnewton
2007-01-09, 17:36
Not getting much from Event Viewer. Source: Service Control Manager. Category: None. Type: Error. Event ID: 7034. Date, Time, User and Computer. That's it.

I did not have those file types set up as exclusions, have done that now - waiting to see if it'll crash again.
Thanks!


Quoting scnewton <scnewton.2k5yeb1168380301 (AT) no-mx (DOT) forums.slimdevices.com>:

>
> Not really a crash, more like it just stops - apparently at random. I'm
> trying to run:
> SlimServer Version: 6.5.0 - 9916 - Windows XP - EN - cp1252
> Server IP address: 192.168.2.105
> Perl Version: 5.8.7 MSWin32-x86-multi-thread
> MySQL Version: 5.0.22-community-nt
> on a Sony VAIO Media Center PC - dual core, 1GB RAM.
>
> It runs fine for a while, then the process just stops. In Windows
> System Event Viewer I get an Error entry with Event ID 7034.

What is the message in the event viewer? It will usually explain what
caused the crash. If you are running a virus scanner, you'll need to
tell it to ignore *.MYI and *.MYD files. This is a common cause of
server stoppage, as mysql and scanners don't seem to get along.
-kdf

scnewton
2007-01-09, 17:38
I'm going to see if the NAV exclusions work, first. If not, I'll branch out into the nightly builds. Thanks!

Looks like you're running the basic 6.5.0 from the download page; try installing the most recent nightly update at

http://www.slimdevices.com/downloads/nightly/latest/6.5/

You'll need to download and run the 'Windows Executable' installation file.

scnewton
2007-01-10, 19:23
Have disabled Norton auto-protect and Norton Internet security altogether. Still crashes.
Installed the latest nightly build. Still crashes.
Thought some device (like disk array) might be powering down, but have all of those settings set to Never turn off.
Have also tried setting all the server debug flags, but can't find the log file after process goes down and starts back up - http://localhost:9000/log.txt is blank when the server comes back... any way to make that data persistent? Any other troubleshooting ideas?
Thanks!!