PDA

View Full Version : Ogg streaming



Steve Pawsey-Bowerman
2003-12-22, 15:58
Hi,

I've decided to venture into ogg territory. I've installed all the required
libs and vorbis tools 1.0 (tried 1.0.1 but failed miserably - scanning the
archives, there seems to be issues).

I've managed to get ogg files to replay through my squeezebox OK, but can't
seem to get them working thru my slimp3 or through http streaming. I also
can't get ICECast's to work either (on the any client, even the squeezebox).
Trying the following ICECast

Virgin Radio

[playlist]
numberofentries=3
File1=http://ogg.smgradio.com/vr96.ogg
Length1=-1
File2=http://ogg.smgradio.com/vr32.ogg
Length2=-1
File3=http://www.smgradio.com/core/audio/mp3/problems.mp3
Length3=-1
Version=2


I usually manage to debug things with top, since if the ogg -> mp3
transcoding was occurring then I'd see a "oggdec" and "lame" process in top.

My convert.conf is relatively unchanged from the default:

ogg mp3 * *
$oggdec$ -Q -o - -R 1 $FILE$ | $lame$ --silent -q 9 -b 320 -r - -

I tend to use the -q 9 param in lame because without it my server gets
absolutely hammered. I've also tried the about with $BITRATE$ and a hard
coded value (just a hunch).

Also FYI, my slimserver startup command string is:

slimserver.pl --daemon --d_parse --d_server --d_source --d_stdio --d_command
--d_display --d_files --d_info --prefsfile .slimp3.pref 2> slimserver.log &

There doesn't appear to be anything helpful in the log file (I'm sure there
are some more --d_ commands I should be adding)

Help

TIA

Steve