PDA

View Full Version : Odd search/browse behaviour



chris.mason
2007-01-05, 05:24
Apologies if this has been discussed before, but a cursory search through the forums didn't reveal anything.

I'm running SlimServer Version: 6.5.1 - 11039 - Windows XP - EN - cp1252.
I have my music collection all ripped to FLAC, and using MusicIP to look after the library.

Here's the problem.
I use the CustomBrowse plugin, and specifically the "Composers" browse option that is provided. I noticed that the list of composers was incomplete. I initially though this was a CustomBrowse issue but I don't believe it is. I have a number of classical music albums from specific composers, and a number of compilation albums. It seems as if all the composers that are not from compilation albums are listed, and one or two that are only from compilations are also listed. I've checked my tags, and they are all completely consistent.
All the classical music as Artist populated and Composer populated with the same data (just to make sure).

To confirm my belief that this isn't a custom browse issue, I used the Search facility in Slim UI. I search for Vivaldi for example, and three albums are listed, but not the compilation album that Vivaldi appears on. However, if I use Advanced Search and search by Artist, every track by Vivaldi from all the albums, including compilations is listed.

Note that Search returns Artists, Albums and Song Titles that match while Advanced Search returns individual tracks.

There's something wrong with the way Search is working - has anybody else seen this? Is this another "Various Artist/Compilation Album" problem?

Any help/thoughts appreciated.

Chris.

ModelCitizen
2007-01-05, 05:45
This is something I've meaning to post about for a while (although I am sure it has been mentioned before, but if so I can't find it either).

It appears to me that the normal SlimServer search cannot find a track listed as part of a compilation when you perform a search on artist name. However, it does find it when you search for the track title. The advanced search works fine on both artist and track name.

I imagine this might be linked somehow to the fact that SlimServer does not list the artist's name when showing all artists if the track is listed as part of a compilation (not even under the various artists section, where by default it lists album names and not artists names). If there is a setting I can change so all artists are listed under the SlimServer artist listing I'd like to know what it is.

This on a 6.5.1 nightly from about 10 days ago on XP, using Fishbone Tan skin.

MC

erland
2007-01-05, 07:12
Just for information in case someone that knows the details of the database see this, the SQL that Custom Browse runs to the retreive the composers are:


select contributors.id,contributors.name,substr(contribut ors.namesort,1,1) from contributors,contributor_album
where
contributor_album.contributor=contributors.id and
contributor_album.role in (2)
group by contributors.id
order by contributors.namesort asc


I had a strange behaviour earlier on my developer machine where contributor_album contained to few rows for a compilation album, but I had experimented a bit with tags on the flac files for the compilation album, so that might have caused the problem I had. The problem disappeared when I replaced the filed with the original flac files from the production machine.

Does anyone know if contributor_album is supposed to contain all contributors available in the contributor_track table for the same album ?

JJZolx
2007-01-05, 23:19
Note that Search returns Artists, Albums and Song Titles that match while Advanced Search returns individual tracks.

There's something wrong with the way Search is working - has anybody else seen this? Is this another "Various Artist/Compilation Album" problem?

The basic Search (the non-Advanced Search) searches for the string that you enter in

1. Artist names
2. Album titles
3. Track titles

It really is a "basic" search. All it's doing is string matching within those items, then listing the items matched. It won't find the composer and then list all the albums or tracks by that composer. If you search for 'vivaldi' then it will list only albums and tracks that have the string 'vivaldi' in the title.

But if you find Vivaldi (and listed in the search under Artists), clicking on the name should list all of the albums credited to the composer, so albums are just one additional click away.

(Note that for the basic Search to find composers, you'll also need to have 'Composer' checked off under Server Settings > Behavior > COMPOSER, BAND AND ORCHESTRA IN ARTISTS.)


BTW, in looking at this I notice that my library has just one album tagged with a composer. It's "The Jerome Kern Songbook", with Jerome Kern as composer on all tracks. If I search for 'kern', then Jerome Kern is found, and if I click the name, the album is shown. But I notice that under Browse Artists, Jerome Kern is nowhere to be found. If you have the server setting mentioned above checked off, are your classical composers listed along with the artists on your system?

chris.mason
2007-01-06, 03:07
Ah, of course you are right, the simple search does return tracks - I wasn't thinking clearly, for some reason assuming "song titles" were different from "tracks"...

However, the problem still remains, but I don't think I've explained the issue clearly.

If I search for "Vivaldi" using the simple search, I get one artist retrieved, no albums and no song titles. This is correct. If I click on the returned artist ("Antonio Vivaldi"), three "Albums" are listed. However, these are not the only three albums that Vivaldi appears on. There is another which happens to be a compilation album.

If I search on Artist using Advanced Search, *all* the tracks from *all* the albums are in returned, i.e. including the compilation album tracks.

And just to re-iterate, all my tracks have Artist populated - in the case of my classical music, the artist is the composer, but I have also populated the composer tag, as a duplicate of the artist tag, just to make sure...!

Jim, In answer to your question, I get the same behaviour whether I have the Composers behaviour switched on or off. When I browse by artist, I see all the composers that don't have compilation albums, as they are listed under Various Artists. This is because as mentioned above, the Artist tag is populated as composer as well. Hope I'm not confusing everyone...!

Chris.