PDA

View Full Version : SlimServer won't start - Port conflict?



ejm1385
2007-01-03, 07:21
After using SlimServer for 9 months, it suddently won't start automatically or manually. Just keeps saying "Starting SlimServer"....... Thought it may be a McAfee conflict since i just installed Total Protection 2007, but after disabling all the protections, it still won't start. Tried uninstalling and reinstalling; tried v6.2, v6.3 and v6.5 and nothing. Reading posts, it seems maybe I have a port 9000 conflict.

Can someome please assist by explaining how to set up SlimServer to open with another port - 9080 perhaps? I haven't figured out how to set this up. Thanks!

ceejay
2007-01-03, 09:45
The answer is actually in the other thread you posted this question to! From a command prompt, start slimserver with the command line option "--httpport" using say "--httpport 9080"

Ceejay

ejm1385
2007-01-03, 10:37
Sorry - but I think I need a little more hand holding here. From command prompt, what are the steps to "start slimserver with the command line option "--httpport 9080." Thanks for your help!

ceejay
2007-01-03, 12:45
First stop the server if its already running. Then open a command prompt window:

cd \Program Files\Slimserver\server
slim --httpport:9080


Or you can try "slim --help" to see a list of al lthe options in case you are interested.

This might not be your long term solution but will help you see if it is your problem. Don't forget to access the server from your browser with the new port, eg "http://localhost:9080"

HTH
Ceejay

ejm1385
2007-01-03, 19:59
Thanks for bearing with me. I followed your steps and got Slimserver to open through my browser. My Squeezebox is now connected and reads my music, and indicates what is playing, but there is no sound. Tried all the volume adjustments, but it is silent. Please help.

ceejay
2007-01-04, 02:31
Thanks for bearing with me. I followed your steps and got Slimserver to open through my browser. My Squeezebox is now connected and reads my music, and indicates what is playing, but there is no sound. Tried all the volume adjustments, but it is silent. Please help.

first try turning on one of the visualisers (eg analog VU meters) to check that the SB thinks it should be playing something!

then check your connections to the amplifier (what have you got and how is it connected?)

You might also try plugging some headphones into the headphone socket...

HTH
Ceejay

ejm1385
2007-01-04, 04:00
Seems to think it is playing something. At one point after running CMD prompt and then opening SLimServer through the new port on my browser, I actually got it to play. But once I stopped it, it never came back. Tells me the connections are fine.

Also, to open SLimServer via the new port on my browser, I seem to have to have CMD prompt running to open the new port. What a pain.

JeremyJGreen
2007-01-07, 01:03
Another way appears to be to change the parameter in: D:\Program Files\SlimServer\server\slimserver.pref

Change httpport: 9000 --> new port of your choice

peter
2007-01-07, 01:32
ejm1385 wrote:
> Seems to think it is playing something. At one point after running CMD
> prompt and then opening SLimServer through the new port on my browser,
> I actually got it to play. But once I stopped it, it never came back.
> Tells me the connections are fine.
>
> Also, to open SLimServer via the new port on my browser, I seem to have
> to have CMD prompt running to open the new port. What a pain.
>


Why don't you first try to figure out what's using port 9000 at the
moment. I wouldn't be too surprised if it was another instance of
slimserver. It's not very likely that some other process would grab
precisely that port.

Start > Run > cmd.exe [enter]
netstat -b -v [enter]

Most aggro is caused by stuff calling itself 'Total Protection', perhaps
it's impossible to switch it off.

Regards,
Peter

shawnharper
2007-01-07, 23:32
*** my response was moved to a new post here ***

http://forums.slimdevices.com/showthread.php?p=168774#post168774


Thanks,
-Shawn