PDA

View Full Version : Q:Playlists updated but..music won't play!



mmg_fan
2006-12-26, 17:08
I'm having some issue in getting updated playlists to play properly
ie, after rescanning, slimserver (or the player) will only play the first song in a new playlist (if at all)no matter which song in that playlist I choose.

In the server all the playlists and song lists appear correct..any new music I add simply won't play.

Is this simply because the server's scanning of the changed/updated itunes playlist is incomplete or hasn't updated fully?

When there is a message 'The server is now rescanning your Music Library.' how does one know how long it will take??

I'm using the Max software on OSX to do the rip/conversions to Apple lossless.

Diana
2006-12-27, 01:01
There have been a number of threads about scanning problems due to playlist issues and tagging issues - try a search.

Like you, I've had problems with the scan for new/changed music (because scanner.exe itself does not terminate on my system for reasons that remain unidentified even after much discussion with Slimdevices support).

My solution - and the procedure routinely adopted by many, I understand - is only ever to use clear and rescan. What happens when you use that?

As for a progress monitor - there isn't one. And like me you may find that the web interface never updates to tell you the scan is finished (even when it has!).

My solution for this - on my Win XP system - is as follows:

# Start the 'Clear/rescan'
# open the Task Manager (Ctrl+Alt+Del, and click the Task Manager button)
# open the Processes tab, and click 'Image Name' to sort the column alphabetically
# scroll down to scanner.exe - the value of its CPU activity in the CPU column will be changing, and the CPU % at the bottom of the window will rise (can reach between 50% and 100%)
# After a while (15-20 mins for 3500 tracks on my system) scanner.exe will finish and disappear from the Task Manager list - but the scan process is not finished yet! (CPU usage remains elevated.)
# The two process, mysqld.exe and slim.exe become active - shown by the changing numbers in their 'CPU' column values, and by the sustained CPU usage at the bottom of the Task Manager screen.
# Eventually, the CPU values for mysqld.exe and slim.exe will return to and stay at 00, and the CPU usage will drop back to 2%-4% (assuming you're not simultaneously running other programs).
# If you now close Task Manager, and refresh the SlimServer web page (just click 'Home', or press Ctrl+f5) your library statistics will be displayed.

I don't know whether there's an equivalent Mac method - can you use Applications/Utilities/Activity Monitor to do something similar? I hope you can, 'cos otherwise, if your interface isn't just reporting the end of a scan by displaying the library stats, I don't think there's any way of knowing when the scan has finished (unless you become skillfull in knowing how the sound of your hard drives changes during the two phases of a rescan and when it ends! Perhaps the Audiophiles are particularly good at this!)

I post what I do with WinXP in the hope that it may help other Win users who have reported issues with monitoring scan progress.

But, guys, isn't this a ridiculous way to have to monitor scan progress? Does anyone have a better way? And I know that scanning and screen updating may work fine for some people on some platforms - but that doesn't help those of us for whom it doesn't :(

Very best wishes

mmg_fan
2006-12-27, 20:47
yes..it should be a feature of the software.

A simple progress bar would do the trick

I'm on a mac but I believe entering'top' in the terminal window will do the trick

Still haven't solved my problem...I see the new playlists and new songs but the new songs won't play!!

Siduhe
2006-12-27, 21:30
Still haven't solved my problem...I see the new playlists and new songs but the new songs won't play!!

I'm guessing your music is on a network attached drive ? If so, the issue with playlists via Itunes on a NAS is known and not (officially) supported by Slim.

However, the unofficial workaround is about halfway down this thread from SD SUPPORT:

http://forums.slimdevices.com/showthread.php?t=29823&highlight=itunes+playlist