PDA

View Full Version : why does browse_playlist.html load when edit_playlist.html should?



bklaas
2006-12-14, 09:58
I'm trying to fix Bug 4512 (http://bugs.slimdevices.com/show_bug.cgi?id=4512), and I'm experiencing some weird behavior in both Nokia770 and Touch skins.

On the playlist.html, the link for saving a playlist is this:
<a href="edit_playlist.html?player=[% playerURI %]&saveCurrentPlaylist=1">[% "SAVE" | string %]</a>

but when I go to edit_playlist.html, the page that gets rendered comes from browse_playlist.html. I can't for the life of me figure out why. I checked this in Default, and the link to edit_playlist.html loads edit_playlist.html as expected.

Anyone know what's up with that?

#!/ben

bklaas
2006-12-15, 13:37
(bump)

can anyone provide insight?

why would going to edit_playlist.html load the browse_playlist.html template and not edit_playlist.html?

#!/ben

kdf
2006-12-15, 13:50
Quoting bklaas <bklaas.2ivjsn1166215201 (AT) no-mx (DOT) forums.slimdevices.com>:

>
> (bump)
>
> can anyone provide insight?

I had answered you elsewhere:


Ben: I believe the browse_playlist use is due to the calls to the db
to get a tracklist for the playlist being edited, and it is a result
of the browsedb handling that the results go to browse_playlist.

see Slim::Web::Pages::EditPlaylist::saveCurrentPlaylis t (the last line
feeds to browse_db)

bklaas
2006-12-15, 15:45
Quoting bklaas <bklaas.2ivjsn1166215201 (AT) no-mx (DOT) forums.slimdevices.com>:

>
> (bump)
>
> can anyone provide insight?

I had answered you elsewhere:


where? on campfire? I went there first but left after waiting a half hour or so to see if anyone would respond to my question...my apologies if you are repeating yourself.



Ben: I believe the browse_playlist use is due to the calls to the db
to get a tracklist for the playlist being edited, and it is a result
of the browsedb handling that the results go to browse_playlist.

see Slim::Web::Pages::EditPlaylist::saveCurrentPlaylis t (the last line
feeds to browse_db)

I'll take a look, but I'm really confused why Default doesn't behave this way when the link to edit_playlist.html is exactly the same except for the target attribute Default uses to push the content to the other frame.

An href link to edit_playlist.html should get its data from the edit_playlist.html template, but it's coming from browse_playlist.html.

I don't even have a custom edit_playlist.html...should be pulling it from EN/, just like Default does.

#!/ben

kdf
2006-12-15, 16:48
Quoting bklaas <bklaas.2ivptb1166223001 (AT) no-mx (DOT) forums.slimdevices.com>:

> An href link to edit_playlist.html should get its data from the
> edit_playlist.html template, but it's coming from
> browse_playlist.html.

follow the code. the request (ie the url) is for edit_playlist.html,
but in those cases where the EditPlaylist modules passes the request
on to browsedb (as in saveCurrentPlaylist, the results are fed to the
browse_playlist.html file.

-kdf