PDA

View Full Version : Some OGGs playback with lots of static



jabster
2006-12-08, 08:42
Hi.

I'm having an occasional problem with my slimserver.

Some Q10 OGGs playback with a lot of static. It seems random, but one song that consistently plays back badly is Cartman's rendition of Come Sail Away. I ALWAYS get a lot of static on this song.

I don't think it's a problem with the file, as it plays back just fine thru amarok.

Any ideas? This is the only problem I'm having with it.

Server:
SlimServer Version: 6.5.0 - 9916 - Debian - EN - iso-8859-1
Server IP address: 192.168.100.2
Perl Version: 5.8.7 i486-linux-gnu-thread-multi
MySQL Version: 5.0.22-Debian_0ubuntu6.06.2
Ubuntu Dapper, fully updated

Player:
Player Firmware Version: 64
Hooked up wirelessly

thanks,
john

andyg
2006-12-08, 08:45
Can you file a bug and attach the problem file? I think we are very close to the CPU limit when decoding q10, although we did test some q10 files which worked fine, so as you said it may only happen with certain files.

Ben Sandee
2006-12-08, 08:54
On 12/8/06, jabster <jabster.2ii7gz1165592701 (AT) no-mx (DOT) forums.slimdevices.com>
wrote:
>
> I'm having an occasional problem with my slimserver.
>
> Some Q10 OGGs playback with a lot of static. It seems random, but one
> song that consistently plays back badly is Cartman's rendition of Come
> Sail Away. I ALWAYS get a lot of static on this song.
>
> I don't think it's a problem with the file, as it plays back just fine
> thru amarok.


Do you know which version of the ogg encoder you used? If you used any the
pre-1.0 versions then that is a known problem (unlikely to be fixed, I
suppose). I would try reencoding the CD (or track) with ogg of course.

Ben

jabster
2006-12-09, 12:06
Andy:
Bug created. #4576. Currently uploading Come Sail Away.

Ben:
All OGGs I have are definately post v1.0. And nearly all of them behave this way. And I can't reencode most of them as my Q10s are typically bought thru allofmp3.com. I rip all my CDs as FLAC.

Which leads to a question. Intuitively, shouldn't FLACs require more processing power then a Q10 ogg, as FLACs are lossless? FLACs all play back just fine.

-john

edit: actually, I'm assuming all oggs from allofmp3.com are newer than pre-v1.0. They're all from within the last year or so, so I think it's a good assumption.

radish
2006-12-09, 18:38
FLAC takes very little processor to decode, much less than Vorbis.