PDA

View Full Version : Chinese and other asian chars in SSODS



flipflip
2006-12-08, 03:28
Hello

I'm willing to try to fix the issue with chinese chars etc. in SSODS. But I need your help to do so.

We'll have to distinguish two things:

- Chinese chars in filenames and
- Chinese chars in the tags.

I'll focus on the second thing. Special chars in filenames might not be possible. I'm not sure.

I need the following things and answers to test:

A set of files with chinese names and chinese tags which must meet the following:

- filenames must show up correctly in windows explorer (on a chinese windows)
-> I need a screenshot of this window.

- show up correctly in SS and on the SB when using SS on windows.
-> I need screenshots of of the song details in the web interface.

- And the folloing answers:
- what does "SERVER INFO" (of the SS running in windows) say?
- how do the filenames look internal to the DS. Chech within telnet using a command like "cd /to/my/music/folder; ls -l > dirlist.txt". Attach this file.

And I need the mp3 files.

I'd appreciate if somebody can create a working (i.e. chars working correctly in SS and on the DS) set of files using SS on windows. The sound and the tags needn't match, you can take any freely available mp3 from the net and add a few tags. E.g.

And one more question (I didn't find it. Bloody search. Maybe somebody knows.):

How must the tags be encoded so they work with SS and the SB? UTF-8?

Regards,
flip

hkfriends
2006-12-09, 18:25
well done.

I hope have time to help. It is my wish to become true, cheers!

matt24
2006-12-10, 00:02
Hi Flipflip,

I'm willing to help. I've got lots of Chinese music which I play on my SB.

I use itunes to rip and encode, to apple lossless. However, in order for it to be discovered by SlimServer I needed to use Tag&Rename to rename them to very basic filenames (without chinese characters), then rename the folders (manually) since they also must not contain characters in order for the files to be discovered.

I can send you files with the raw filenames ex itunes, and with the modified filenames which are discoverable by slimserver.

I'm using english windows but have installed the support for east asian characters.

If you can work under these arrangments I'll be pleased to provide the files.

PS. I don't have a diskstation yet.

flipflip
2006-12-10, 07:52
Hello

Ok, hkfriends sent me many screenshots and some sample files. I think that's enough for the moment to test. I'll let you know if I need something more and i'll keep you up to date here.

I expect to have some time around christmas to check these things.

Regards,
flip

joe_wang2006
2006-12-10, 22:40
Dear flipflip, I had also spoken to engineer guys at Synology, and they are willing to support you on SSODS project. Let me know, if need my help here in Taiwan.

Joe Wang

WSLam
2006-12-11, 09:53
Looks like the other members from HK have already volunteered.
But if you need any more help, please count me in too!
Thanks in advance.

flipflip
2006-12-11, 10:24
Ok.

I tested it on a Linux PC (Debian) and the chars are displayed correctly in the web interface and on the (soft-)squeezebox. But the filenames containing Chinese chars are _not_ displayed correctly. Such filenames consisting only of Chinese chars are not displayed at all. Files starting with some "normal" chars (e.g. track number) are displayed with the Chinese chars stripped.

As said above, we have to distinguish these two things.

I reckon that it won't be possible to have chinese chars in the filenames. Can somebody confirm or object this?

And I am pretty sure that it will be possible to have Chinese chars in the tags with SSODS.

See: http://oinkzwurgl.org/downloads/ssods/pics/chinchars-bender.jpg

Regards,
flip

flipflip
2006-12-11, 14:27
Hmm.. something very strange happend:

The tags of hkfriend's mp3s showed up with wierd chars in mp3tag on my windoze. Okay, as expected. I have more or less the same display on the Squeezebox.

BUT:

After having installed (enabled) "Asian Chars Support" (or so) in "Regional Settings" (or so) in the control panel I can perfectly see the rights chars in mp3tag and in the Slimserver web interface (SSODS r2b9 which hasn't really changed since r2b3 or so)!!!

On hk's screenshots this didn't work! Why?! Damn.

And now to the real strange thing:

On the Squeezebox I can see the following for one of the files (while the webinterface shows nice chinese chars!):

Title = Tian Shui. Wei Cheng
Artist = Li Ke Qin
Band = Li Ke Qin
Album = Li Ke Qin Yan Zou Ting II

...which look pretty reasonable to me. I just wonder where the hell the SS has this information from.. I reckon that it is not in the file (checked with mp3tag and with "strings").

Any suggestions?

In the meantime I'll try to fix SSODS.. I have a guess who's the culprit (Perl, of course :-).

flip

flipflip
2006-12-11, 14:31
Here's a screenshot:

http://oinkzwurgl.org/downloads/ssods/pics/strange.jpg


And as said, before I had wierd chars on the Squeezebox/Softsqueeze and the web interface.

I'm puzzled.

hkfriends
2006-12-12, 06:20
look like someone from synology can help... from Joe Wang?
it is great if synology can help flipflip.

flipflip
2006-12-12, 08:19
hkfriend, what I tried to say/ask is this:

- Asian chars _do_work_ in the web interface with SSODS. Where it doesn't work it's probably a problem with windoze or the browser. And I don't know why this does not work in your installation (did you try Firefox?).

- Why do your mp3's with Chinese chars in the tags suddenly show up with latin tags on the SB? Are there some other tags present in the file which I don't see with mp3tag?

- It should be possible to see asian chars on the SB because that works on my slimserver installation on a Linux PC. I just have to find out why (or what is the difference between the installation on the pc and on the ds).

flip

WSLam
2006-12-12, 08:58
Here's a screenshot:

http://oinkzwurgl.org/downloads/ssods/pics/strange.jpg


And as said, before I had wierd chars on the Squeezebox/Softsqueeze and the web interface.

I'm puzzled.

who sent you the song? make sure it was properly tagged to begin with. many songs that are illegally downloaded are tagged with mixed GB and Big5 characters.

and imho, bad music. sorry you have to listen to that!

flipflip
2006-12-12, 09:48
who sent you the song? make sure it was properly tagged to begin with. many songs that are illegally downloaded are tagged with mixed GB and Big5 characters.


How could I know.. the symbols look all the same to me.. :)

Feel free to send me some correctly tagged files.


and imho, bad music. sorry you have to listen to that!

:-)

flip

flipflip
2006-12-12, 15:18
Ok, I understand now what "Li Ke Qin" etc. means. That must be the "latin" names of the Chinese symbols.

We're getting closer... obviously Slimserver knows how to read the symbols but not yet how to display.

Hmm.. maybe I'll try the forum search when I run out of ideas ;->

flip

hkfriends
2006-12-12, 16:44
It is strange...
the songs are ripped by me using "Easy CD-DA Extractor"
it should be tagged with utf8 and are filled by freedb

btw, I found that if click on "Album", I can see the chinese but not music folder.

flipflip, I'll send you another screen shot.

anyone has a good mp3 tagged please send to flipflip.


How could I know.. the symbols look all the same to me.. :)

Feel free to send me some correctly tagged files.



:-)

flip

flipflip
2006-12-12, 17:00
Ok, I think I found the culprit (actually me.. :-).

Download http://oinkzwurgl.org/downloads/ssods/pics/chinese-test.tar.gz and copy it to the public share. Then stop slimserver, then do the following in telnet (as admin or maybe root) and then start slimserver again:



cd /
tar -xzvf /volume1/public/chinese-test.tar.gz


I hope the above download contains all necessary files. Because here, it now works on the SB!

Good night,

flip

flipflip
2006-12-12, 17:02
The problem that chinese chars in the filenames are not displayed correctly is something completely different and can possibly not be solved without changes to the firmware (if at all).

Has anybody seen a Linux system able to display chinese chars in filenames without using special (utf-8 capable) terminals and fonts (I don't speak of KDE or so, I mean the vanilla linux console/shell)?

flip

hkfriends
2006-12-13, 04:25
Thanks flipflip.

I confirm "CODE2000.TTF" can be loaded after your patch files.
Now I can see the Chinese (in Windows & Squeezebox)
This is the first time I can see Chinese fonts through SSODS from Synology box.


Retrieving font data from font cache: /volume1/SSODS/var/cache/fontcache
0023: 2006-12-13 19:14:16.4867 Trying to load GD Library for TTF support: ok
0024: 2006-12-13 19:14:16.4905 Using TTF for Unicode on Player Display. Font: [/volume1/SlimServer/Graphics/CODE2000.TTF]



BTW, now only the problem is Chinese File Name file, only this cannot be displayed. I think it need firmware path to help. Since no Chinese can be seen in unix shell terminal.

Anyway Many Thanks to FlipFlip!!!



Ok, I think I found the culprit (actually me.. :-).

Download http://oinkzwurgl.org/downloads/ssods/pics/chinese-test.tar.gz and copy it to the public share. Then stop slimserver, then do the following in telnet (as admin or maybe root) and then start slimserver again:



cd /
tar -xzvf /volume1/public/chinese-test.tar.gz


I hope the above download contains all necessary files. Because here, it now works on the SB!

Good night,

flip

flipflip
2006-12-13, 04:50
I'll include this in the next release of SSODS (next weekend or so).

Regarding filnames: My guess is that slimserver does not get the right string because the filename is translated somehow while copying to the DS. I think if SS gets the correct bytes it would detect the string as utf8 encoded and would maybe render it using code2000.ttf. I'm not sure if SS does this "detection and rendering" only for the tags or also for filenames. But if it does it for filenames as well then the following could work:

Add a line

unix charset = UTF-8 (or maybe UTF8, i'm not sure)

or

unix charset = CP950

in the [global] section of the samba config file (/usr/syno/etc.defaults/smb.conf).

Then either reboot the diskstation or restart samba ("killall smbd" and then restart with "smbd") to activate the changes.

You'll have to rename the files already on the DS. These changes would only apply to new or newly named files.

This would be analogous to "unix charset = iso-8859-1" for accented latin characters. See README.ssods for details.


flip

hkfriends
2006-12-13, 06:48
just add the

unix charset = UTF8

but no luck


I'll include this in the next release of SSODS (next weekend or so).

Regarding filnames: My guess is that slimserver does not get the right string because the filename is translated somehow while copying to the DS. I think if SS gets the correct bytes it would detect the string as utf8 encoded and would maybe render it using code2000.ttf. I'm not sure if SS does this "detection and rendering" only for the tags or also for filenames. But if it does it for filenames as well then the following could work:

Add a line

unix charset = UTF-8 (or maybe UTF8, i'm not sure)

or

unix charset = CP950

in the [global] section of the samba config file (/usr/syno/etc.defaults/smb.conf).

Then either reboot the diskstation or restart samba ("killall smbd" and then restart with "smbd") to activate the changes.

You'll have to rename the files already on the DS. These changes would only apply to new or newly named files.

This would be analogous to "unix charset = iso-8859-1" for accented latin characters. See README.ssods for details.


flip

flipflip
2006-12-13, 08:25
And with CP950? I think that is what your Windoze uses. I think they should match. And are you sure that samba has reloaded the new config? To be sure you need to reboot after the change.

hkfriends
2006-12-13, 08:59
but in Synology page, under Network | Win/Mac OS | Encoding = CP950...
so it is impossible to change it in smba conf file?



And with CP950? I think that is what your Windoze uses. I think they should match. And are you sure that samba has reloaded the new config? To be sure you need to reboot after the change.

flipflip
2006-12-13, 09:26
but in Synology page, under Network | Win/Mac OS | Encoding = CP950...
so it is impossible to change it in smba conf file?

Sorry, I don't understand what you try to say.

As far as I know this setting does not have any influence on samba behaviour. Actually I don't know what it is good for. At least I am pretty sure that it does not change anything in the samba config file. Maybe that is what it should do and maybe it works with the most recent firmwares. You could check this looking at the file /usr/syno/etc/smb.conf.

The changes I suggest have to be done manually directly in the template file for the samba configuration (hence "etc.defaults"). After you did that you _must_ reboot the ds so it re-creates the actual samba config file.

Well, this helped for latin accented characters which are not displayed correctly without this addition. Some claimed that the settings in the syno web interface would influence this but I have never been able to reproduce it. So I reckon that to be a rumour.

flip

flipflip
2006-12-13, 16:38
Ok, utf8 filnams is possible as follows:

1. Change smb.conf as said above.

I.e. edit /usr/syno/etc.defaults/smb.conf and add the line

unix charset=utf8

to the [global] section.


2. Modify /volume1/SlimServer/Slim/Utils/Unicode.pm

At around line 158 (SS 6.5.0):



# CJK Locales
$lc_ctype =~ s/eucjp/euc-jp/i;
$lc_ctype =~ s/ujis/euc-jp/i;
$lc_ctype =~ s/sjis/shiftjis/i;
$lc_ctype =~ s/euckr/euc-kr/i;
$lc_ctype =~ s/big5/big5-eten/i;
$lc_ctype =~ s/gb2312/euc-cn/i;
}


# ADD THIS LINE:
$lc_ctype = 'utf8';

# Setup suspects for Encode::Guess based on the locale - we might also
# want to use our own Language pref?
if ($lc_ctype ne 'utf8') {

Encode::Guess->add_suspects($lc_ctype);
}


This will somehow force SS into an utf8 locale even if the system does not really support it.

Then reboot the diskstation to activate the changes


Now Server Settings shows:



VERSION INFO

SlimServer Version: 6.5.0 - 9916 - Linux - EN - utf8
Server IP address: 192.168.1.10
Perl Version: 5.8.8 ppc-linux-thread-multi
MySQL Version: 4.1.15


Then you'll have to rename all your mp3 files..

As a proof, here's a screenshot (I just randomly copied&pasted some symobls):

2139


I thing the right way would be to have locales support on the DS so that we could say LC_ALL=en_US.UTF-8 or something and so SS would inherit this setting. On the other hand it would be nice to have a possibility to override this and force SS to use UTF8 for filenames. I don't know much about SS programming. But I am sure some folks around here do and may know how one could achieve this without patching Unicode.pm. Anyway, do it once and always remeber "never touch a running system".

Are there any further wishes from the East?

flip :-)

joe_wang2006
2006-12-13, 20:09
Dear flipflip,

I guess SS might pull those information from Internet such as FreeDB or similar CDDB, "Tian Shui" or "Wei Cheng" is sort of phonetic transcription against Chinese words, "天水" or "圍城". In most of case, the Chinese music tags contain Chinese only, which were encoded by either BIG5 or UTF-8/Unicode.

I can email you both UTF-8 and BIG5 encoded Chinese music filename for testing if needed.

Joe Wang

Note: I am trying Infrant's ReadyNAS NV+ now. Its latest firmware already includes the SS6.5.1, but cannot support Chinese until font pack plug-in is installed (same as Diskstation+SSODS, showing the same weird char on both tags and file names).

FontPack can be downloaded here, http://www.infrant.com/forum/viewtopic.php?t=3471





Hmm.. something very strange happend:

The tags of hkfriend's mp3s showed up with wierd chars in mp3tag on my windoze. Okay, as expected. I have more or less the same display on the Squeezebox.

BUT:

After having installed (enabled) "Asian Chars Support" (or so) in "Regional Settings" (or so) in the control panel I can perfectly see the rights chars in mp3tag and in the Slimserver web interface (SSODS r2b9 which hasn't really changed since r2b3 or so)!!!

On hk's screenshots this didn't work! Why?! Damn.

And now to the real strange thing:

On the Squeezebox I can see the following for one of the files (while the webinterface shows nice chinese chars!):

Title = Tian Shui. Wei Cheng
Artist = Li Ke Qin
Band = Li Ke Qin
Album = Li Ke Qin Yan Zou Ting II

...which look pretty reasonable to me. I just wonder where the hell the SS has this information from.. I reckon that it is not in the file (checked with mp3tag and with "strings").

Any suggestions?

In the meantime I'll try to fix SSODS.. I have a guess who's the culprit (Perl, of course :-).

flip

hkfriends
2006-12-13, 22:45
OK, I try this tonight


[QUOTE=flipflip;162220]Ok, utf8 filnams is possible as follows:

1. Change smb.conf as said above.

I.e. edit /usr/syno/etc.defaults/smb.conf and add the line

unix charset=utf8

to the [global] section.


2. Modify /volume1/SlimServer/Slim/Utils/Unicode.pm

At around line 158 (SS 6.5.0):



# CJK Locales
$lc_ctype =~ s/eucjp/euc-jp/i;
$lc_ctype =~ s/ujis/euc-jp/i;
$lc_ctype =~ s/sjis/shiftjis/i;
$lc_ctype =~ s/euckr/euc-kr/i;
$lc_ctype =~ s/big5/big5-eten/i;
$lc_ctype =~ s/gb2312/euc-cn/i;
}


# ADD THIS LINE:
$lc_ctype = 'utf8';

# Setup suspects for Encode::Guess based on the locale - we might also
# want to use our own Language pref?
if ($lc_ctype ne 'utf8') {

Encode::Guess->add_suspects($lc_ctype);
}

flipflip
2006-12-14, 05:48
I guess SS might pull those information from Internet such as FreeDB or similar CDDB, "Tian Shui" or "Wei Cheng" is sort of phonetic transcription against Chinese words, "天水" or "圍城".


Yes, that's right. But I think it is some Perl module which knows about these "transcriptions" (or whatever that is called).

What I did to add the support is adding a few libraries and perl modules, namely libfontconfig, libfreetype, libpng and libgd and the GD and GD::Text perl modules. Now Slimserver uses this to render the chinese chars as graphics using the included code2000.ttf font.



I can email you both UTF-8 and BIG5 encoded Chinese music filename for testing if needed.


Thanks, I think this is not necessary anymore. Synology will test my patches as well.



Note: I am trying Infrant's ReadyNAS NV+ now. Its latest firmware already includes the SS6.5.1, but cannot support Chinese until font pack plug-in is installed (same as Diskstation+SSODS, showing the same weird char on both tags and file names).
FontPack can be downloaded here, http://www.infrant.com/forum/viewtopic.php?t=3471

Hmm.. I downloaded it.. but does not seem to be a standard archive so i cannot see what files are inside. But basically the same should be possible with Infrant than it is with the DS (add the libraries and GD support to perl).

Regards,
flip

hkfriends
2006-12-14, 07:01
Everything look fine after modify the follwing codes
There is no need to re-create the filename, I can see Chinese even in folder level.

Many thanks to Flipflip !!!




Ok, utf8 filnams is possible as follows:

1. Change smb.conf as said above.

I.e. edit /usr/syno/etc.defaults/smb.conf and add the line

unix charset=utf8

to the [global] section.


2. Modify /volume1/SlimServer/Slim/Utils/Unicode.pm

At around line 158 (SS 6.5.0):



# CJK Locales
$lc_ctype =~ s/eucjp/euc-jp/i;
$lc_ctype =~ s/ujis/euc-jp/i;
$lc_ctype =~ s/sjis/shiftjis/i;
$lc_ctype =~ s/euckr/euc-kr/i;
$lc_ctype =~ s/big5/big5-eten/i;
$lc_ctype =~ s/gb2312/euc-cn/i;
}


# ADD THIS LINE:
$lc_ctype = 'utf8';

# Setup suspects for Encode::Guess based on the locale - we might also
# want to use our own Language pref?
if ($lc_ctype ne 'utf8') {

Encode::Guess->add_suspects($lc_ctype);
}

flipflip
2006-12-15, 03:11
hkfriends, can you please test it without the additional line in smb.conf. I just spoke to Synology and they claim that UTF-8 would be the default. They will try to add an UTF-8 locale to the system so we would not need to modify Unicode.pm.

Regards,
flip

flipflip
2006-12-15, 03:24
And I need an easy way to patch Unicode.pm as long as there is no utf-8 locale on the DS (they might add one sometimes).

Individual patches for individual versions of Unicode.pm might work.. i'll see what i can do.

Or does anyonw have any suggestions?

flip

hkfriends
2006-12-15, 07:21
Confirmed.

NO need to add UTF8 in smb.conf



hkfriends, can you please test it without the additional line in smb.conf. I just spoke to Synology and they claim that UTF-8 would be the default. They will try to add an UTF-8 locale to the system so we would not need to modify Unicode.pm.

Regards,
flip

joe_wang2006
2006-12-15, 20:23
Superb!!, as a end user, I just advised their engineers to jump in and fully support flipflip, otherwise most of potential customers or SB owner would consider Infrant rather than Synology.
Confirmed.

NO need to add UTF8 in smb.conf

hkfriends
2006-12-16, 06:40
yes, Synology should help flipflip to develop great enhancement on SSOD. So synology will be come a very great product.


Superb!!, as a end user, I just advised their engineers to jump in and fully support flipflip, otherwise most of potential customers or SB owner would consider Infrant rather than Synology.

flipflip
2006-12-17, 12:31
Hello

I uploaded a new release of SSODS (-> r2b10) which addes Unicode/UTF-8 support. There is a new "Tools" menu entry to patch Slimserver into UTF-8 mode.

Those who changed Unicode.pm should revert the changes before installing. Then use the "Unicode_enable" routine to patch the file again.

Regards,
flipflip

hkfriends
2006-12-18, 08:52
beside the revert of Unicode.pm, do I need to uninstall b9 + already patched for Chinese?
or simply install the b10 for the upgrade.


Hello

I uploaded a new release of SSODS (-> r2b10) which addes Unicode/UTF-8 support. There is a new "Tools" menu entry to patch Slimserver into UTF-8 mode.

Those who changed Unicode.pm should revert the changes before installing. Then use the "Unicode_enable" routine to patch the file again.

Regards,
flipflip

flipflip
2006-12-18, 08:59
No, just upgrading is okay (you'll keep the database and settings this way). You can also keep your patched Unicode.pm. The routine in SSODS patches is slightly different, but the result is the same.

flip

oldleesd
2007-02-05, 08:00
Dear flipflip,

I downloaded the latest version of SSODS and installed it onto a new CS406

I have enabled the unicode support using the tool menu
However, no luck for me. All chinese characters cannot be shown (neither the filename nor the tag)

What steps cld I have missed?

Hardware: a new CS406 (i.e. no previous version of SSODS installed)
slimserver 6.5.1
Internet explorer 6.0

Any suggestion?

thank you in advance.

oldleesd

hkfriends
2007-02-05, 08:21
Home / Server Settings / Basic Settings

Mine is:
SlimServer Version: 6.5.2 - 11345 - Linux - EN - utf8


I don't jave any problem on Chinese chars (even using synology built-in MySQL database set with UTF-8 Unicode)



you may also force to use --d_graphics parameter
0023: 2007-02-05 20:41:51.2781 Trying to load GD Library for TTF support: ok
0024: 2007-02-05 20:41:51.2809 Using TTF for Unicode on Player Display. Font: [/volume1/SlimServer/Graphics/arialuni.ttf]

flipflip
2007-02-05, 08:47
Did you restart Slimserver after enabling unicode support?
Try a reboot and complete rescan.

oldleesd
2007-02-05, 09:09
Thank for the prompt reply

rebooted and complete rescaned

still no luck

what else should I check?

flipflip
2007-02-05, 09:31
What does "Home / Server Settings / Basic Settings" say?

Do you see correct filenames in the Explorer?

oldleesd
2007-02-05, 16:20
SlimServer Version: 6.5.1 - 11206 - Linux - EN - utf8

Perl Version: 5.8.8 ppc-linux-thread-multi
MySQL Version: 4.1.15

Additional information:

The chinese character can be displayed neither in the IE nor the slimdevice interfaces.


Before I switch to CS406. I run the slimserver on a PC with internet explorer 6.0. All the chinese characters can be displayed properly.


many thanks again!

flipflip
2007-02-06, 02:16
I mean the Explorer, not the Internet Explorer. Like here:
http://oinkzwurgl.org/downloads/ssods/pics/chinese-filez.jpg

oldleesd
2007-02-06, 04:20
The characters are properly displayed in the explorer

flipflip
2007-02-06, 05:21
Hmm..

There are two independent problems:

1. Display on the Squeezebox:

Try this: Enable the d_graphics debugging option as hkfriends suggests, stop slimserver, empty the log file, start slimserver and post the logfile here.

2. Display in the web interface.

Try with Firefox. And within that force the encoding to UFT8 (menu View->Character Encoding->UTF8. IE might have a similar option.


A screenshot like mine above could hep too.

oldleesd
2007-02-06, 06:25
Log file says:

0001: 2007-02-06 21:17:13 **** rc.slimserver Starting SlimServer (please wait) ..
0002: 2007-02-06 21:17:35.3193 Use of uninitialized value in join or string at /volume1/SSODS/lib/perl5/5.8.8/File/Spec/Unix.pm line 81.
0003: 2007-02-06 21:17:35 **** rc.slimserver Start of SlimServer successful. Please wait until it has settled.
Reload log file Truncate log file

(-: flipflip's SSODS Release 2.13 :-)


I have forced IE to use the unicode for uncoding -- no luck
Run firefox 2.0 and enforce the coding as suggested -- no luck again

oldleesd
2007-02-06, 06:33
screen capture

oldleesd
2007-02-06, 06:36
larger picture

oldleesd
2007-02-06, 06:42
Still cannot post a bigger picture

anway the character in the slimserver windows is in a mess while those in the explorer display ok

flipflip
2007-02-06, 06:44
The screenshots are too small, I cannot see anything.

The logfile should show much more too. Wait some time after Slimserver has started and check the logfile again.

There must be someting like (as hkfriends said):

0023: 2007-02-05 20:41:51.2781 Trying to load GD Library for TTF support: ok
0024: 2007-02-05 20:41:51.2809 Using TTF for Unicode on Player Display. Font: [/volume1/SlimServer/Graphics/arialuni.ttf]
Reply With Quote


Did you enable d_graphics in Server Settings->Debugging (or so)?

flipflip
2007-02-06, 06:45
And do you have "Asian Char Support" enabled in Windows (Control Panel->Regional Settings, somewhere around there)?

oldleesd
2007-02-06, 06:51
I just checked again. still ony the three lines I have posted.

I will stop and restart slimserver and post the log again a bit later

I did turn on the enable d_graphics

I do have the Asian font support in windows

flipflip
2007-02-06, 06:56
Strange. The should be more..

Go to SSODS->Tools->Sysinfo. Post the complete text here using the code-style:
...text...

oldleesd
2007-02-06, 07:10
try the log again

still the three lines I posted

But I found that after I checked the d-graphics and click changed, the change seem to have applied.

but then after I restarted slimserver and goto the debug option. The d-graphics is not checked. is this normal?

The complete log is too log and the system does not allow me to post it

Which part shall I post?

flipflip
2007-02-06, 07:21
I don't know. I'd expect the debugging flags to be saved in the preferences file, but I am not sure.

Save the log to a text file and put that into a zip. You can then attach it here.

flipflip
2007-02-06, 07:22
..or mail it to me (see mail link on "flipflip" in SSODS at bottom right).

hkfriends
2007-02-06, 07:23
Yes, you should enable the debug option "--d_graphics"
see whether the slimserver is load GD Library for TTF support or not?

by default it will forced to use CODE2000.TTF, which can display chinese (I use arialuni.ttf for better display only)

You should wait for awhile and the log will be displayed.

OR you can hard-coded the --d_graphics in \\diskstation\SSODS\bin\rc.slimerver
I use UltraEdit to do the changes

Line 175:
perl ${SSBIN} --daemon --pidfile ${SSPIDFILE} --logfile ${SSLOG} --d_graphics \

oldleesd
2007-02-06, 07:34
Flipflip,

have sent you the log + screen capture


hkfriends,

how can I see .....
"see whether the slimserver is load GD Library for TTF support or not?"

hkfriends
2007-02-06, 07:45
In SSOD -> "Status" page, click "Show Log" button



Flipflip,

have sent you the log + screen capture


hkfriends,

how can I see .....
"see whether the slimserver is load GD Library for TTF support or not?"

oldleesd
2007-02-06, 07:51
I got the same three lines upon "show log" for no matter how long I wait

turn the d_graphics on and off does not change the three lines

hkfriends
2007-02-06, 07:56
you can hard-coded the --d_graphics in

\\diskstation\SSODS\bin\rc.slimerver

I use UltraEdit to do the changes

Line 175:
perl ${SSBIN} --daemon --pidfile ${SSPIDFILE} --logfile ${SSLOG} --d_graphics \


OR extract my attachment to your
\\diskstation\SSODS\bin\

stop your slimserver and overwrite this file, then re-start it again!!!



I got the same three lines upon "show log" for no matter how long I wait

turn the d_graphics on and off does not change the three lines

oldleesd
2007-02-06, 07:57
does the message

"Use of uninitialized value in join or string at /volume1/SSODS/lib/perl5/5.8.8/File/Spec/Unix.pm line 81"

in line two have any important meaning?

hkfriends
2007-02-06, 08:00
this is normal


does the message

"Use of uninitialized value in join or string at /volume1/SSODS/lib/perl5/5.8.8/File/Spec/Unix.pm line 81"

in line two have any important meaning?

oldleesd
2007-02-06, 08:00
Now I need to confess that I know nothing about Linix. Can I just modify the file as if it is a text file using the text editor of windows or I need to use a specialized tool such as ultraedit?

oldleesd
2007-02-06, 08:02
Oh sorry I see that you put an attachment. I will just use it

oldleesd
2007-02-06, 08:12
I loaded the file, now I get a long log

But I still cannot display the chinese character



The log is as follows,

0001: 2007-02-06 22:49:38 **** rc.slimserver Starting SlimServer (please wait) ..
0002: 2007-02-06 22:49:58.8724 Use of uninitialized value in join or string at /volume1/SSODS/lib/perl5/5.8.8/File/Spec/Unix.pm line 81.
0003: 2007-02-06 22:49:59 **** rc.slimserver Start of SlimServer successful. Please wait until it has settled.
0004: 2007-02-06 23:01:25 **** rc.slimserver Shutting down SlimServer (please wait).
0005: 2007-02-06 23:01:30 **** rc.slimserver SlimServer has been stopped successfully.
0006: 2007-02-06 23:03:11 **** rc.slimserver Starting SlimServer (please wait) ..
0007: 2007-02-06 23:03:31.1350 Use of uninitialized value in join or string at /volume1/SSODS/lib/perl5/5.8.8/File/Spec/Unix.pm line 81.
0008: 2007-02-06 23:03:31 **** rc.slimserver Start of SlimServer successful. Please wait until it has settled.
0009: 2007-02-06 23:03:42.2336 fontfile entry: blockanimateSB2.1.font.bmp
0010: 2007-02-06 23:03:42.2348 fontfile entry: blockanimateSBG.1.font.bmp
0011: 2007-02-06 23:03:42.2360 fontfile entry: full.2.font.bmp
0012: 2007-02-06 23:03:42.2371 fontfile entry: high.2.font.bmp
0013: 2007-02-06 23:03:42.2382 fontfile entry: huge.2.font.bmp
0014: 2007-02-06 23:03:42.2394 fontfile entry: large.2.font.bmp
0015: 2007-02-06 23:03:42.2405 fontfile entry: light.1.font.bmp
0016: 2007-02-06 23:03:42.2417 fontfile entry: light.2.font.bmp
0017: 2007-02-06 23:03:42.2428 fontfile entry: logo.font.bmp
0018: 2007-02-06 23:03:42.2441 fontfile entry: medium.1.font.bmp
0019: 2007-02-06 23:03:42.2452 fontfile entry: medium.2.font.bmp
0020: 2007-02-06 23:03:42.2464 fontfile entry: small.1.font.bmp
0021: 2007-02-06 23:03:42.2475 fontfile entry: small.2.font.bmp
0022: 2007-02-06 23:03:42.2488 fontfile entry: standard.1.font.bmp
0023: 2007-02-06 23:03:42.2499 fontfile entry: standard.2.font.bmp
0024: 2007-02-06 23:03:42.2510 fontfile entry: threeline.1.font.bmp
0025: 2007-02-06 23:03:42.2522 fontfile entry: threeline.2.font.bmp
0026: 2007-02-06 23:03:42.2534 fontfile entry: threeline.3.font.bmp
0027: 2007-02-06 23:03:42.2617 Retrieving font data from font cache: /volume1/SSODS/var/cache/fontcache
0028: 2007-02-06 23:03:42.3073 Trying to load GD Library for TTF support: ok
0029: 2007-02-06 23:03:42.3101 Using TTF for Unicode on Player Display. Font: [/volume1/SlimServer/Graphics/CODE2000.TTF]

oldleesd
2007-02-06, 08:18
Would it be possible that my mp3 file is just not right?

I ripp my CD using music match and I get the tag & filename from CDDB.

The tag information & folder etc do shown correctly when I run the slimserver on my PC.

hkfriends
2007-02-06, 08:21
can you see chinese in "Home / Music Folder /" ?

I can see "Chinese Character" directory / file Names

or you can try re-scan "clear and re-scan everything"


your IE, should be Encoding->Auto->UTF8

oldleesd
2007-02-06, 08:27
Oh Yes!

I can display the character correctly under "Home / Music Folder /"

all the filenames are properly displayed on the left hand panel


But then when I click "+" to add the song to the playlist.

All the tag information cannot be displayed properly on the playlist (right hand) panel

oldleesd
2007-02-06, 08:33
I can also display the correct character in the slimdevice under music folder

but the characters messed up again under any other items such as artist, album etc

Does it mean that the tag information in my MP3 file have some problem?

could anyone post a small sample file here such that everyone can use it as a standard reference?

hkfriends
2007-02-06, 08:33
that's mean your mp3 tag is not utf8

you need to change the tag to utf8 (id3v2 2.3 unicode-LE)

you can correct it by using convertz, there is a built in function to change all tags from files.
http://alf-li.pcdiscuss.com/



Oh Yes!

I can display the character correctly under "Home / Music Folder /"

all the filenames are properly displayed on the left hand panel


But then when I click "+" to add the song to the playlist.

All the tag information cannot be displayed properly on the playlist (right hand) panel

flipflip
2007-02-06, 08:36
I got the mail. Strange, there are indeed only three lines of log. Very unusual even with no debug flags set.

The screenshot tells me that the encoding of the filenames _seems_ to be utf-8 (good). I don't know why they're not displayed correctly.

I understand that you have some additional plugins installed (lazysearch, superdatetime).. maybe you should try with an unmodified Slimserver version wit hdefault settings. I don't know how a plugin could mess with these things, but one never knows.

I don't have any further ideas in the moment.

oldleesd
2007-02-06, 08:39
or you can try re-scan "clear and re-scan everything"


your IE, should be Encoding->Auto->UTF8


Both of the above do not change the situation

flipflip
2007-02-06, 08:49
The answers here got a bit disordered..

As said, there are two independent things going on:

1. Display of file/folder names in the web interface (left pane) and on the SB (browse music folder). I understand that this works now.

2. Display of tag information. This is independent from the filename, it's the file's content. Tags need to be encoded in utf8. Maybe you have them in an other format. It looks like the tool hkfriends suggests would convert them to the right format.

oldleesd
2007-02-06, 08:56
Downloaded the convetor and change the tag

everything is right now!!!!!

you guys here are great!!!


BTW a side issue: using IE, the view-->text size option does not let me change the size of the characters.

All the character are very small now, is there anything that I can do other than change my display resolution

flipflip
2007-02-06, 09:30
Good. I just wonder what was the actual solution to display the file and folder names correctly. A reboot?



BTW a side issue: using IE, the view-->text size option does not let me change the size of the characters.


In Firefox text scales fine using CTRL+MouseWheel. It also scales the Slimserver web interface, including Chinese chars. I reckon that (CTRL-Mousewheel) works in IE too.

Regards,
flip

oldleesd
2007-02-06, 09:42
One cause of the problme is that the Tags in my MP3 files were not of UTF-8 code. I do not know what code they were. But they can be display correctly with both explorer and slimserver run on a PC.

the ctl+wheel work beautifully in firefox. do not work for me in IE

thank you again flipflip!

hkfriends
2007-02-06, 20:12
hope this thread can help people to resolve this issue.

kbelinski
2007-04-25, 22:07
I am having the same problem in SS v6.5.1.2 on Infrant ReadyNAS NV+.

With SS running on Windows, both the web UI and SB could display the Chinese chars correctly. Now that I have switched to running SS on ReadyNAS NV+, the web UI display the chars correctly, but on the SB the Chars were phonetically translated to ASCII chars. What's up with this? Has anyone managed to resolved? Or it is a known issue of the SS on ReadyNAS?

BTW. All my tags are in cuesheet named CDImage.cue. Cue sheet with Chinese tags are saved in UTF-8 format.

DreamYA
2007-07-01, 07:50
Thanks Flipflip,You are so great!

As follow you advice,I can display chinese filename in SS on my FreeNAS!!!

Thanks again!

DreamYA
2007-07-04, 08:39
It is find that when I set the language to simplified chinese in my slimserver by web UI,everything display in the web is just find,buy when I connect to the slimserver by my SB3,the character display in the SBplayer were phonetically translated to ASCII chars just like Kbelinski said.

At the same time,when I connect to the slimnetwork in SB3,Everything is OK,the character display correct.What a strange!!!

My Slimserver base on the FreeNAS(which is developed from FreeBSD):

This is my server's information:

SlimServer revison : 6.5.2 - 12047 - freebsd - ZH_CN - utf8
Server IP address: 192.168.1.250
Perl revison : 5.8.8 i386-freebsd-64int
MySQLr revison : 5.0.33