PDA

View Full Version : 12/1 version skipping the ends of songs



wduncan
2006-12-02, 13:05
I upgraded to the current nightly release last night and it fixed some issues but introduced a bad new one: on 75% of the songs, slimserver (or the device firmware - the behavoir is the same on all devices) skips the last 1-15 seconds of the song and goes on to the next song.

Is it possibly some parameter setting?

Thanks,

Bill

DMR NYC
2006-12-03, 06:32
I have had a SQ3 for about a month and have had the same problem w 6.5.1. Are you using Itunes? I was recording in Apple Lossless format and tried to see whether I was having the same problem in Itunes. I was. Yesterday I discovered that if I unchecked the "crossfade" option in Itunes' playback preferences, the songs will play properly in Itunes.

There is still a quirk in the SD software, though, because now there is no gap in the playback of these recordings over the Squeezebox.

Any further word or suggestions welcome.

M3Rocket
2006-12-06, 13:11
I upgraded to the current nightly release last night and it fixed some issues but introduced a bad new one: on 75% of the songs, slimserver (or the device firmware - the behavoir is the same on all devices) skips the last 1-15 seconds of the song and goes on to the next song.

Is it possibly some parameter setting?

Thanks,

Bill

Please vote for this bug: http://bugs.slimdevices.com/show_bug.cgi?id=4384

There has been no response from the developers on this problem!

wduncan
2006-12-06, 15:03
First, DMR: Great idea. I DID have crossfade set in iTunes and, having unchecked it, I'm now having slimserver rebuild it's db, but I'll bet anything your right and that will be it. It'll take awhile to rebuild this 60 gig db, but I'll post my results when I try it.

And M3Rocket: Thanks. That's it for sure. I had been corresponding with support but responses have stopped for the last several days. At least it's clear that they must know about it.

Actually, a quick glance at the forum suggests that others ("stuttering crossfade") are figuring out the same thing.

Thanks...

wduncan
2006-12-06, 16:14
Having upgraded to the 12/6 version of slimserver and unchecked crossfade in iTunes, the system still skips the last 8-10 seconds of all songs.

But the behavoir is different now: the skip used to vary between 5 and 15 seconds. And it starts the next song immediately instead of leaving a gap.

Makes the system useless. Guess the only choice is to go back to an earlier version.

M3Rocket
2006-12-06, 17:10
Makes the system useless. Guess the only choice is to go back to an earlier version.

I have two SB3's at home, but I use SoftSqueeze at work the most. And this has essentially made everything since 6.5.1 b10207 useless for me! We're now at b10879 and nearly two months later, and still not even a peep from the developers.

It doesn't sound like this "fix" is going to make 6.5.1.

Wirrunna
2006-12-06, 18:51
I too rip to Apple Lossless and use SlimServer 6.5.1 SlimServer_6.5_v2006-12-03 and it doesn't skip the last few seconds.
I have never used crossfade in iTunes though. Maybe that affects the rip.

DMR NYC
2006-12-06, 21:28
In my case, it fixed the problem in Itunes, and I had assumed that the problem would be resolved with my SB3. I still am having difficulties, although not as severe. The cut off is less and in certain instances, only the gap is cut. I did not do a database rebuild, though. I will try that tonight.

As for the bug report, this is happening for files other than MP3s.

I had brought this to the attn of Slimserver support staff, but they said that they hadn't heard of this problem, and they couldn't replicate it.

Let me know of further developments.

Thanks all.

wduncan
2006-12-06, 22:10
I had brought this to the attn of Slimserver support staff, but they said that they hadn't heard of this problem, and they couldn't replicate it.

This is very odd. I've had a long running correspondence with Kevin Pearsall (who may be the head of the support team), although I do have to say that it's been pretty one way since last Friday. Can't get any response at all now.

btw, my problem is consistent on both a Transporter and an SB3 and regarless of whether the format is lossless of lossy. And the Transporter is 2 feet from the wireless router.

DMR NYC
2006-12-07, 06:11
I spoke to Daniel Evans in SD Tech Support. I believe that he consulted with Kevin. Daniel closed my case last week, because I told him I thought it might be an I-Tunes sw problem.

After rescanning the music library, the problem has lessened somewhat but has not disappeared in all cases.

Have you tried recording in FLAC and seeing whether you have a problem with that sw as well? I intend to do so but just haven't had the time to work this through properly.

DMR NYC
2006-12-07, 06:27
In reviewing other message threads, I saw some nasty flaming of SD Tech Support. By my statements above, I am not flaming tech support. I think that, from my limited experience, tech support seemed willing to work with me on this issue. When I did not follow up with them, they closed the support ticket.

That said, I do feel that Dan and Kevin should now be aware that there is an issue with several people who are having problems with either crossfade or gap. For me, it is an annoyance that I hope to resolve when I've more time to focus.

I think that, in the month that I have had this product, I am generally pleased with the results. The sound is fabulous, and the product does exactly what I wanted it to. I am convinced that this bug, too, will eventually get worked out, either by users sharing information in this forum or by intervention from Tech Support, or both. I will call Tech Support today and bring this thread to their attn.

wduncan
2006-12-07, 07:55
I spoke to Daniel Evans in SD Tech Support. I believe that he consulted with Kevin. Daniel closed my case last week, because I told him I thought it might be an I-Tunes sw problem.

After rescanning the music library, the problem has lessened somewhat but has not disappeared in all cases.

Have you tried recording in FLAC and seeing whether you have a problem with that sw as well? I intend to do so but just haven't had the time to work this through properly.

It would be very unfortunate to consider it an iTunes problem. It doesn't happen when playing via iTunes. And it only started with the newer slimserver releases. It could be a matter of the interaction between iTunes and slimserver, but that would still be something for SD to figure out. In any case, the support people should be able to reproduce it and identify the source of the problem.

I use both AAC and AIFF files (depending on whether the music is worth it) but have not used FLAC. I'll do that and report back.

Support should be treating the problem with the greatest of urgency - even if it's user error or an iTunes problem - because it makes the system unusable.

DMR NYC
2006-12-07, 08:18
I don't disagree with you. Just to clarify my point, at the time that I spoke to Daniel, I discovered that I was having the problem in I-Tunes as well. Now that the problem in I-Tunes is solved but the SD problem remains, the issue sits squarely in SD's court. That's why I am going to call Tech Support today.

Before Tech Support opens, I may try to use FLAC for one of my problem CD's. I have had some separate issues with that program, though.

It sounds as though your problem may be more extreme than mine, but in both instances, the software changes tunes too quickly. Is that a fair assessment?

wduncan
2006-12-07, 08:20
I
It sounds as though your problem may be more extreme than mine, but in both instances, the software changes tunes too quickly. Is that a fair assessment?

Yes, my problem is pretty consistent: 8-10 seconds clipped from the end of each song.

I'll try calling support again too...

DMR NYC
2006-12-07, 10:40
I have just set up FLAC and re-recorded a classical cd with which I was having problems. The FLAC recording works fine. This does not let SD off the hook, though. I-Tunes needs translation by slimserver to work; slimserver provides native support for FLAC. Therefore, there is quite possibly a bug in the translation program. I will call tech support abt this.

kevin
2006-12-07, 11:55
Hi,

I have a couple of ideas here...

If you're using AIFF, WAV, or AAC, can you try disabling the AAC/WAV/AIFF -> flac transcoding rules in Server Settings -> File Types?

If you're using Apple Lossless, can you edit the convert.conf file found in Program Files\SlimServer\server so that these lines:
alc flc * *
[alac] $FILE$ | [flac] -cs --totally-silent --compression-level-0 --endian big --sign signed --channels 2 --bps 16 --sample-rate 44100 -

Read like this instead?:
alc flc * *
[mov123] $FILE$ | [flac] -cs --totally-silent --compression-level-0 --endian big --sign signed --channels 2 --bps 16 --sample-rate 44100 -

(On Windows you would want to use wordpad to edit the file. On a Mac TextEdit should work fine but the file is in a different location either /library or home -> library -> preferencepanes -> slimserver.prefpane (ctrl-click and click view package contents) -> contents -> server)

Does that seem to make any difference?

wduncan
2006-12-07, 14:06
No skips! Thanks.

Eric Seaberg
2006-12-07, 14:18
Should ALL of us make this change if we're using the listed file formats? I'm not having fade-out issues but am just wondering if this is a good option for those file types.

Thanks...

kevin
2006-12-07, 14:21
Should ALL of us make this change if we're using the listed file formats? I'm not having fade-out issues but am just wondering if this is a good option for those file types.

Thanks...

Well, it doesn't -always- seem to happen. I haven't been able to reproduce it. I just had a theory that alac decoding rather than mov123 might be causing a problem, and in the other cases its possible that transcoding was causing a problem. In those cases more bandwidth will be used on the network...

kevin
2006-12-07, 14:39
Actually... For Apple Lossless, you might want to change these two lines as well:

alc wav * *
[alac] $FILE$

So that they read:
alc wav * *
[mov123] $FILE$

edit: Oh, additionally in Server Settings -> File Types disable everything for Apple Lossless except for the WAV line.

DMR NYC
2006-12-07, 16:51
Thanks, Kevin. While there has been improvement, I still am losing the "gap" where it should be, and the songs recorded in Apple lossless still run into one another. Any other suggestions?

M3Rocket
2006-12-08, 03:50
As I've noted in the bug report (http://bugs.slimdevices.com/show_bug.cgi?id=4384), this IS a transcoding problem. If I turn transcoding off, the end of the songs are not truncated (SB3 or SoftSqueeze). I still strongly believe that this bug was introduced after MP3 gapless playback was implemented.

Unfortunately, most of my library is in FLAC. And while I can stream that to my wired SB3's with no problem, I HAVE to transcode to MP3 when I access my library from work.

kevin
2006-12-11, 13:50
Thanks, Kevin. While there has been improvement, I still am losing the "gap" where it should be, and the songs recorded in Apple lossless still run into one another. Any other suggestions?

Not sure what else to do here... Does it happen at the same place on all of the songs? I do recall someone mentioning to me that they had to turn off crossfading in iTunes before it worked quite right. Do you possibly have that enabled?