PDA

View Full Version : Firmware update/backdate madness!



John Stimson
2006-11-28, 17:41
It seems like every minor revision number of slimserver comes packaged with a different version of the Squeezebox firmware. That would be okay, except that the system behaves as if the firmware is not backwards compatible, and can only be used with the revision of slimserver that it was bundled with.

If I switch from my server to a friend's server which is running a slightly older version of slimserver, I have to "update" the firmware, then "update" back when I reconnect to my own server. This happens with Squeezenetwork as well.

Can't the newer firmware be used with slightly older versions of the server? If not, what is the reason? If so, could the system be programmed to recognize compatible firmware/slimserver pairs and not require a firmware "downgrade"?

radish
2006-11-28, 20:37
Firmware and server versions are tied, sorry. The reason it considers them incompatible is because they might be. If you look around you can probably find instructions for tricking the server into accepting other firmware versions, but you do so at your own (very slight) risk!