PDA

View Full Version : SB2 not opening CUE files when browsing



bowmore17
2006-11-25, 21:59
When I browse my musicfolder on the Squeezebox all my cuefiles show up as empty. Worse still when I'm on a cue file and push to the right (so normally all songs in that cue file would show up) the screen goes black and I have to push the power button. I then get the screen of the screensaver.

However when I do a search for artists for example, I have no problems whatsoever (I go directly to the album and the album is totally recognized).

Also browsing on albums, artists doesn't pose a problem.

I mainly browse by musicfolder as I only rip to WAV and the tagging is terrible there (especially for classical and albums with different performers) and so I have made my own directory structure which seems logic to me and offers more functionality then the search function on SB.
I have no problem opening the cue files in the browser on the PC.
I've been playing for more then a year with my SB2 and hadn't had that problem. I didn't change software and played with version 6.5 before. I allready upgraded to version 6.51 and the appropiate firmware 69. I doesn't help. Also emptying playlist doesn't help.

bowmore17
2006-12-03, 11:06
Nobody has this problem? This is the log report


ERROR: Backtrace follows:

Backtrace:

frame 0: Slim::Schema::throw_exception (/PerlApp/DBIx/Class/Schema.pm line 606)
frame 1: DBIx::Class::Schema::txn_do (/PerlApp/Slim/Music/Import.pm line 241)
frame 2: (eval) (/PerlApp/Slim/Music/Import.pm line 233)
frame 3: Slim::Music::Import::setIsScanning (/PerlApp/Slim/Music/Import.pm line 152)
frame 4: Slim::Music::Import::launchScan (/PerlApp/Slim/Control/Commands.pm line 1947)
frame 5: Slim::Control::Commands::wipecacheCommand (/PerlApp/Slim/Control/Request.pm line 1483)
frame 6: (eval) (/PerlApp/Slim/Control/Request.pm line 1483)
frame 7: Slim::Control::Request::execute (/PerlApp/Slim/Control/Request.pm line 772)
frame 8: Slim::Control::Request::executeRequest (/PerlApp/Slim/Web/Setup.pm line 1436)
frame 9: Slim::Web::Setup::__ANON__ (/PerlApp/Slim/Web/Setup.pm line 2906)
frame 10: Slim::Web::Setup::processChanges (/PerlApp/Slim/Web/Setup.pm line 2660)
frame 11: Slim::Web::Setup::setup_HTTP (/PerlApp/Slim/Web/HTTP.pm line 824)
frame 12: Slim::Web::HTTP::generateHTTPResponse (/PerlApp/Slim/Web/HTTP.pm line 690)
frame 13: Slim::Web::HTTP::processURL (/PerlApp/Slim/Web/HTTP.pm line 536)
frame 14: Slim::Web::HTTP::processHTTP (/PerlApp/Slim/Networking/Select.pm line 238)
frame 15: Slim::Networking::Select::select (slimserver.pl line 492)
frame 16: main::idle (slimserver.pl line 35)
frame 17: PerlSvc::Startup (perlsvc.pl line 1482)
frame 18: PerlSvc::_startup (slimserver.pl line 0)
frame 19: (eval) (slimserver.pl line 0)

scanPathOrURL: Finding valid files in: N:\muziek\crooners\Frank Sinatra\The best of Frank.cue
About to look for files in N:\muziek\crooners\Frank Sinatra\The best of Frank.cue
For files with extensions in: [(?i-xsm:\.(?:ape|wma|asf|wax|asx|lnk|wpl|shn|wav|wave| mp3|mp2|m3u|pls|xspf|flc|flac|m4a|mov|m4b|mp4|cue| mp+|mpc|ogg|aif|aiff|lnk)$)]
Found 1 files in N:\muziek\crooners\Frank Sinatra\The best of Frank.cue
Couldn't push into new mode: [browsedb] !: Can't call method "all" on an undefined value at /PerlApp/Slim/Buttons/BrowseDB.pm line 724.

Couldn't push into new mode: [browsedb] !: Can't call method "all" on an undefined value at /PerlApp/Slim/Buttons/BrowseDB.pm line 724.

Couldn't push into new mode: [browsedb] !: Can't call method "all" on an undefined value at /PerlApp/Slim/Buttons/BrowseDB.pm line 724.

scanPathOrURL: Finding valid files in: N:\muziek\crooners\Frank Sinatra\The best of Frank.cue
About to look for files in N:\muziek\crooners\Frank Sinatra\The best of Frank.cue
For files with extensions in: [(?i-xsm:\.(?:ape|wma|asf|wax|asx|lnk|wpl|shn|wav|wave| mp3|mp2|m3u|pls|xspf|flc|flac|m4a|mov|m4b|mp4|cue| mp+|mpc|ogg|aif|aiff|lnk)$)]
Found 1 files in N:\muziek\crooners\Frank Sinatra\The best of Frank.cue
Couldn't push into new mode: [browsedb] !: Can't call method "all" on an undefined value at /PerlApp/Slim/Buttons/BrowseDB.pm line 724.

bowmore17
2006-12-26, 00:27
Nobody has this problem with cd's encoded into single wav files? The browsing in server UI works fine, the browser in the player seems to be broken.

Greg Erskine
2006-12-26, 16:20
hi bowmore17,

I use a single WAV and CUE file so I thought I'd give it a go.

I can confirm there is a problem browsing folders using the remote and Transporter. The Transporter's display and remote function goes to "lala" land.

The web interface works, well sort of, it seems to only play the first song, then stops.

regards

SlimServer Version: 6.5.1 - 11013 - Windows XP - EN - cp1252

miklorsmith
2006-12-26, 16:22
I have a related problem. Getting flac files to play from the server is spotty and doesn't work at all from the player. .mp3 files work fine but I've loaded 6.5 and 6.5.1 with no solution.

These are continuous files with .cue cutters.

I get the following error message:

Required binary was not found: [flac] -dcs --skip=$START$ --until=$END$ -- $FILE$ | [lame] --resample 44100 --silent -q $QUALITY$ --abr $BITRATE$ - -

Slimdevices is (sort of) trying to help me with no solution yet.

I'll post back if I hear anything productive.

Mike

NewBuyer
2006-12-26, 23:25
I used to have a similar problem, but after having SlimServer rescan my music library, everything works fine...

miklorsmith
2007-01-05, 09:22
I ended up going back to 6.3.1 which fixed the .cue problem. It has introduced some other inconveniences, but so far they seem workable.

Finally. Whew.