PDA

View Full Version : gap - crossfade - 6.5.1



randybrand
2006-11-24, 23:07
I recently upgraded to the 6.5.1 nightly and noticed that the gap between songs is gone. I must now either run songs into each other or any sort of fade. Can I get the normal gap back without fade?

Mark Lanctot
2006-11-25, 09:13
The gap was removed at the request of many users for gapless playback. Reminds me of the expression "one man's meat is another man's poison"...

I presume you're using MP3? There's a tag in there that specifies the gap that SlimServer reads. MP3 only plays back gapless with this tag.

I'm not sure what happens if you remove the tag, but without it, MP3 cannot play back gapless, so presumably removing it will bring the gap back. Now once you remove the tag you can't get it back, so I'd experiment around with copies of a few of your tracks. Mp3tag ought to be able to see the gap tags in its "Extended tags" dialog box. foobar may be able to see them and remove them as well, although I don't like foobar as a tagger.

See if you can get the gap back by removing tags that reference gaps. iTunes puts in gap tags as well, I've seen files with "ITUNGAP" tags.

MelonMonkey
2006-11-25, 12:10
It seems he's asking baout disabling cross-fade, not gapless playback (which is completely different).

Crossfade or fading in general modifies the audible part of the audio to create a smooth transition that, albeit a fabricated one which is not part of the original audio stream nor source.

Slim server has a setting for NONE to disable this fading per-player. Player settings > audio > crossfade (it's a pop-up menu).

Gapless playback is the attempt to restore the quality of the original source where one track starts immediately after the next such that no gap is heard between tracks. This is difficult, but possible with MP3 audio. if an original CD does not feature tracks back to back without gap, then playing these tracks in with Slim without crossfade shouldn't blend them together. The track's original fade or cut-out should be heard. No additional gap however should be introduced (like a false 2 second gap).

iTunes also uses the Gapless tag to disable crossfade on tracks from a gapless source - so that the original transition is not destroyed). I haven't read whether or not Slimserver does this for such tagged tracks.

randybrand
2006-11-25, 13:44
No, I'm not using MP3. I use iTunes and rip using Apple Lossless. The only switch that I see (in iTunes) is under options where a song can be made part of a gapless album. These are all un-checked.

If I set the the Crossfade in Slimserver to "None" the tracks run into each other without any gap whatsoever regardless of the gap duration setting.

I would request that the duration be adjustable to accomodate individual users preferences whether or not they desired gapless or not, as wewll as the ability to override certain songs to be "gapless" such as to preserve the original album production. Is there a way to do that? I cannot log in to post a bug report.

Mark Lanctot
2006-11-25, 14:58
I cannot log in to post a bug report.

You have to create a new account.

stinkingpig
2006-11-25, 15:30
On 11/25/06, randybrand
<randybrand.2huioz1164487501 (AT) no-mx (DOT) forums.slimdevices.com> wrote:
> ...
> I would request that the duration be adjustable to accomodate
> individual users preferences whether or not they desired gapless or
> not, as wewll as the ability to override certain songs to be "gapless"
> such as to preserve the original album production. Is there a way to
> do that? I cannot log in to post a bug report.
>

Like the man said, you can please some of the people some of the
time... The only way I can think of to make this happen is to make a
new crossfade setting which plays a period of silence between tracks.
--
"I spent all me tin with the ladies drinking gin,
So across the Western ocean I must wander" -- traditional

radish
2006-11-25, 16:10
The key here is that something is up with the rips. If the original CD had gaps (which I assume it did) then those should be present as 2 second (usually) silences at the end of each track. Thus, when you play the album back you get gaps as intended. If there aren't any gaps then either (a) there were none on the CD to begin with or (b) the ripping process removed them. In case (a) there's nothing which can easily be done as the point of the squeezebox and lossless encoding is to reproduce exactly what's on the CD as closely as possible. In case (b) reripping may help, once you figure out why the gaps are missing.