PDA

View Full Version : SB3 always 44.1 KHz on S/PDIF ?



holmsn
2006-11-20, 22:02
Am I missing something in the setup of Slimserver or SB3 ?, but even when playing FLAC or WAV files at 48kHz sample rate (the SB3 confirms the rate on its display)I notice that the external DAC I use, the Crystal which is part of the Quad 99 CD-P, says 44.1k

SuperQ
2006-11-20, 22:27
Am I missing something in the setup of Slimserver or SB3 ?, but even when playing FLAC or WAV files at 48kHz sample rate (the SB3 confirms the rate on its display)I notice that the external DAC I use, the Crystal which is part of the Quad 99 CD-P, says 44.1k

what version of slimserver are you running?

seanadams
2006-11-20, 22:28
Am I missing something in the setup of Slimserver or SB3 ?, but even when playing FLAC or WAV files at 48kHz sample rate (the SB3 confirms the rate on its display)I notice that the external DAC I use, the Crystal which is part of the Quad 99 CD-P, says 44.1k

What firmware version do you have? Also, did you change to AES/EBU encoding?

There are two ways for an s/pdif receiver to get the sample rate. One is to measure it against a reference frequency, which is reliable. The other way is to read some additional data, called "channel status" which is embedded in the s/pdif signal. That might be wrong if the channel status is encoded/decoded incorrectly for some reason.

Richard has been doing some work on this part o the firmware recently in order to add support for AES/EBU on transporter. It is possible that a bug was introduced.

It's probably worth doing a sanity check on the DAC side as well though - have you ever seen your it display 48KHZ?

holmsn
2006-11-21, 04:46
I'm using 6.2.1 and ,yes, the DAC always indicates 48kHz when fed from a TOSlink output from a UK DVB "Freeview" box.
I have actually been recording the S/PDIF stream to a PC and the resultant WAV's are being streamed over the LAN.These WAV files are definitely still 48KHz, not sample-rate converted by the recording app (SoundForge) as I have played them back via this Edirol USB interface direct into a TOSlink input of the DAC.
Oh and I've tried a second SB3 and they're both firmware version 28

rtitmuss
2006-11-21, 05:08
Older Squeezebox firmware does not send any information in the channel status that is embedded in the spdif signal. The default value is 44.1kHz, and this is what your DAC is showing. The newer firmware, available from slimserver 6.5 does send the correct information in the channel status, and this should display the correct rate on your DAC.

With all firmware versions the Squeezebox will be playing the files correctly at 48kHz.

Richard

holmsn
2006-11-21, 06:56
Well, Richard, I've just upgraded to Slimserver 6.5 and the players firmware to version 64 but still it displays 44.1 on the Quad !
There is absolutely no pitch change when switching from the Freeview output to SB when playing the same track so, as you said, the DAC is obviously decoding at the right rate despite what it says.

Neil

rtitmuss
2006-11-22, 02:52
Well, Richard, I've just upgraded to Slimserver 6.5 and the players firmware to version 64 but still it displays 44.1 on the Quad !


Well I'm a little surprised at this as I thought it should work with the latest firmware. Please feel free to file a bug at http://bugs.slimdevices.com to get this fixed.

Richard