PDA

View Full Version : Various Artists shenanigans



4mula1
2006-11-15, 17:27
I'm trying to get my collection sorted but I have some strange things going on in gallery view with soundtracks/compilations. The majority of my collection is in FLAC and the soundtracks and compilations all have the BAND tag set to various artists. I have the sort order set to Artist, Year, Album and some albums end up in odd places. For instance:

Singles Soundtrack: I have four tracks: Would? (Alice In Chains), Breath (Pearl Jam), State of Love and Trust (Pearl Jam), and Overblown (Mudhoney). I have made sure that all tracks have the BAND tag set using MP3tag and for some reason this album always sorts to A (right in from of another Alice In Chains album). All tracks are FLAC.

White Man's Burden Soundtrack: I have only one track, Broken TV by Bush. This track is an mp3 with the old tag completely stripped off and a new one added. It ends up next to another Bush album in the sort.

I have two more albums that end up in odd places, the rest end up under V.

Clicking on the Various Artists under any album to see all VA albums leaves out 9 of 23 albums from this view, and I've checked most if not all to make sure the band tag is set and it is.

I'm running 6.5.0 on XP. Any ideas?

JJZolx
2006-11-15, 18:19
I'm trying to get my collection sorted but I have some strange things going on in gallery view with soundtracks/compilations. The majority of my collection is in FLAC and the soundtracks and compilations all have the BAND tag set to various artists. I have the sort order set to Artist, Year, Album and some albums end up in odd places. For instance:

Singles Soundtrack: I have four tracks: Would? (Alice In Chains), Breath (Pearl Jam), State of Love and Trust (Pearl Jam), and Overblown (Mudhoney). I have made sure that all tracks have the BAND tag set using MP3tag and for some reason this album always sorts to A (right in from of another Alice In Chains album). All tracks are FLAC.

White Man's Burden Soundtrack: I have only one track, Broken TV by Bush. This track is an mp3 with the old tag completely stripped off and a new one added. It ends up next to another Bush album in the sort.

I have two more albums that end up in odd places, the rest end up under V.

Clicking on the Various Artists under any album to see all VA albums leaves out 9 of 23 albums from this view, and I've checked most if not all to make sure the band tag is set and it is.

I'm running 6.5.0 on XP. Any ideas?
This is a known bug. If there's an artist on the album that also has a complete album then the VA album gets sorted into the album list along side the albums from the first such artist. VA albums that don't have an artist like this will end up in their proper place under "Various Artists" (or the name you've set to override it in the settings). I'm not certain that everyone sees the bug, though. If not, it sure would be nice to figure out what causes it, either in the code or in the tagging of these albums.

http://bugs.slimdevices.com/show_bug.cgi?id=3350

I'd recommend removing the BAND=Various Artists (equivalent to ALBUMARTIST=Various Artists) tags from the various artists albums and always using COMPILATION=1. I used to tag my VA albums like that, but I realize it doesn't do anything and may ultimately confuse SlimServer more than anything else.

MelonMonkey
2006-11-15, 18:31
The bug where VA albums get sorted into the incorrect place does not require that the album's first artist also have an additional album of its own. At least not with 6.5.1 update as of last week.

A number of my VA albums show this very problem and I definitely have no other tracks from the artists appearing first on each of them.

JJZolx
2006-11-15, 19:10
The bug where VA albums get sorted into the incorrect place does not require that the album's first artist also have an additional album of its own. At least not with 6.5.1 update as of last week.

A number of my VA albums show this very problem and I definitely have no other tracks from the artists appearing first on each of them.
I took another look at my album listing, sorted by artist/year/album and I believer you're right. Since I removed the ALBUMARTIST=Various Artists tags I now have no albums sorted into the "Various Artists" position.

I don't think the albums are sorted randomly into the list, though. But it appears that the track artist used to sort the album into the list is random. I'm definitely seeing some grouped with artists that have complete albums, but on others it looks like they're sorted using another artist.

I was trying to construct a query the other day to actually get the listing in the right order. It's not simple.

MelonMonkey
2006-11-15, 21:37
In my situation it's as simple as this. All VA albums are listed in a position determined by the name of the artist of their first tracks.

So one album with the first track by "49 Acres" gets listed between 10000 Maniacs and 808 State using Artist/Year/Album as you've indicated.

I submitted this as a bug a few days ago because my searching didn't turn it up elsewhere, but it was marked as a duplicate (rightly so) by someone who did find the original submission.

I'd like to say that version 6.5.1 is working perfectly for me, but so far I've been spending all my Slim time with Slimserver, sans SB or soft alternative. I'm a bit worried that I'm finding some bugs, but hopeful the music will actually "just play" :)