PDA

View Full Version : Slim Server 6.5 - formatting garbled in Firefox



Cleve
2006-11-14, 20:30
I guess I should have "knocked on wood" when I posted earlier today that Slimserver had been working painlessly for some time for me. Now I've a problem.

I'm running Firefox 2.0 on my computer. My previous version of Slimserver worked fine on both Mozilla, Firefox, and Firefox 2.0.

Tonight, Slimserver prompted me that a new version, 6.5, was available. I downloaded the .exe file, closed Slimserver, and then ran the executable.

Well, Slim Server works, BUT all the borders, shadings, highlights, et al in the interface vanish in Firefox. But if I use Internet Explorer to open Slim Server, Voila - it's all returned.

I've attached screenshots of both browsers with Slimserver open. As you can see, in Firefox I can't even tell if power is on or off!!! Is there a fix?

Cleve
2006-11-14, 20:41
Ok, sorry for playing the 'drama queen'. I found the interface setting, changed the interface from default, now the GUI in Firefox looks good!

Did the old Slimserver have selectable skins like that? I've been using over a year, and never stumbled across it, if so! LOL

Ben Sandee
2006-11-14, 21:04
On 11/14/06, Cleve <Cleve.2haosz1163562301 (AT) no-mx (DOT) forums.slimdevices.com>
wrote:
>
>
> Ok, sorry for playing the 'drama queen'. I found the interface setting,
> changed the interface from default, now the GUI in Firefox looks good!
>
> Did the old Slimserver have selectable skins like that? I've been
> using over a year, and never stumbled across it, if so! LOL


Yes it did. You probably just needed to clear your browser cache.

Ben

Cleve
2006-11-15, 06:02
It would be nice, though, if the default skin looked better in Firefox. That could cause problems for new owners of SB3.

The previous version of Slimserver defaulted to pretty much the same appearance in Mozilla/Firefox that it did in Internet Explorer.

Cleve
2006-11-15, 06:16
Sigh, now a NEW problem. I was checking out the different skins - I selected "Default 2" which squishes the entire Slimserver GUI down to a little box at the top left corner of my browser window.

To make matters worse, When I try to access server settings to change it back, I get a message "404 Not Found: Setup.html Try adding page=SERVER_SETTINGS"

I've tried closing Slimserver and restarting. I STILL get this message. How can I get out of this? :(

jeffluckett
2006-11-15, 06:17
It would be nice, though, if the default skin looked better in Firefox. That could cause problems for new owners of SB3.

The previous version of Slimserver defaulted to pretty much the same appearance in Mozilla/Firefox that it did in Internet Explorer.

Your problem is probably just related to a browser cache issue. The Default skin is working just fine in FF2 for me.

Here's what you need to do:

1. Switch back to the default skin and wait for the page to reload.
2. Hit CTRL+F5 (This forces the browser to reload the page and NOT use its cached data)
3. Wait for page to reload again.
4. If it looks fine, great! If not, proceed to step 5.
5. In Firefox, go to Tools->options, then click the "Advanced" option and then the "Network" tab.
6. Click "Clear Now" in the Cache section.
7. Reload the page.
8. Everything should work fine now.

Why do you need to do this?

For some reason, your local cache of SlimServer pages is particularly "sticky". In the 6.5 release, they made significant changes to the display code of the Default skin, but they didn't change the page names. When you visit the page after an upgrade, you are still holding the cached version of the display code. Clearing your cache forces you to download a new local copy to your browser.

People doing a new install will not encounter this issue because they don't have any cached versions of the web UI pages.

jeffluckett
2006-11-15, 06:23
Sigh, now a NEW problem. I was checking out the different skins - I selected "Default 2" which squishes the entire Slimserver GUI down to a little box at the top left corner of my browser window.

To make matters worse, When I try to access server settings to change it back, I get a message "404 Not Found: Setup.html Try adding page=SERVER_SETTINGS"

I've tried closing Slimserver and restarting. I STILL get this message. How can I get out of this? :(

You can always switch skins by doing the following:

http://[your server IP]:9000/[skin_name]

So, if you wanted to go to Default, use the following:
http://[your server IP]:9000/Default

I believe that Default2 was removed by the 6.5.0 release. However, if you installed over your previous version, the installer didn't delete it. So when you switched to Default2, you got a "broken" skin that isn't compatible with 6.5.

Unfortuntately, the best way to upgrade to 6.5 is to UNINSTALL your previous version, and then do a clean install of 6.5. This fact is poorly documented. Also, if you were using any plugins with your earlier version, you will probably find that they won't work with 6.5, or may even cause crashes.

Cleve
2006-11-15, 07:31
Jeff, thank you! Ctrl+F5 did the trick. Then I was able to switch back to "default" via the address bar shortcut you suggested.

You're correct - I didn't uninstall and then install. I just shut down Slimserver and proceeded with the install. As I recall, the install package didn't request that I do so - only to shut down running apps!

During the upgrade process, I was, in fact, a bit concerned that the installer didn't automatically "uninstall" the old version - many such install packages for other software do!

I can see that my concern was justified, based on this "default2" skin bug.

W1NDRUSH
2007-01-10, 14:10
Thx to the CTRL F5 trick my slim server is now a vivid array of colours - i've never seen it look quite that good, dunno whats been happening for the last 3 months but i have never been able to load a theme correctly, until now

Cheers!