PDA

View Full Version : Crash after scheduled scan



jeffluckett
2006-11-02, 15:56
Hi, I'm running SlimServer 6.5.0 on Win2k3.

This evening, I got home and noticed my SB's screen was dark.

Checked the server and found out it had crashed ... probably after my scheduled scan, which occurs at 4:00 AM.

I looked in my Application Event log and found the following at 4:26 AM:

The description for Event ID ( 0 ) in Source ( Application ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Carp::Clan::__ANON__(): Error executing 'UPDATE tracks SET lastplayed = ?, playcount = ? WHERE ( id = ? )': DBD::mysql::st execute failed: Lock wait timeout exceeded; try restarting transaction at D:\Program Files\SlimServer\server\CPAN/DBIx/Class/Storage/DBI.pm line 771.
.

kdf
2006-11-02, 16:02
anything else scheduled to run at that time?

http://bugs.slimdevices.com/show_bug.cgi?id=4423

-kdf

jeffluckett
2006-11-02, 16:09
anything else scheduled to run at that time?

http://bugs.slimdevices.com/show_bug.cgi?id=4423

-kdf

Nope, the machine is a dedicated SS box, and I have no other scheduled processes running against it. The server is set to scan for changes daily at 4:00 am, has done so for a while now .. so this is rather random.

pgrashof
2006-11-03, 08:13
Same problem here, after a scheduled rescan Slimserver dies. I have this problem since version 6.50 and 6.51 still has the problem. Running on Win-XP

ceejay
2006-11-03, 08:47
check you have the latest versions of all the plugins you are using. I had a similar problem which was fixed by getting the latest version of Lazysearch.

Ceejay

jeffluckett
2006-11-03, 08:57
check you have the latest versions of all the plugins you are using. I had a similar problem which was fixed by getting the latest version of Lazysearch.

Ceejay

All my plugins are up-to-date as of early this week.

I should mention that I did not have a crash last night and I did nothing besides restart my Slim service after discovering the crash. No config changes. So it would appear this is a random event... don't know how to reproduce. All I have to go on is the error the Event log captured, and I posted above.

snarlydwarf
2006-11-03, 09:41
Is this on Windows? Is your antivirus software playing with the .my* files? The error is basically saying it tried to update the database, but the file was locked ... if antivirus software is scanning it, it may be locking it.

jeffluckett
2006-11-03, 09:58
Is this on Windows? Is your antivirus software playing with the .my* files? The error is basically saying it tried to update the database, but the file was locked ... if antivirus software is scanning it, it may be locking it.

No AV software installed on that machine.

pgrashof
2006-11-07, 06:01
in my case it appeared to be the Lazy Search plugin version ... thanks!