View Full Version : Problem restoring playlists from backup

2006-11-01, 10:46
I'm using SlimServer Version: 6.5.1 - 10526 on a Fedora 4 Linux machine. After a harddrive failure and drive/directory reorganization of my music files (20,000+ flac, I tried to restore my playlists from backup. Only one song, or no songs at all in some cases are on the playlists, which all formerly had 8 - 12 songs each. All of the playlists were created using the Slimserver web interface. I tried to look at some of the playlists using kwrite, but nothing shows up when the file(s) are opened. Nothing shows up when I open newly created playlists, which work properly. I've checked permissions, they appear to be correct. Anyone have any ideas?

2006-11-02, 12:35
An update. I was able to edit the playlist files I have restored from tape with kedit (Linux editor). So, to try and expedite the problem, I recreated most of the old playlists in the Slimserver Web interface. Unfortunately, after a full rescan, all of the playlists appear in duplicate, but only display and playback one song, apparently truncating the others. Anyone familiar with this? I've also updated to the latest nightly,

SlimServer Version: 6.5.1 - 10554


2007-01-29, 10:06

I am having a similar problem. When I update Slimserver, I can't get it to recognize any of my existing playlists. I've tried uninstalling and reinstalling, copying playlists to directories and alternately, setting the playlist directory to where my playlists are. Slimserver sees none of my playlists.

I initially discovered the problem when I updated to 6.5.0. I had my playlists in the default location and it got wiped out. I rebuilt my playlists in a safe location but I can't use them.


2007-01-29, 11:07
First question - is the path used in your playlist files the same as the way Slimserver sees your music library ?
So if your playlist shows mnt/dir/Music/filename.mp3, is your music library also set up as mnt/dir (for example) ?

Do your playlists use relative paths ? [Slimserver doesn't]

You need to point Slimserver at the playlist directory - does it recognise the directory as valid ? Could it be a permissions issue, if you've been moving the playlists around - does Slimserver have read access ?

Finally, try running Slimserver from the command line,
but add the following "--d_scan --logfile=[your directory here]scanlog.txt"

Then do a "playlist only" rescan. When Slimserver has finished the scan, look for the scanlog.txt file and see if there are any error messages. Does this give you a clue as to why the files aren't found ? Welcome to post a chunk up here if you want others to comment.

See the below thread for a very similar discussion I had with another poster that may help.