View Full Version : Slimserver not playing .m4a tracks ??

2006-10-30, 15:30
I've got slimserver 6.5 running on WinXp
(SlimServer Version: 6.5.0 - 9916 - Windows XP - EN - cp1252)

There are a number of .m4a ACC tracks in my library. The slimserver interface sees the files, and will put them into the current playlist, but will not play them.

I've played the same files through winamp, and they play fine, so the files are ok, and quicktime is installed ok.

But if I attempt to play them through the squeezebox (or through winamp playing the slimserver's stream on the Xp machine) the file does not play. (the music player pane display stays on "Stop", clicking on "Play" has no effect)

In the server settings/file types pane, the first two Apple AAC, Lossless or Movie file checkboxes are selected (stream = AIFF, FLAC) the third is not (stream = MP3)

From everything I've found on the forum and FAQs - I expected the ACC files to just play. What do I need to do to configure the slimserver to play these .m4a files?

2006-10-30, 15:43
Have you seen the suggestions in the wiki here (http://wiki.slimdevices.com/index.cgi?AAC) ?

2006-10-30, 18:01
yes - They're for getting the stream to use compressed mp3s instead of flac. In my case, the squeezebox & the server are connected via ethernet, not wireless - so bandwidth is not an issue.

2006-10-30, 18:44
I've had this problem, or something like it, with Slimserver.

Tech support had me d/l an older version of mov123.exe at, http://svn.slimdevices.com/*checkout*/trunk/server/Bin/MSWin32-x86-multi-thread/mov123.exe?rev=235.

And had me edit convert.conf so that the line

[mov123] $FILE$ | [flac] -cs --totally-silent --compression-level-0 --endian big --sign signed --channels 2 --bps 16 --sample-rate 44100 -

would have '--endian big' replaced with '--endian little'.

That solved my problem. Only thing is that I've had to do that (replace mov123.exe and edit convert.conf) anytime I re/install Slimserver. As long as it works, I don't mind.

Good luck

2006-10-30, 20:10
thanks, i'll give it a try

2006-10-30, 23:29
No luck. Using the old mov123.exe and revising the conf file didn't change anything.

2006-10-30, 23:41
Do you have iTunes or Quicktime installed on the slimserver machine? If not, it won't work.

2006-10-31, 06:52
Have you tried running mov123 by hand?


2006-10-31, 09:33
It turns out quicktime was not installed. I thought winamp needed quicktime to play the acc files - apparently not. Thanks!

Now to figure out why the same problem happens with .ogg files. (they don't play either)