PDA

View Full Version : Help Setting Up Remote Streaming!



Dan Speirs
2003-12-10, 18:40
I really want to get the remote streaming function
working but I haven't had any luck yet. I was
wondering if you could give me a bit of help. Keep in
mind I am not very tech saavy but I am a hell of a
foosball player.

I am running XP standard with Netgear WGR614 802.11g.
I have Norton Internet Security installed and running.
I have a cable modem/access.

I tried going to Netgears configuration site
http://192.168.0.1 and then clicking port forwarding
and port start 9000 and port end 9000. I am not sure
if this is where I tell the firewqall to let
squeezebox in/out.

To try to access remote streaming I use:
http://localhost:9000 entering my IP address as local
host. I get my IP from www.whatismyip.com. Is this
correct or do I use the number displayed on the
SlimServer under settings which says “Player Settings
for XX.XX.XX.XX (which is a different number than my
IP).

When I currently get a buddy to try
http://localhost:9000 my internet access actually
drops and I have to shut down the computer and reset
the router. Obviously my router config for port 9000
is not right. By the way, I disable the Norton
Internet Security each time I try this.

Anybody got some step by step advice for me?

Dan


__________________________________
Do you Yahoo!?
New Yahoo! Photos - easier uploading and sharing.
http://photos.yahoo.com/

Thomas B. Malsbury
2003-12-10, 19:48
Dan,

You are on the right track.

First off, you need to properly set up your port forwarding within your
router. To do this you need to assign a static IP address to the machine
that is running the SlimServer software. This is done through the Netgear
configuratin web interface (192.168.0.1). In my case I set it so that it
always assigns 192.168.0.99 to my SlimServer machine. This is an arbitrary
number, I picked 99 so I could remember it. You then set up the port
forwarding so that any incoming requests on port 9000 are passed through the
router to the internal IP 192.168.0.99.

Second, you need to make sure that the machine itself will not deny the
request once the router forwards it. This will be a matter of properly
configuring your Norton Internet Security. I personally haven't used it, so
I'm sorry I can't be more helpful on the exact steps. Generally you just
have to allow the SlimServer program to listen on a specific port. Don't
forget you will also have to configure the Windows XP internal firewall if
you have enabled it. Or simple disable it since you are running Norton. I
believe by default it is disabled, but you may have enabled it a some point.

For remote streaming you would use the IP address you found using
www.whatismyip.com. Lets say for example you find your IP address is
67.84.171.42 you would use the following urls:

Web Interface: http://67.84.171.42:9000/
Media Player: http://67.84.171.42:9000/stream.mp3

The IP address that appears as "Player Settings for XX.XX.XX.XX" is the
address for the remote location. This helps you keep track of which play
list is for which location. Using that settings link you can rename it so
that it shows a name (Such as Work , etc.) instead of the IP Address.

Looking through the manual for your router it looks pretty well written,
even gives some examples for setting up an ftp server. This is the same
basic process, just use port 9000 instead of port 21. Chapter 6 and Appendix
B should help with most of your issues.

Hope at least some of that was useful,

Tom

----- Original Message -----
From: "Dan Speirs" <dspeirs (AT) yahoo (DOT) com>
To: <discuss (AT) lists (DOT) slimdevices.com>
Sent: Wednesday, December 10, 2003 8:40 PM
Subject: [slim] Help Setting Up Remote Streaming!


>
> I am running XP standard with Netgear WGR614 802.11g.
> I have Norton Internet Security installed and running.
> I have a cable modem/access.
>
> I tried going to Netgears configuration site
> http://192.168.0.1 and then clicking port forwarding
> and port start 9000 and port end 9000. I am not sure
> if this is where I tell the firewqall to let
> squeezebox in/out.
>
> To try to access remote streaming I use:
> http://localhost:9000 entering my IP address as local
> host. I get my IP from www.whatismyip.com. Is this
> correct or do I use the number displayed on the
> SlimServer under settings which says "Player Settings
> for XX.XX.XX.XX (which is a different number than my
> IP).
>
> When I currently get a buddy to try
> http://localhost:9000 my internet access actually
> drops and I have to shut down the computer and reset
> the router. Obviously my router config for port 9000
> is not right. By the way, I disable the Norton
> Internet Security each time I try this.
>
> Anybody got some step by step advice for me?
>
> Dan
>
>
> __________________________________
> Do you Yahoo!?
> New Yahoo! Photos - easier uploading and sharing.
> http://photos.yahoo.com/
>