View Full Version : Squeezebox2/3 & Reciva upnp interoperability

2006-10-19, 01:30
This relates to Reciva based wifi radios such as those made by Acoustic Energy and Magicbox.

After about 6 hours trying various upnp server software, different wireless network settings, updating the firmware on my router and much other messing around I finally discovered that the problems I was having with upnp on my Reciva based radio went away when I switched off my slimdevices squeezebox2.

Basically if the squeezebox is connected to a slimserver, even in standby mode, attempting to do anything via upnp on a Reciva radio is extremely flakey and will result in a reset to reacquire network within seconds.

I'd be interested to know whether it's the squeezebox or the reciva radio that's not behaving so I know who to whinge at! Interestingly a upnp client operating on a windows machine seems unaffected by the squeezebox which might imply it's the Reciva's fault but I guess it's not totally conclusive.

Any help or suggestions to workaround this would be great (other than the obvious "Turn the squeezebox off")


2006-10-19, 02:17
Does the problem happen when SB3 is in standby and slimserver is not running ?

If it only happens when slimserver is running - have you tried the -noupnp option on the command line ?


Further thoughts

Could it be a 802.11B vs G conflict. Is your router in mixed mode ? Does the problem happen if Squeezebox is wired into router ?

2006-10-19, 02:36

Helpful input as always (thanks!)

The problem seems to happen when SB3 is switched on and associated with a slimserver. If slimserver is not running the problem doesn't occur.

I didn't know about the -noupnp option but I'll try it later.(good idea!)

I've tried various wireless options including mixed/non mixed modes and it doesn't seem to affect things.

There also might be a clue in this problem when firing up the upnp server:


2006-10-19, 02:49
In case it's relevant I have a SB2 (don't know if it happens with a SB3 but I presume it would).

2006-10-19, 03:29
SB2 and SB3 are the same except for packaging and antenna.

If it only happens with slimserver running - I would think it is upnp associated or possibly conflict on port 9000.

IIRC in 6.5 slimserver acts as upnp client to enable user browse upnp served media - I think happens as part of the solution to support Rhapsody. The -noupnp stops this upnp activity.

It is also possible the AE device can only use port 9000 and if slimserver starts first then slimserver gets port 9000 rather than the other upnp server.

2006-10-29, 03:45
I finally solved this. The squeezebox/slimserver were complete red herrings. I found that any setting applied to slimserver would not fix the problem including disabling upnp. Finally I noticed even with slimserver completely disabled I still had problems (despite what I thought before).
However whether the squeezebox was powered up and connected to the wireless network definitely did affect the problem.

In the end I discovered it was due to an NSLU2 device attahed to the ethernet port of the squeezebox which I use to form an interface to the USB port of my Topfield set top box. When this was switched off the problem went away. This device also has some form of upnp running, and disabling it fixes the problem.

So sorry for the wild goosechase - as I say nothing to do with Squeezebox/slimserver at all!