PDA

View Full Version : iTunes redux



Jeff Allison
2003-12-09, 09:38
> > Sorry, I should've made that clear. They're AAC (most of them
> > anyway), and I do have LAME installed. I can play the
> > files through SlimServer to the Squeezebox if I don't select
> > "use iTunes" in server options, so there's no particular problem
> > with on the fly conversion from AAC to MP3. When I run the server
> > with the iTunes debug option I get messages about not finding the
> > iTunes folder, but I don't know why that would be.

> Can you post the exact error message?

With iTunes debug on I get this:

2003-12-09 08:20:38 using itunes library: 1
2003-12-09 08:20:38 iTunes: found My Music here: for \iTunes\iTunes
Music Library.xml
2003-12-09 08:20:38 iTunes: couldn't read \iTunes\iTunes Music
Library.xml
2003-12-09 08:20:43 iTunes: found My Music here: for \iTunes\iTunes
Music Library.xml
2003-12-09 08:20:43 iTunes: couldn't read \iTunes\iTunes Music
Library.xml
2003-12-09 08:20:43 using itunes library: 1
2003-12-09 08:20:43 iTunes: found My Music here: for \iTunes\iTunes
Music Library.xml
2003-12-09 08:20:43 iTunes: couldn't read \iTunes\iTunes Music
Library.xml
2003-12-09 08:20:48 iTunes: found My Music here: for \iTunes\iTunes
Music Library.xml
2003-12-09 08:20:48 iTunes: couldn't read \iTunes\iTunes Music
Library.xml
2003-12-09 08:20:48 using itunes library: 1

And that repeats. I added d_itunes_verbose as well, but it didn't add
anything to the above.

- Jeff

> -dean

dean
2003-12-09, 10:03
Jeff, is it possible that the permissions on that file prevent it from
being read by the SlimServer software?

-dean

On Dec 9, 2003, at 8:38 AM, Jeff Allison wrote:

>>> Sorry, I should've made that clear. They're AAC (most of them
>>> anyway), and I do have LAME installed. I can play the
>>> files through SlimServer to the Squeezebox if I don't select
>>> "use iTunes" in server options, so there's no particular problem
>>> with on the fly conversion from AAC to MP3. When I run the server
>>> with the iTunes debug option I get messages about not finding the
>>> iTunes folder, but I don't know why that would be.
>
>> Can you post the exact error message?
>
> With iTunes debug on I get this:
>
> 2003-12-09 08:20:38 using itunes library: 1
> 2003-12-09 08:20:38 iTunes: found My Music here: for \iTunes\iTunes
> Music Library.xml
> 2003-12-09 08:20:38 iTunes: couldn't read \iTunes\iTunes Music
> Library.xml
> 2003-12-09 08:20:43 iTunes: found My Music here: for \iTunes\iTunes
> Music Library.xml
> 2003-12-09 08:20:43 iTunes: couldn't read \iTunes\iTunes Music
> Library.xml
> 2003-12-09 08:20:43 using itunes library: 1
> 2003-12-09 08:20:43 iTunes: found My Music here: for \iTunes\iTunes
> Music Library.xml
> 2003-12-09 08:20:43 iTunes: couldn't read \iTunes\iTunes Music
> Library.xml
> 2003-12-09 08:20:48 iTunes: found My Music here: for \iTunes\iTunes
> Music Library.xml
> 2003-12-09 08:20:48 iTunes: couldn't read \iTunes\iTunes Music
> Library.xml
> 2003-12-09 08:20:48 using itunes library: 1
>
> And that repeats. I added d_itunes_verbose as well, but it didn't add
> anything to the above.
>
> - Jeff
>
>> -dean
>
>