PDA

View Full Version : Problem with Alien BBC on Diskstation 106



andy1966
2006-10-15, 15:38
Perhaps someone could assist me, I'm having problems streaming RTE radio 1 (using the alien BBC plugin).

I have slimsever installed on a Diskstation 106 (with SSODS). Then added Alien BBC (1.06). I edited the Alien BBC custom-convert.conf file as instructed in the SSODS readme file. The BBC stations and RTE 2FM all work fine but RTE radio 1 just keeps trying to connect stops and trys to connect again.

Any ideas or tips? I have attached a log of debugging with d_source on, and a copy of my custom-convert.conf.

With slimserver running on my laptop RTE radio 1 works fine.

I'm new to forums so forgive me if I've posted this in the wrong spot.

Thanks in advance

bpa
2006-10-15, 15:50
RTE1 live uses an old RealAudio standard which requires a special codec. Download the following library
http://www.mplayerhq.hu/MPlayer/releases/codecs/essential-ppc-20051120.tar.bz2

The codec file you want is sipr.so.6.0 - it has to be extracted from the tar file and then installed in the "codecs" directory for mplayer. The location of the codecs directory will be set during build of mplayer. The version of mplayer for SSODS is special so you will need flipflip to reply with the setting - you could send him a PM.

You should also set Radio station timeout to about 40 secs as it is a very slow stream and the Mplayer cache is set to 128kbytes.

BTW - How did you manage to get RTE1 working on a laptop without installing the SIPR file ?

andy1966
2006-10-16, 04:33
Thanks a lot for your reply, I'll contact flipflip about the mplayer codec directory and add the codec file as suggested.

As for your question regarding how I got RTE1 working on the laptop, I just installed slimserver, and the windows version of th Alien BBC plugin. Could mplayer/alien BBC be using codecs that were already on my laptop?

Thanks again!

flipflip
2006-10-16, 05:09
"strings mplayer-stdout" reveals the following:

/volume1/SSODS/etc/mplayer/mplayer.conf
/volume1/SSODS/etc/mplayer/codecs.conf
/volume1/SSODS/share/mplayer/font
/volume1/SSODS/lib/mplayer/vidix/
/volume1/SSODS/etc/mplayer/input.conf

Could you configure the codecs location in one of these files?

On my Linux system here at work, they are in /usr/lib/win32 and in /usr/lib/codecs. So I guess that it could be /volume1/SSODS/lib/codecs or /volume1/SSODS/share/codecs.

mplayer was configured with "--prefix=/volume1/SSODS", so everything should be in the standard location relative to the prefix (which on other system is /usr or /usr/local).

I hope this helps. I don't know much about mplayer configuration and I don't even use it in my SSODS setup. I listen to "DRS", the Swiss equivalent of the "BBC" :-). These programmes come as http wmv streams and mp3 podcasts.

Let me know if I have to compile mplayer differently or with added options.

If you succeed installing the additional codecs, let me know how. I'll add that to the README.ssods.

Regards,
flip

andy1966
2006-10-17, 11:27
Thanks everyone for your replies, I tried putting the codec file in a directory /volume1/SSODS/lib/codecs or /volume1/SSODS/share/codecs and just restarting SS but unfortunately no success, still no RTE 1.

By the way where is mplayer on the DS, I couldn't find it on the the Slimserver or the SSODS share? Does SSODS add it to the firmware of the DS.

Anyway I need to read more documentation as I'm new to Linux /streaming/perl etc.

I'll post a solution if I come up with one but I think it may take a while.

Regards
Andrew

flipflip
2006-10-17, 11:44
Mplayer is /volume1/SSODS/bin/mplayer-stdout. The command is called mplayer-stdout because I patched the original source code to allow the pcm output plugin to output to stdout instead of a file.

Try something like this:

"/volume1/SSODS/bin/mplayer-stdout -ac help" which should give you a list of available audio codecs. I don't know if that would include "external" codecs, though.

Or try opening your Radio-Stram on the command line. This might output informative (error) messages. Something like this might work:

/volume1/SSODS/bin/mplayer-stdout -vc null -vo null -cache 128 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:waveheader:file=/volume1/public/stream.wav <URL>

Where <URL> is the URL for your radio station. This will save the stream to stream.wav (on the public share). Try saving a few seconds (abort with CTRL-C) and then try to play that file with the squeezebox and/or some media player on your PC. Note that if the URL contains ?, \ or other funny chars, quote it (put " around it), e.g. "http://blabla.com/playradio?somestation".

Btw, you don't need to restart Slimserver after installing the codecs, just play the Radio station. mplayer will be started every time you try to play. Only if you change custom-convert.conf, you'll have to restart SS. But trying on the command line as described above is probably easier anyway.

Happy hacking! :-)

flip


Edit: add -msglevel all=X, where 0 < X < 9 as the first argument to mplayer-stdout. Higher X will increase verbosity. The default is probably 1, 2 or 3.

Edit2: You can probably direct mplayer's messages to a file using mplayer ...arguments.... 2> /volume1/public/mplayer.txt .. just in case you want to post it here.

Edit3 (last one for today :-): I understand that you don't have telnet access to the diskstation.. you need it to issue the above commands. Activate it as follows:

create a file called TELNET on the public share (no extension, size/contents does not matter). After that, a new button will appear in the "Tools" menu of SSODS. Enable telnet there and then use the command "telnet <ds_ip_addr" in a command shell (cmd.exe) to telnet to the DS. "Putty" or "Hyperterminal" (included in Windows) works as well. Login as user "admin" with the admin password. Then type the above commands. Easy and harmless commands to test include "date", "df" or "echo Hello World".

bpa
2006-10-17, 12:33
TO check this problem, I tried with the latest mplayer to install SIPR on my Linux system and I am having the same problem whereas it still works OK on Windows mplayer. This used to work OK on Linux with earlier mplayer builds so I think there may have been a change in configure and build-options.

I need to check the build option as it may be necessary to have use -with-reallibdir option.

A simple way of getting extra messages from mplyer is to use -v Multiple -v's gives even more messages.

flipflip
2006-10-17, 12:59
I need to check the build option as it may be necessary to have use -with-reallibdir option.


Hmm.. I configured as follows:

./configure --prefix=/volume1/SSODS --disable-mencoder --language=en,de --disable-jpeg --disable-gif --disable-tga --disable-liblzo --disable-tv --disable-dvb --disable-sdl --disable-pnm --disable-xvid --disable-toolame --disable-mad --disable-png --disable-vm --enable-md5sum --disable-menu --charset=US-ASCII --disable-mpdvdkit --disable-dvdread

I'll recompile it with the above option when I find time (probably not before the next weekend).

bpa
2006-10-17, 15:15
You need to build mplayer with --enable-real to support additional RealAudio dynamic libraries.

On my system I used to have RealPlayer9 installed and mplayer's configure autodetected this and the associated codecs and so automatically enabled --enable-real.

I currently have RealPlayer10 installed and mplayer's configure does not detect this version and so didn't enable real library support.

Finally there was some compatibility issue with the Linux x86 codec file sipr.so as distributed in the mplayer tar - when I used RealPlayer10 version, there was no problem. So there may still be an issue when new version of mplayer is built to DS106. I'll try to test it on my kuro box in a day or so.

flipflip
2006-10-18, 16:28
A new release of SSODS is ready to download (in a few minutes). It includes the necessary codecs to play Andy's favourite radio station.

flip

bpa
2006-10-18, 16:49
Have you tried mplayer running the SIPR codec ?

I have comes across a strange problem with it on my Kuro Box (Gentoo) - I have just found the answer but it requires a change to the config.mak. I'm not sure if it is something specific with my system or something with the SIPR codec in general.

Edit:
Just completed the testing and it seems OK. You may not have to do this change but if mplayer still refuses to find the codec, edit config.mak. Then find and change "-z,noexecstack" to "-z,execstack". Now delete mplayer exe and just "make" mplayer again.

I think there is something odd about the PPC implementation of this codec and since it is not used much now, I suspect the mplayer group didn't test it on PPC.

flipflip
2006-10-18, 17:01
I don't know.. but Andy1966's radio station plays.. does it use the SIPR codec?

I make "make distclean", then "
./configure --prefix=/volume1/SSODS --disable-mencoder --language=en,de --disable-jpeg --disable-gif --disable-tga --disable-liblzo --disable-tv --disable-dvb --disable-sdl --disable-pnm --disable-xvid --disable-toolame --disable-mad --disable-png --disable-vm --enable-md5sum --disable-menu --charset=US-ASCII --disable-dvdread --disable-mpdvdkit --with-reallibdir=/volume1/SSODS/lib/codecs --with-codecsdir=/volume1/SSODS/lib/codecs", then "make".

Just worked.. well, I only checked if mplayer plays the stream and it looked like it does. The quality was not very good and the stream seems to be rather slow as you said before.

Did you have problems building mplayer or running it?

flip (good night, it's 2 a.m. local time :-)

P.S. I don't use AlienBBC or mplayer with the Squeezebox, so I cannot tell if my binaries are good. Complaints from users are rare and have been unrelated to mplayer so far, though.

bpa
2006-10-18, 17:11
The only "main" stations which use SIPR now are RTE Radio 1 - live and NPR News - Real Stream. IIRC These are 16kbps streams.

Wait until we hear from Andy. If it works with your changes then the problem I found is specific to my system/build - which was my suspicion.

Edit:
For completeness - below is a clip of the log - note the "cannot enable executable stack" error.


Clip info:
name: RTE Radio 1 FM Live Stream
author: Radio Telifis Eireann
copyright: RTE Interactive 2005
================================================== ========================
Opening audio decoder: [realaud] RealAudio decoder
opening shared obj '/usr/lib/codecs/sipr.so.6.0'
Error: /usr/lib/codecs/sipr.so.6.0: cannot enable executable stack as shared object requires: Bad address

andy1966
2006-10-19, 10:49
This is brillant news .....
I had just getting started following your instructions with hacking the DS and getting more information.
I got a crash course in Linux from my UNIX colleagues here at work but it was looking like a very long road ......

Anyway I'll try installing the new SSODS tonight and I'll post the outcome.

Thanks a million,
Andy

andy1966
2006-10-19, 12:11
Just installed the new SSODS ssods-r2b5-ppc.zip/ Slimserver 6.3.1./ Alien BBC 1.06 (with ammemded plugin.pm) on my DS106.

And RTE radio 1 is working !!!

Thanks a million flipflip and bpa !
Best regards,
Andy