PDA

View Full Version : Random play only plays 10 songs and stops...



ctviggen
2006-10-14, 10:46
Random play only plays 10 songs, then stops playing. Hitting play again causes the server to replay the same 10 songs. I have version 6.5.0, and prior to this version, Slim Server would keep selecting new random songs. Is there a setting I have incorrectly set?

Mark Lanctot
2006-10-14, 10:51
Have you set in Random Mix - Add new items when old ones finish?

oreillymj
2006-10-15, 01:34
Also if you re-start the service, Slimserver "forget's" that it was in Random mix mode and your playlist does not get any more tracks added to it.

ctviggen
2006-10-15, 09:07
Have you set in Random Mix - Add new items when old ones finish?

I wonder if my installation is corrupted? When I go to Random Mix, there is no option to add new items when old ones finish. Also, the genres to include are all numbered and are not named. Further, where it asks you to choose a random mix, it lists Random Albums, Songs and Years, but there is no entry for Artists. There is additionally a large space between the "Home / Random Mix" and "Choose a random mix...", and it appears that something should be there that is not.

Would you recommend a complete uninstall followed by a reinstall? Thank you for your help.

Mark Lanctot
2006-10-15, 09:28
Yes, on 6.5.0, those options should definitely be there.

First, make sure in Server Settings - Plugins that the Random Mix plugin is enabled, although I don't think you'd see the option in the main menu if it wasn't.

Also try clearing your browser cache.

Uninstall/reinstall seems so drastic. But if you do, go in there and delete the rest of the SlimServer directory after uninstall and before you reinstall - it leaves items behind.

Bob Bressler
2006-10-15, 12:07
I wonder if my installation is corrupted? When I go to Random Mix, there is no option to add new items when old ones finish. Also, the genres to include are all numbered and are not named. Further, where it asks you to choose a random mix, it lists Random Albums, Songs and Years, but there is no entry for Artists. There is additionally a large space between the "Home / Random Mix" and "Choose a random mix...", and it appears that something should be there that is not.

My system behaves exactly this way, after a clean install and rescan. As another data point, the number of songs matches the count from iTunes, but the number of Genres is only a subset of what iTuens thinks are there. Maybe this is a tag issue?

ctviggen
2006-10-15, 14:51
I fixed this by uninstalling and reinstalling (along with deleting the slimserver directory). I tried removing and reinstalling just the random play plugin, but that did not work.