PDA

View Full Version : Full Scan Not Getting All Files



kyleki
2006-10-14, 10:41
I'm running SlimServer Version: 6.5.1 - 10337 - RedHat - EN - utf8
in Fedora Core 4 and am getting the following errors in my log when
I try and do a full rescan. It seems to not like the tags in one
or more of my files anymore and stops short of completing the scan.
Can anyone help me figure out why this is happening?


2006-10-14 10:24:27.8742 About to look for files in /data/music/mp3
2006-10-14 10:24:27.8760 For files with extensions in: [(?i-xsm:\.(?:ape|wma|shn|wav|wave|mp3|mp2|flc|flac|m4a |mov|m4b|mp4|mp+|mpc|ogg|aif|aiff|cue)$)]
2006-10-14 10:24:29.1782 Found 11791 files in /data/music/mp3
Unicode character 0xfffe is illegal at /usr/lib/perl5/5.8.6/i386-linux-thread-multi/Encode.pm line 166, <$fh> line 1.
Unicode character 0xfffe is illegal at /usr/local/slimserver/Slim/Utils/Text.pm line 130.
Unicode character 0xfffe is illegal at /usr/local/slimserver/Slim/Utils/Text.pm line 130.
Unicode character 0xfffe is illegal at /usr/local/slimserver/Slim/Utils/Text.pm line 102.
Unicode character 0xfffe is illegal at /usr/local/slimserver/Slim/Utils/Text.pm line 102.
Unicode character 0xfffe is illegal at /usr/local/slimserver/Slim/Utils/Text.pm line 102.
Unicode character 0xfffe is illegal at /usr/local/slimserver/Slim/Utils/Text.pm line 102.
Unicode character 0xfffe is illegal at /usr/local/slimserver/Slim/Utils/Text.pm line 102.
Unicode character 0xfffe is illegal at /usr/local/slimserver/Slim/Utils/Text.pm line 102.
Unicode character 0xfffe is illegal at /usr/local/slimserver/Slim/Utils/Text.pm line 102.
Unicode character 0xfffe is illegal at /usr/local/slimserver/Slim/Utils/Text.pm line 102.
Unicode character 0xfffe is illegal at /usr/local/slimserver/Slim/Utils/Text.pm line 102.
Unicode character 0xfffe is illegal at /usr/local/slimserver/Slim/Utils/Text.pm line 102.
Unicode character 0xfffe is illegal at /usr/local/slimserver/Slim/Utils/Text.pm line 102.
Unicode character 0xfffe is illegal at /usr/local/slimserver/Slim/Utils/Text.pm line 102.
Unicode character 0xfffe is illegal at /usr/local/slimserver/Slim/Utils/Text.pm line 102.
Unicode character 0xfffe is illegal at /usr/local/slimserver/Slim/Utils/Text.pm line 102.
substr outside of string at /usr/local/slimserver/lib/MP3/Info.pm line 1344, <$fh> line 1.
Use of uninitialized value in multiplication (*) at /usr/local/slimserver/lib/MP3/Info.pm line 1347, <$fh> line 1.
Use of uninitialized value in multiplication (*) at /usr/local/slimserver/lib/MP3/Info.pm line 1347, <$fh> line 1.
Use of uninitialized value in multiplication (*) at /usr/local/slimserver/lib/MP3/Info.pm line 1347, <$fh> line 1.
Use of uninitialized value in multiplication (*) at /usr/local/slimserver/lib/MP3/Info.pm line 1347, <$fh> line 1.
Use of uninitialized value in length at /usr/local/slimserver/lib/MP3/Info.pm line 1361, <$fh> line 1.
substr outside of string at /usr/local/slimserver/lib/MP3/Info.pm line 1993, <$fh> line 1.
Use of uninitialized value in division (/) at /usr/local/slimserver/lib/MP3/Info.pm line 693, <$fh> line 1.
Use of uninitialized value in substr at /usr/local/slimserver/lib/MP3/Info.pm line 696, <$fh> line 1.
Use of uninitialized value in substr at /usr/local/slimserver/lib/MP3/Info.pm line 696, <$fh> line 1.
2006-10-14 10:32:31.5341 ERROR: Error executing 'INSERT INTO tracks (audio, audio_offset, audio_size, bitrate, block_alignment, content_type, drm, filesize, lossless, lyrics, rating, remote, replay_gain, replay_peak, samplerate, secs, tagversion, timestamp, title, titlesearch, titlesort, tracknum, url, year) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?,
Created with mp3Tag, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)': DBD::mysql::st execute failed: called with 24 bind variables when 23 are needed at /usr/local/slimserver/CPAN/DBIx/Class/Storage/DBI.pm line 771.

2006-10-14 10:32:31.5343 ERROR: Backtrace follows:

2006-10-14 10:32:31.5346 Backtrace:

frame 0: Slim::Schema::Storage::throw_exception (/usr/local/slimserver/CPAN/DBIx/Class/Storage/DBI.pm line 773)
frame 1: DBIx::Class::Storage::DBI::_execute (/usr/local/slimserver/CPAN/DBIx/Class/Storage/DBI.pm line 788)
frame 2: DBIx::Class::Storage::DBI::insert (/usr/local/slimserver/CPAN/DBIx/Class/Row.pm line 75)
frame 3: DBIx::Class::Row::insert (/usr/local/slimserver/CPAN/DBIx/Class/PK/Auto.pm line 43)
frame 4: DBIx::Class::PK::Auto::insert (/usr/local/slimserver/CPAN/DBIx/Class/ResultSet.pm line 1335)
frame 5: DBIx::Class::ResultSet::create (/usr/local/slimserver/Slim/Schema.pm line 794)
frame 6: Slim::Schema::newTrack (/usr/local/slimserver/Slim/Utils/Scanner.pm line 322)
frame 7: Slim::Utils::Scanner::scanDirectory (/usr/local/slimserver/Slim/Music/MusicFolderScan.pm line 72)
frame 8: Slim::Music::MusicFolderScan::startScan (/usr/local/slimserver/Slim/Music/Import.pm line 422)
frame 9: Slim::Music::Import::runImporter (/usr/local/slimserver/Slim/Music/Import.pm line 265)
frame 10: Slim::Music::Import::runScan (/usr/local/slimserver/scanner.pl line 180)
frame 11: (eval) (/usr/local/slimserver/scanner.pl line 174)
frame 12: main::main (/usr/local/slimserver/scanner.pl line 312)

2006-10-14 10:32:31.5429 ERROR: Scanner: Failed when running main scan: [Carp::Clan::__ANON__(): Error executing 'INSERT INTO tracks (audio, audio_offset, audio_size, bitrate, block_alignment, content_type, drm, filesize, lossless, lyrics, rating, remote, replay_gain, replay_peak, samplerate, secs, tagversion, timestamp, title, titlesearch, titlesort, tracknum, url, year) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?,
Created with mp3Tag, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)': DBD::mysql::st execute failed: called with 24 bind variables when 23 are needed at /usr/local/slimserver/CPAN/DBIx/Class/Storage/DBI.pm line 771.
]

2006-10-14 10:32:31.5431 ERROR: Scanner: Skipping post-process & Not updating lastRescanTime!

ob_kook
2006-10-15, 12:50
I am having the same problem after upgrading to the latest released version. I am using Windows version and have not turned on de-bug, but after the scan is finished, it shows that I have 3500 songs (I have about 26,000)

One thing that we might have in common is that I have several songs with unicode tags.

kyleki
2006-10-15, 23:20
It turns out the errors were due to some tags in my files. After launching
slimserver with "--d_scan --d_paths --d_mp3 --d_info", I was able to see the
file names that were causing the problem. The debug output was placed in
the logfile on the server (/tmp/slimserver.log).

I cleared the id3 tags on the "bad" files and reset them using
Zortam Mp3 Media Studio (http://www.zortam.com/) (I just found this online while trying to
fix my tags from my networked Windows box. Otherwise I would have used
EasyTag (http://easytag.sourceforge.net/) in Linux).

I'm fairly new to utilizing debug flags and found the ones I listed to
at least get me the info I was looking for. Unfortunately, it took a very
long time and generated a fairly large log file I had to wade through.
Does anyone know if there's a more efficient way to find these needles
in the haystack?

ceejay
2006-10-16, 00:16
I cleared the id3 tags on the "bad" files and reset them using
Zortam Mp3 Media Studio (http://www.zortam.com/) (I just found this online while trying to
fix my tags from my networked Windows box. Otherwise I would have used
EasyTag (http://easytag.sourceforge.net/) in Linux).



Glad you got it fixed - but if one of your mp3s isn't already attached to http://bugs.slimdevices.com/show_bug.cgi?id=4282 could you attach one? This might help the developers to fix the problem more permanently...

On Windows, I and many others use mp3tag for tagging.

As for the difficulty of using the debug flags, I quite agree. However from the look of http://bugs.slimdevices.com/show_bug.cgi?id=4293 this areas is about to be reworked anyway...

HTH
Ceejay

kyleki
2006-10-16, 08:14
Glad you got it fixed - but if one of your mp3s isn't already attached to http://bugs.slimdevices.com/show_bug.cgi?id=4282 could you attach one? This might help the developers to fix the problem more permanently...

Thanks for the pointer to the bug. I've just updated it with my experiences.

stinkingpig
2006-10-16, 10:35
On 10/16/06, ceejay <ceejay.2frerb1160983201 (AT) no-mx (DOT) forums.slimdevices.com>
wrote:
>
>
> As for the difficulty of using the debug flags, I quite agree. However
> from the look of http://bugs.slimdevices.com/show_bug.cgi?id=4293 this
> areas is about to be reworked anyway...
>
> HTH
> Ceejay
>
>
Oo, that's a very nice thing.
--
"I spent all me tin with the ladies drinking gin,
So across the Western ocean I must wander" -- traditional