View Full Version : Mandriva 2007 and YAML::Syck

2006-10-09, 19:12
I just upgraded to Mandriva 2007 and have having trouble starting slimserver

I complains about the module YAML::Syck failing to load, but when I try to compile it I get the following error:

Downloading YAML-Syck-0.64.tar.gz to: /usr/local/slimserver/Bin
/usr/bin/perl Makefile.PL
make: *** No rule to make target `/usr/lib/perl5/5.8.8/i386-linux/CORE/EXTERN.h', needed by `bytecode.o'. Stop.
Couldn't find a valid dynamic library for YAML-Syck-0.64.tar.gz - something is wrong. Exiting!
[root@localhost Bin]#

Also, I have installed the perl-Yaml-syck rpm from mandriva, but that doesn't seem to affect anything..


2006-10-11, 22:26
I am having the exact same problems with YAML::Syck.

Starting the slimserver I get the following error:

[root@localhost init.d]# ./slimserver start
Starting SlimServer: The following modules failed to load: YAML::Syck

To download and compile them, please run: /usr/local/slimserver/Bin/build-perl-modules.pl YAML::Syck

[ OK ]
[root@localhost init.d]#

I get the same error whether I use the RPM or the SlimServer_v6.5.0.tar.gz perl files. I have confirmed that version 0.67 of YAML::Syck is already installed on my system:

[root@localhost SlimServer_v6.5.0]# rpm -qa | grep YAML
[root@localhost SlimServer_v6.5.0]#

I tried to use the build-perl-modules.pl script to build the module but I got the exact same error as Xhorder in the above post.

I then ran the following perl code to see if I could load the YAML::Syck modlule:

# test loading of YAML module
use YAML::Syck
print "End of test.\n";

This was the output:

[lyndon@localhost ~]$ perl yaml-test.pl
End of test.
YAML::Syck version 1 required--this is only version 0.67 at /usr/lib/perl5/5.8.8/Exporter/Heavy.pm line 121.
BEGIN failed--compilation aborted at yaml-test.pl line 4.
[lyndon@localhost ~]$

It's weird that version 1 of YAML::Sync is required. AFAIK, the latest available version is 0.71.
(See http://search.cpan.org/dist/YAML-Syck/)

I have just bought a nice SilverStone media case that I am going to dedicate to the Slimserver. If anyone can help with this problem it would be much appreciated. In the meantime, I will revert back to 6.3.1.

Regards, Lyndon

2006-10-12, 02:07
Try removing the following directories in the SlimServer distribution:
Don't delete the system versions (/usr/lib/perl5)!

I had similar problems on Gentoo (except with YAML::Syck::Dumper) and the above fixed it. SlimServer seemed to be trying to load a mix of its own version and the system version of YAML::Syck, which broke. Removing SlimServer's own version got it behaving again.


2006-10-12, 19:15
I fixed my problem eventually by installing the perl-devel rpm.

Appartantly it wasn't part of my original install and I eventually found it after configuring rpmdrake to work with online mirrors.

2006-10-15, 00:54
Thanks guys,

I have finished the music server using version 6.3.1. I will try to test 6.5.0 on a different machine. To get 6.3.1 working with Mandriva Free 2007.0 I only needed to install two extra packages:


There seemed to be an issue with the versions however. Slim Server did not work with the newer version 2.x of SQLite.

I used a mini-itx board in a SilverStone LC-19 case. It's a nice setup as the board is fanless and virtually silent. Here is a photo.