PDA

View Full Version : 6.5.0 can't see network UNC paths anymore



Paul Forgey
2006-10-03, 22:38
Upgraded to 6.5.0 on Windows XP.

For as long as I can remember I've been running slimserver as a particular user with network access to where my mp3 files live.

I have slimserver using my iTunes library, which lives on a \\server\public\mp3 share, and is why I need to run the service as a particular user.

After installing 6.5.0 (and changing the account the service runs as and restarting it), this trick doesn't seem to work anymore. It scans in less than a minute and finds nothing to add. Additionally, my playlist folder is also on a network share and the web interface complains the path is not valid.

Is there any workaround or do I need to back out to the last release?

Paul Forgey
2006-10-07, 13:47
Tried 6.5.1 and the behavior is the same. Any ideas before I downgrade back to 6.3?

ceejay
2006-10-07, 13:51
Run with some debug flags and post the log file output?

Ceejay

Paul Forgey
2006-10-07, 14:37
which d_ flags? I turned on files, itunes, mysql, sql, paths, scan:

commit ineffective with AutoCommit enabled at C:\Program Files\SlimServer\server\CPAN/DBIx/Class/Storage/DBI.pm line 706.
Commmit ineffective while AutoCommit is on at C:\Program Files\SlimServer\server\CPAN/DBIx/Class/Storage/DBI.pm line 706.
ERROR: DBD::mysql::db commit failed: Commmit ineffective while AutoCommit is on at C:\Program Files\SlimServer\server\CPAN/DBIx/Class/Storage/DBI.pm line 706.

ERROR: Backtrace follows:

Backtrace:

frame 0: Slim::Schema::throw_exception (/PerlApp/DBIx/Class/Schema.pm line 606)
frame 1: DBIx::Class::Schema::txn_do (/PerlApp/Slim/Music/Import.pm line 241)
frame 2: (eval) (/PerlApp/Slim/Music/Import.pm line 233)
frame 3: Slim::Music::Import::setIsScanning (/PerlApp/Slim/Music/Import.pm line 152)
frame 4: Slim::Music::Import::launchScan (/PerlApp/Slim/Control/Commands.pm line 1941)
frame 5: Slim::Control::Commands::wipecacheCommand (/PerlApp/Slim/Control/Request.pm line 1485)
frame 6: (eval) (/PerlApp/Slim/Control/Request.pm line 1485)
frame 7: Slim::Control::Request::execute (/PerlApp/Slim/Control/Request.pm line 774)
frame 8: Slim::Control::Request::executeRequest (slimserver.pl line 955)
frame 9: main::checkDataSource (slimserver.pl line 414)
frame 10: main::init (slimserver.pl line 32)
frame 11: PerlSvc::Startup (perlsvc.pl line 1482)
frame 12: PerlSvc::_startup (slimserver.pl line 0)
frame 13: (eval) (slimserver.pl line 0)

There was an error while checking for updates to SlimServer:
Failed to connect to http://update.slimdevices.com/update/?version=6.5.1&lang=EN (Connect timed out)

SELECT me.name, me.value FROM metainformation me WHERE ( name = ? ): 'isScanning'
SELECT me.name, me.value FROM metainformation me WHERE ( name = ? ): 'isScanning'
SELECT me.name, me.value FROM metainformation me WHERE ( name = ? ): 'isScanning'
cracked: http://odie:9000/home.html?player=00%3A04%3A20%3A06%3A2f%3A3d with [odie],[9000],[/home.html?player=00%3A04%3A20%3A06%3A2f%3A3d]
SELECT me.name, me.value FROM metainformation me WHERE ( name = ? ): 'isScanning'
cracked: http://odie:9000/setup.html?page=BASIC_SERVER_SETTINGS&player=00%3A04%3A20%3A06%3A2f%3A3d with [odie],[9000],[/setup.html?page=BASIC_SERVER_SETTINGS&player=00%3A04%3A20%3A06%3A2f%3A3d]
SELECT me.name, me.value FROM metainformation me WHERE ( name = ? ): 'isScanning'
SELECT me.name, me.value FROM metainformation me WHERE ( name = ? ): 'isScanning'
SELECT me.name, me.value FROM metainformation me WHERE ( name = ? ): 'isScanning'
SELECT me.name, me.value FROM metainformation me WHERE ( name = ? ): 'isScanning'
SELECT me.name, me.value FROM metainformation me WHERE ( name = ? ): 'isScanning'
SELECT me.name, me.value FROM metainformation me WHERE ( name = ? ): 'isScanning'

ModelCitizen
2006-10-07, 14:39
Funny, but I found that upgrading to the latest 6.5.2 nightly reset my SlimServer account to local (whereas I normally run it under my administrator acount so it can access network shares). In addition it seemed to change the service startup to manual (should be automatic).
It sounds like you've done this but it's not completely clear... does your SlimServer service run under an account that has network privileges? To test, set it to your administrator account and see if it will scan your music. The UNC paths should be the correct ones to use.
MC

Paul Forgey
2006-10-07, 14:40
Yes, it's an account with specific network access to where the mp3 files are. It's also the same account iTunes runs as and is able to read/update/create/delete songs without any problem.

Paul Forgey
2006-10-07, 14:43
Hmmm... looks like after doing a clean uninstall, deleting the SlimServer folder, rebooting, then reinstalling things are starting to work now.