PDA

View Full Version : I want SS to ignore TPE2 / Album Artist tags?



Iznotgold
2006-10-03, 06:39
Is there a way to get Slim Server to ignore TPE2 / Album Artist tags?

I have had lots of 'Artists' disappear from my listings. From the investigations I've made - what appears to have happened is that I had WMP set to update media info from the internet but not over right existing data. What this appears to have done is insert into lots of tags additional TPE2 'Album Artist' data which in many cases it has gathered from compilation albums and not the original albums. Therefore, the 'Album Artist' is now listed as 'Various Artists'. Now I wouldn't have thought that that should be a problem except that for some reason Slim Server is giving priority to 'Album Artist' rather than 'Artist' and listing many of my artists now as 'Various Artists'.

Therefore, I would like to configure Slimserver to ignore 'Various Artists' or (in my mind what it should be doing anyway) give priority to the 'Artist' tag.

Any thoughts

luga00
2006-10-03, 06:45
I wonder if the designers at SD have considered having both AlbumArtist and Artist (track artist) in the browse and search menus. This would solve nearly all the artist listing dislikes that people experience.

R

slimpy
2006-10-11, 04:28
I don't like the idea of making adjustments to one program because another program has messed up the data the program works with.
Slimserver doesn't give priority to the album artist for non-compilation albums. What you're seeing is an unexpected behaviour due to the messed up information in your tags. You should definitely clean up your tags.

-s.

Iznotgold
2006-10-11, 07:23
Of course you're right...and I am slowly going through my tags....but a quick short-term fix would have been to be able to get SS to ignore the 'album artist' tags...I suspect I'm not alone in experiencing unexpected behaviour since upgrading to 6.5

I'm still not sure why SS gives priority to the 'Album artist' tag rather than the 'artist' tag. That is, why does SS insist on listing tracks as 'Various Artist' (due to there being an admittedly eroneous 'Album Artist' tag) when there is a perfectly good 'artist' tag for it to read?

Thanks for your response though...its appreciated.

slimpy
2006-10-11, 07:49
I suspect I'm not alone in experiencing unexpected behaviour since upgrading to 6.5
There were considerable changes made in 6.5 regarding the handling of compilation albums. For most users compilations are now handled correctly by slimserver. But then there are some who experience problems, just like you.


I'm still not sure why SS gives priority to the 'Album artist' tag rather than the 'artist' tag. That is, why does SS insist on listing tracks as 'Various Artist' (due to there being an admittedly eroneous 'Album Artist' tag) when there is a perfectly good 'artist' tag for it to read?
Is there a line "Compilation: YES" on the song info page for the songs/albums listed under Various artist?
If that's the case then slimserver thinks these albums are compilations and doesn't list them under each artist but under the 'Various artist' entry (coincidently the same as your ALBUMARTIST tags).
Another thought: What happens when you select "List albums by all artists for that album" (instead of "List albums by band") in Server settings - Behavior - Compilations?

-s.

Iznotgold
2006-10-11, 09:12
Slimpy - thanks for sticking with me on this one.

As previously said I'd had problems caused by 'Album Artist' tags being automatically updated by WMP (now disabled option)atributing tracks to compilation albums. I've subsequently gone through the collection removing this inaccurate data. But I was still having problems with None compilation albums being identified as compilation albums by SS. So as you say in the song info getting the result Compilation: Yes.

I was confounded by this because no tagging data was indicating this and the album folders were OK as should be. But thanks to your suggestions I have tracked down the problem, which goes like this: -

I have 36 genuine Bob Marley Album folders but SS was identifying several as compilations. But I also have a generic Bob Marley folder containing a few early ripped tracks, before I became systematic about ripping albums. In this folder were several tracks also in the seperate album folders. But these odd duplicate tracks had the artist listed as 'Bob Marley & the Wailers' where as the ripped albums had artist info as just Bob Marley. Therefore for a given album SS was listing the full album plus the duplicate track, there by creating multiple artists. I assume that this is how SS defines a compilation album and therefore gives it the dreaded Various Artist label.

Removing the duplicates and clear - rescanning resulted in no more compilation / various artists issues with these tracks. I now just have to track down any other instances where this will be causing me problems.

Once again thanks for your forbearance and once again it comes down to user error...doh!

kweller
2006-10-11, 14:01
I don't like the idea of making adjustments to one program because another program has messed up the data the program works with.
Slimserver doesn't give priority to the album artist for non-compilation albums. What you're seeing is an unexpected behaviour due to the messed up information in your tags. You should definitely clean up your tags.

-s.

Have I missed a change somewhere along the line? My MP3s are correctly tagged - the artist field contains the name of the artist. The album artist field contains 'Various Artists' for compilations and the name of the recording artist for the rest.

The problem I have now is that for compilation albums Slimserver is displaying <Artist>-<Track> by Various Artists from <Album>. I preferred the 6.3 version that displayed <track name> by <Artist> From <album>. The format I'm now seeing is irritating, in fact I think it's nonsense, but I can probably put up with it. What's giving me difficulties is that Slimscrobbler is now logging my tracks from compilation albums using Various Artists' as the artist name (presumably because that's what SS is now passing it). So I'm seeing 'messed up data' when there is nothing wrong with my tags.

Is the only solution to go back to 6.3?

EDIT: I looked in the Help but couldn't find anything that discusses this behaviour. I'm quite happy to read the relevant documentation if someone can point it out to me.

Thanks.

Kevin

slimpy
2006-10-11, 15:12
My MP3s are correctly tagged - the artist field contains the name of the artist. The album artist field contains 'Various Artists' for compilations and the name of the recording artist for the rest.
Why do you set the album artist to 'Various Artists'? I don't see any use for that. Get rid of those tags and you should be fine.
Some time ago there seemed to be a common misunderstanding that compilations need the album artist tag to be set this way to work properly. But that was several releases ago. Just make sure all tracks from the same album are in the same folder and slimserver will recognize them as compilation.

-s.

kweller
2006-10-11, 15:29
In article <slimpy.2fjauz1160604901 (AT) no-mx (DOT) forums.slimdevices.com>,
Slimpy wrote:
> Why do you set the album artist to 'Various Artists'? I don't see any
> use for that.

I use that within my tagging software to group all compilation albums
into the same folder tree.

I don't understand why that would cause a problem to Slimserver as the
artist is correctly set in the artist field.

Kevin

Ben Sandee
2006-10-11, 15:38
On 10/11/06, Kevin Weller <SlimDML (AT) thewellers (DOT) net> wrote:
>
> In article <slimpy.2fjauz1160604901 (AT) no-mx (DOT) forums.slimdevices.com>,
> Slimpy wrote:
> > Why do you set the album artist to 'Various Artists'? I don't see any
> > use for that.
>
> I use that within my tagging software to group all compilation albums
> into the same folder tree.
>
> I don't understand why that would cause a problem to Slimserver as the
> artist is correctly set in the artist field.


I use this feature to categorize all soundtracks into a separate VA-type
folder. I set the TPE2 to "Film Soundtracks", which creates an artist with
this name in the artist list.

Ben

slimpy
2006-10-11, 15:39
Do you have "List albums by band" selected in Server settings - Behavior - Compilations?
What happens if you change it to "List albums by all artists for that album"?

-s.

slimpy
2006-10-11, 15:51
I use this feature to categorize all soundtracks into a separate VA-type
folder. I set the TPE2 to "Film Soundtracks", which creates an artist with
this name in the artist list.
Fair enough.
Do you see the same behaviour Kevin describes?

-s.

slimpy
2006-10-11, 16:00
The problem I have now is that for compilation albums Slimserver is displaying <Artist>-<Track> by Various Artists from <Album>. I preferred the 6.3 version that displayed <track name> by <Artist> From <album>. The format I'm now seeing is irritating, in fact I think it's nonsense, but I can probably put up with it. What's giving me difficulties is that Slimscrobbler is now logging my tracks from compilation albums using Various Artists' as the artist name (presumably because that's what SS is now passing it). So I'm seeing 'messed up data' when there is nothing wrong with my tags.
Having reread your post I just realized that you seem to have a completely different problem than Iznotgold.
There's nothing wrong with how slimserver groups your albums but how it displays track information. Is that right?
Can you explain exactly where you see this odd formatting (squeezebox, web interface, skin you're using, etc.)
Please also post your formatting settings (Server settings - Formatting - Title format)

-s.

Iznotgold
2006-10-12, 03:37
Hi Slimpy,

I've ironed out the problems caused by poor tags and poor folder management on my part!

But there remains one unexpected behaviour of SS that I can't explain.

I want 'List all compilation Albums under each artist' to operate so have that selected under SS behaviour. If I then select 'List all Albums by all albums for that Artists' and then search: Artists/Various Artists and select 'Sort by Album' the result is exactly what I want/would expect. If however I sort by 'Artist, Album' it returns every artist and album in my collection.

Now if I still have 'List all compilation Albums under each artist' but select 'List by Band' and then search: Artists/Various Artists and select 'Sort by Album' the result is every artist in my collection. If however I sort by 'Artist, Album' it returns exactly what I want/would expect.

Now this is where it gets weird for me - if under either of the above circumstances I now select the 'Various Artists' link displayed to the left of the 'Sort' box. I get returned exactly what I want / expect with either sort by Album (I get a return of all my compilation albums) or sort by 'Artist, Album' (I get a return of all the artist in those compilation albums).

Am I misunderstanding how this feature works or is their an unexplained behaviour with initial search results dependant on the behaviour settings selected under SS - any thoughts?

slimpy
2006-10-12, 04:13
...or is their an unexplained behaviour with initial search results dependant on the behaviour settings selected under SS - any thoughts?
Looks like this is indeed a bug. I think that most people with 'List all compilation Albums under each artist' don't browse Various artists much as all those albums are listed under the respective artists anyway.
You may file a bug report under http://bugs.slimdevices.com

-s.

Iznotgold
2006-10-12, 04:38
Thanks Slimpy,

I have filed a bug report...at least I'm not going mad. Thanks for all your time...it's been appreciated!

Cheers

shabbs
2006-10-12, 13:21
My MP3s are correctly tagged - the artist field contains the name of the artist. The album artist field contains 'Various Artists' for compilations and the name of the recording artist for the rest.
I was under the impression that the "Album Artist" tag should ONLY be used for compilations that have various artists and that it should be populated with the value "Various Artists" for all the tracks on that album (or whatever value you want, it just has to be the same value for each track). For albums by a single artist, the "Album Artist" tag should be blank and the artist should only be listed in the "Artist" tag.

Is that not the correct use of the "Album Artist" tag? What does SS do with the Album Artist tag?

Cheers.

slimpy
2006-10-12, 14:34
I was under the impression that the "Album Artist" tag should ONLY be used for compilations that have various artists and that it should be populated with the value "Various Artists" for all the tracks on that album (or whatever value you want, it just has to be the same value for each track). For albums by a single artist, the "Album Artist" tag should be blank and the artist should only be listed in the "Artist" tag.

Is that not the correct use of the "Album Artist" tag? What does SS do with the Album Artist tag?
That's about as wrong as it could get. But this was a common misunderstanding by a lot of people some time ago.
The ALBUMARTIST (or TPE2 in ID3) tag can be used in different ways:
1) Compilations
A lot of compilations are compiled by some artist who doesn't necessarily contibuted as a track artist on the album. In this case you can use the album artist for that artist.
e.g. Blue Note Trip is a jazz compilation compiled by Jazzanova. Jazzanova goes into the album artist tag.
If you have "List albums by band" selected in Server settings - Behavior (together with "Group compilation albums together") then this album will show up under Artist - Various Artists like this:
"Blue Note Trip by Jazzanova" instead of "Blue Note Trip by Various artists". But not only will the compilation be listed under Various Artists but also under Artist - Jazzanova.
Note: Slimserver does not rely on the album artist tag to recognize an album as a compilation. If tracks within the same directory have the same album tag but different artist tags SS treats it as a compilation.

2) Regular albums
The album artist tag can be used to have an album listed under an artist who is not necessarily an artist on that album.
I use this primarily in cases such as this one:
I have some albums by Horace Silver but I also have two albums by The Horace Silver Quintet. All albums are tagged with their respective artist. If I want to listen to all my Horace Silver albums I would have to select all albums by Horace Silver and all by The Horace Silver Quintet. Now, if I tag all The Horace Silver Quintet albums with the album artist "Horace Silver" these albums are also listed under Horace Silver. When I play the album it still shows The Horace Silver Quintet.

-s.

shabbs
2006-10-12, 17:18
That's about as wrong as it could get.
So, then the guys over at HA are wrong?

http://wiki.hydrogenaudio.org/index.php?title=Foobar2000:Encouraged_Tag_Standard s#ALBUM_ARTIST

The madness continues...

slimpy
2006-10-13, 00:40
So, then the guys over at HA are wrong?

http://wiki.hydrogenaudio.org/index.php?title=Foobar2000:Encouraged_Tag_Standard s#ALBUM_ARTIST

No offense, but have you looked at the title? "Foobar2000:Encouraged Tag Standards"
We're not dealing with Foobar here. I merely described how things work in Slimserver. I couldn't care less for a standard proposed by a group of Foobar users as I have never used that program (and probably never will). Foobar seems to rely on this tag to properly recognize compilations. IMHO the use of the tag in the proposed way is just a workaround for one of the shortcomings of Foobar. Slimserver uses other criteria to detect compilations (see my previous post).
Please also note that the article doesn't mention any file or tag types. So I'm not sure to what files or tagging schemes this should be applied. There' also a difference in spelling: The article has it as "ALBUM ARTIST" (with space). I use "ALBUMARTIST" in vorbis comments (flac, ogg) and TPE2 in ID3 (mp3). I'm not even sure if "ALBUM ARTIST" is recognized in slimserver.

-s.

shabbs
2006-10-13, 05:26
I've been trying to isolate what's up with the Artist count in SS and where it pulls the data for it from. Part of that search has led me to this "Album Artist" tag (or "TPE2" or "Band" depending on the file format). Some new apps (WMP11b and iTunes7) seem to be populating it now. There seems to be a large difference of opinion on how this tag should be used wrt to VA. I don't want to code my tags "just for SS", I'd rather code them using the proper standard. The Foobar WIKI at HA I linked is just one example of a group trying to suggest a standard.

I'm just trying to sort though all the confusion. ;)

Slimpy - I appreciate the info.

Cheers.

JJZolx
2006-10-13, 10:02
I've been trying to isolate what's up with the Artist count in SS and where it pulls the data for it from. Part of that search has led me to this "Album Artist" tag (or "TPE2" or "Band" depending on the file format). Some new apps (WMP11b and iTunes7) seem to be populating it now. There seems to be a large difference of opinion on how this tag should be used wrt to VA. I don't want to code my tags "just for SS", I'd rather code them using the proper standard. The Foobar WIKI at HA I linked is just one example of a group trying to suggest a standard.

I'm just trying to sort though all the confusion. ;)
I don't think the issues are necessarily with the SlimServer's mistreatment of how the tags are to be used, or the way SlimServer recognizes compilations, or even who those albums or tracks are attributed to.

What's wrong is that the queries being used to list the library are badly broken. That's why the counts are off. That's why artists are missing, and why compilations often aren't displayed in their proper place. I also think there's a lot of confusion about how the compilation options should affect the listing of albums and artists.

slimpy
2006-10-13, 10:25
What's wrong is that the queries being used to list the library are badly broken. That's why the counts are off. That's why artists are missing, and why compilations often aren't displayed in their proper place. I also think there's a lot of confusion about how the compilation options should affect the listing of albums and artists.
What is your conclusion based on? I agree that the counts are dubious sometimes. But all the problems with missing artists and misplaced compilations I've seen since the release of 6.5 have always turned out to be some sort of tagging problem.
The compilation options are indeed not very easy on the user. The corresponding wiki page is also outdated. I might make an update attempt next week, time permitting.

-s.

Iznotgold
2006-10-13, 10:32
Shabba I have great sympathy with your position.

Only by experimenting and asking questions have I begun to understand how SS handles tag information, particularly in relation to the 'Album Artist' tag.

I also think that there is an issue with how SS handles this information specifically with WMA files.

Today I created an mp3 file and a wma file each was tagged with only the basic 'Artist', 'Track' & 'Album' info. I then moved them to my monitored music folder and rescanned with SS. The two new files were correctly identified by SS and could be searched for by either 'Artist', 'Track' or 'Album'.

I then added 'various artists' using the 'Album Artist' tag to each file and did a clear - rescan. The result was that SS seemed to ignore the 'album artist' tag for the mp3 file and it could still be found using either 'Artist', 'Album' or 'Track.

However, the WMA file had dissappeared from the Artist listing - it couldn't be located by either the original artist details or within various artists details. It could be found via the 'album' tag where it is now is shown as 1 album with 1 song by 2 artists - also the artist could be found using the search music function.

The Song Info displayed by SS does however show the correct information as tagged.

shabbs
2006-10-13, 11:27
I then added 'various artists' using the 'Album Artist' tag to each file and did a clear - rescan. The result was that SS seemed to ignore the 'album artist' tag for the mp3 file and it could still be found using either 'Artist', 'Album' or 'Track.
Did you enable the COMPILATION tag?

Cheers.

broth420
2006-10-19, 13:06
to get this to work. my album count, artist count, song count was accurate in 6.3. Now, in 6.5.1, my library is jacked. I would like to get it to work correctly. I ripped all albums using Easy CD DA. I modified the tags either with Media Monkey or Tag & Rename. I do have "Various Artists" in the "Album Artist" section, for albums that were compliations albums (like AM Gold 1969, movie soundtracks, etc).
Do I need to take out the tag, and if so, how. Just leave the section blank? Or do I need to reconvert the entire lot. I use .flac files, for the most part, but i have an mp3 album I created out of singles. What gets me the most is that the MP3 files seem fine. The flac files are what are jacked. For a detailed description of what I am experiencing, please see this post (http://forums.slimdevices.com/showthread.php?t=26576&page=3) . I have been trying to figure this out since 6.5 came out. I have a 500GB, 20,000 song library, it takes forever to unistall 6.3, reinstall 6.5, scan, find out it is still broken, and then uninstall 6.5 and go back to 6.3 and do it all over again. I have basically had it. I would really like to fix this problem.

Roy
2006-10-19, 13:31
Broth

Like you I have been struggling with this one since 6.5

I stumbled on this solution which might work for you

In your flac files create a tag called wm/albumartist and populate it with the artist name - I used MP3tag really easy to do.

Do a complete clear and rescan and see if it solves your problem - I have absolutly no idea why it worked for me - it just did

roy

broth420
2006-10-19, 19:33
Is there a good place to go for instructions in the use of that program. I am a little confused as to what I need to do.

slimpy
2006-10-20, 02:03
I do have "Various Artists" in the "Album Artist" section, for albums that were compliations albums (like AM Gold 1969, movie soundtracks, etc).
Do I need to take out the tag, and if so, how. Just leave the section blank? Or do I need to reconvert the entire lot.
Remove all album artist tags from the flac files. I've made a quick test with mp3Tag (free, download from here http://www.mp3tag.de/en/index.html ).
After installation load your library and select all files then go to menu Convert - Actions.
Click the "New Configuration" icon, give a name (e.g. remove ALBUMARTIST),
click on "New Configuration" icon in Action window,
select "Remove fields" from the dropdown menu,
enter ALBUMARTIST;ALBUM ARTIST (or whatever the name of the album artist field actually is) in the "Fields to remove" dialog.
Mark the checkbox for the newly created action and click ok. mp3Tag now removes all tags with the given names from the selected files.

I have been trying to figure this out since 6.5 came out. I have a 500GB, 20,000 song library, it takes forever to unistall 6.3, reinstall 6.5, scan, find out it is still broken, and then uninstall 6.5 and go back to 6.3 and do it all over again. I have basically had it. I would really like to fix this problem.
Why don't you just create a small sample library away from your regular library? A rescan will be much faster and you don't have to uninstall and reinstall over and over.

-s.

Mark Lanctot
2006-10-20, 06:24
Is there a good place to go for instructions in the use of that program. I am a little confused as to what I need to do.

If you're referring to Mp3tag, take a look here:

http://wiki.slimdevices.com/index.cgi?Mp3tagGuide

It's not specific to this particular problem, but it will give you an idea. slimpy's complete instructions should help you out with this issue.

slimpy
2006-10-20, 06:33
In your flac files create a tag called wm/albumartist and populate it with the artist name
Where did you find this solution? I've never heard of that tag before.
What file types do you use?

-s.

shabbs
2006-10-20, 06:35
Where did you find this solution? I've never heard of that tag before.
What file types do you use?
Looks like a Windows Media-specific tag.

broth420
2006-10-23, 06:43
After stripping out the ALBUMARTIST and ALBUM ARTIST tags with MP3Tag, I noticed that I had another artist field in mp3 only tags called BAND. I removed that as well. Then I tried it again, and it was a little better, but still several hundred artists are gone (800 about). I then looked at my compliation albums that I ripped in FLAC, and there was another field, called ENSEMBLE, with Various Artists in it. I removed this as well from all files. I rescanned again, and it was better, but I still was missing 600 artists. I gave up, reinstalled 6.3 and rescanned again. Now, I have a bunch of albums that are cut up. All are various artists albums, and I could not figure out what the heck is wrong with them. I restored the old, unedited files that worked fine, and rescanned. Same problem. All my compilation albums messed up. I would have three albums with the same name, with 4 or 5 tracks in each one. All the tracks and artists were there, but I suddenly had 70 more albums.
I was baffled, so I decided to remove all my playlists and rescan again. Once the playlists were removed, my libary returned to normal. I then put the playlists back in the correct folder, and had SS just scan the playlists. Everything was fine.
Sorry about the long story, but I am getting to the point....
Finally, I reinstalled 6.5.1, removed the playlists again, and scanned. MY LIBARY DATABASE IS CORRECT!!

But...when I click on the artist "Various Artist" it shows all my albums (not just the compilations). I click on any album, the contents are blank. Click on "various artists" in the path above (Home/artists/various artists/...). I get all my compliations. And they are browsable.
And...When I add the playlists back in, the library loses almost 700 artists.

Side Notes.
1. I do have a track artist called "Various Artists" on one album. I may change this and see what happens.
2. I used Easy CD DA to encode all flac files, and Windows Media Player (I didn't know any better :)) to encode the older mp3 files.

kweller
2006-11-05, 08:28
In article <slimpy.2fjc0n1160606401 (AT) no-mx (DOT) forums.slimdevices.com>, Slimpy
wrote:
> Do you have "List albums by band" selected in Server settings - Behavior
> - Compilations?
> What happens if you change it to "List albums by all artists for that
> album"?

Sorry for the long delay in replying. Life has been very hectic lately and
I was in the US for a couple of weeks.

It looks like the problem was with 6.5. I've just updated Slimserver to the
latest 6.5.1. nightly and all the tags are now being read as expected.

Thanks for trying to assist me.

Kevin