View Full Version : play request goes to save playlist

2006-10-02, 22:10
I am having problems with my Squeezebox 2 play button. Many times when I push play after browsing for the artist I want to listen to, nothing happens. Sometimes when I push play a second time, the selected music begins to play. Other times, subsequent pushes of the play button result in going to the save playlist menu. I can back out of the menu and push play again and it goes back into the save playlist menu again. If I fiddle with the thing by pushing stop, play, and moving around in menus, pretty soon I get it to work. There are also times when I turn on the squeezebox and it seems to work perfectly. The problem occurs very frequently when a song is playing and I try to play a different song in the playlist.

I have softsqueeze running on another PC and do not ever see this problem when playing music using softsqueeze.

My current setup has slimserver running on a Debian Linux box: SlimServer Version: 6.5b1 - 8806 - Debian - EN - iso-8859-1. Firmware version 59 is running on the squeezebox 2. However, I have also seen the problem occur when running the server on Windows XP (slimserver version 6.2.0).

I know there is newer software/firmware available and plan to upgrade, however, since this problem existed across two OS's, two slimserver version levels, and does not occur when using softsqueeze, I didn't think a software upgrade was going to help.

I love having my music available with the push of a remote button and would like to put several squeezeboxes aroundthe house. Getting them for my kids will prevent my CD collection from being destroyed. Unfortunately, my family is relunctant to use the thing when it acts strangely so I need to get this problem solved. Thanks for any help you can give.

2006-10-03, 00:06
First, you should upgrade the software, the latest nightly 6.5.1 is significantly improved over what you have. I agree it probably won't fix your problem, but do it anyway - it ensures you are on the same page as people who may be trying to help you.

Second, it sounds like a problem with your remote. Obvious first step - change the batteries!

If that doesn't work, you might want to investigate the hypothesis that the play button on your remote is faulty. Look up the "custom.map" feature and map another button that you don't use very often to have the play function.

If that doesn't work, report back and someone will suggest something else!


2006-10-03, 07:40
Thanks for the reply Ceejay; I will follow your advice and report back.

2006-10-12, 08:29
I put in new batteries and upgraded the slimserver software to version 6.5.0 for debian. The remote problem was still present. I noticed a comment in the release notes for 6.5.0 about a change made concerning remote button pushing time and heavy fingered users. I then tried pushing and releasing the play button very quickly and so far this fixes the problem. I've also had some problems with the fast forward/skip function but pushing/releasing these buttons quickly seems to solve that issue as well. When the play button didn't react as initially described, the natural tendency was to push it harder which held it down longer making the problem worse. I can see why the fast forward/skip buttons have a time contraint because their function changes as a result of hold down time. I would expect the play button to be less sensitive to time. I don't even know if it should ever go to save playlist as a result of pushing the play button. I'll check the documentation on this one.

I really have to make an effort to release the button quickly to make it work correctly. Although it's certainly usable this way, I would like to have it feel a little more natural for pushing a remote button and am surprised no one else has experienced this. Hopefully it will keep working and this is not just a fluke. So far so good.

2006-10-12, 09:06
I don't even know if it should ever go to save playlist as a result of pushing the play button.
That's exactly how the play button works. Normal press = play, long press = save playlist
The long press is defined in SavePlaylist.pm, the save playlist plugin. Just disable the plugin and you can press the play button as long as you like ;)


2006-10-12, 20:43
Thanks for the reply. It is good to know that play is supposed to work this way; I just need to be a little quicker fingered. It might be nice to be able to configure the button press delay like you can for mouse button double clicks and such. I'm just happy it seems to be working correctly.