PDA

View Full Version : slimserver installation on ubuntu 6.06



thoeng
2006-10-01, 21:55
how do i install slim server on ubuntu ?? i downloaded slim server for linux (format .rpm) and double click here shows error saying archive file is not supported . I guess i don't have "winrar" for linux ?? if so where can i get it. THanks guys help appreciated.



Cheers,

ERin

smc2911
2006-10-01, 21:56
I use the deb package on my Ubuntu machine: http://wiki.slimdevices.com/index.cgi?DebianPackage

thoeng
2006-10-01, 23:32
Er .. how do i download the package mate ?? it seems no links link to the file

tyler_durden
2006-10-02, 00:07
You must follow the instructions here:

http://wiki.slimdevices.com/index.cgi?DebianPackage

There are .deb packages for i386 and AMD64 linux. I have personal experience with the AMD64 package- it works.

Read the instructions carefully. Linux is not windows, so you don't just DL a file and run it. Installations are handled by aptitude (apt), or the synaptic package manager. You have to edit the etc/apt/sources.list to point to the location of the file. Then you can either use the command line apt-get a shown on the web page linked above, or open the synaptic package manager from the menu on the desktop and use it to grab and install the package.

The advantage of using the package manager is that it detects and automatically loads other packages that are required for the one you want to work. If you decide to uninstall later, you can do so cleanly using the package manager. It also notifies you of available updates.

TD

thoeng
2006-10-03, 04:20
hello thanks for the respond guys however i am very new to ubuntu (like 2 days) and i don't understand any terminology on ubuntu, could you please show me how to download and install slimserver for ubuntu on steps ?i'd be grateful as i miss my squeezebox for 3days now :(


Cheers mate for the help i'd greatly appreciate it

ERin.

smc2911
2006-10-03, 04:47
Try the following (you will be prompted for your password):


sudo nano /etc/apt/sources.list

which will edit the list of sources (download locations) for the apt-get package manager. You will need to add the following line:


deb http://debian.slimdevices.com stable main

Also, find the two lines that end in 'multiverse' and delete the # from the start of each line (if there is one). Then save the file.
Then type the following:


apt-get update
apt-get install slimserver

thoeng
2006-10-03, 06:51
sudo nano / etc/apt/sources.list ----> does open nano "console" but i do not know where to paste ( i do deleted 2# of multiverse
lines.)
RIght now my nano's outcome:

deb http://au.archive.ubuntu.com/ubuntu/ dapper main restricted
deb-src http://au.archive.ubuntu.com/ubuntu/ dapper main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://au.archive.ubuntu.com/ubuntu/ dapper-updates main restricted
deb-src http://au.archive.ubuntu.com/ubuntu/ dapper-updates main restricted
HERE ???


## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
# deb http://au.archive.ubuntu.com/ubuntu/ dapper universe
# deb-src http://au.archive.ubuntu.com/ubuntu/ dapper universe
# deb http://debian.slimdevices.com stable main
HERE ??


## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
HERE ???

deb http://security.ubuntu.com/ubuntu dapper-security main restricted
deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted
# deb http://security.ubuntu.com/ubuntu dapper-security universe
# deb-src http://security.ubuntu.com/ubuntu dapper-security universe
HERE ??


also get apt-get update says that permission is denied (13 permission) any hint ??

or best way perhaps you could mail me the files needed to install ?? :( i really miss my squeezebox.



Try the following (you will be prompted for your password):


sudo nano /etc/apt/sources.list

which will edit the list of sources (download locations) for the apt-get package manager. You will need to add the following line:


deb http://debian.slimdevices.com stable main

Also, find the two lines that end in 'multiverse' and delete the # from the start of each line (if there is one). Then save the file.
Then type the following:


apt-get update
apt-get install slimserver

smc2911
2006-10-03, 16:28
Apologies, use
sudo apt-get update
sudo apt-get install slimserver
instead.

But first, uncomment the following from sources.list, i.e. remove # from

# deb http://au.archive.ubuntu.com/ubuntu/ dapper universe
# deb-src http://au.archive.ubuntu.com/ubuntu/ dapper universe
# deb http://debian.slimdevices.com stable main

to

deb http://au.archive.ubuntu.com/ubuntu/ dapper universe
deb-src http://au.archive.ubuntu.com/ubuntu/ dapper universe
deb http://debian.slimdevices.com stable main

and see how you go.

thoeng
2006-10-03, 20:02
thx mate !! it works now !!
would you mind to explain to me what just have i done with "nano" and "#" ?? and how would i update with new version next time ?? should i just type "sudo apt-get install slimserver" ??

thanks mate you really save my day !!

thoeng
2006-10-03, 20:32
ugh .. still problem ... downloaded complete and installation halted saying that there is a problem with mysql here is the report

eri@eri:~$ slimserver
061004 11:30:21 [ERROR] Can't start server: Bind on TCP/IP port: Address already in use
061004 11:30:21 [ERROR] Do you already have another mysqld server running on port: 9092 ?
061004 11:30:21 [ERROR] Aborting

061004 11:30:21 [Note] /usr/sbin/mysqld: Shutdown complete

2006-10-04 11:30:51.8337 ERROR: MySQLHelper: createSystemTables() Couldn't connect to database: [Can't connect to local MySQL server through socket '/home/eri/Cache/slimserver-mysql.sock' (2)]

thoeng
2006-10-06, 09:30
allright guys now i eventually managed to download it (fheuhh at last !! )

Now, i still need to know what to fill in music directory section ? hows the format of linux for example on windows i type : d:/music and d:/music/playlist for playlists.

i tried with /media/hda2/music but the folder does not recognized by slimserver

my harddisk now is in 3 partition (C:/ for windows NTFS, D:/ for media files FAT32, /root for linux EXT3)

thanks for the reply

Ben Sandee
2006-10-06, 09:43
On 10/6/06, thoeng <thoeng.2f9lsb1160152501 (AT) no-mx (DOT) forums.slimdevices.com>
wrote:
>
>
> allright guys now i eventually managed to download it (fheuhh at last !!
> )
>
> Now, i still need to know what to fill in music directory section ?
> hows the format of linux for example on windows i type : d:/music and
> d:/music/playlist for playlists.
>
> i tried with /media/hda2/music but the folder does not recognized by
> slimserver
>
> my harddisk now is in 3 partition (C:/ for windows NTFS, D:/ for media
> files FAT32, /root for linux EXT3)


You need to mount your music partition somewhere in your filesystem. In
Ubuntu it's probably easiest for you to use the System->Adminstration->Disks
application to do this.

HTH,

Ben

thoeng
2006-10-06, 10:08
Hi and thanks again for the express reply however i tried to access media disc, would you mind to teach me how to mount my music folder ??
however i think its already mounted because its recognized by linux and i can access it by GUI.

i tried to put "/dev/hda2/music" but "Opps /dev/hda2/music doesn't seems to be valid directory. Try again." keep popping up :(

help please!!

ERin.

Ben Sandee
2006-10-06, 11:22
On 10/6/06, thoeng <thoeng.2f9nen1160154601 (AT) no-mx (DOT) forums.slimdevices.com>
wrote:
>
>
> Hi and thanks again for the express reply however i tried to access
> media disc, would you mind to teach me how to mount my music folder ??
>
> however i think its already mounted because its recognized by linux and
> i can access it by GUI.


I see. I expect what you actually have is a permissions problem. See this
wiki entry here:

https://help.ubuntu.com/community/AutomaticallyMountPartitions

I suspect you may need to add these options to your vfat/fat32 mount point
in your /etc/fstab file:

user,auto,fmask=0111,dmask=0000

This will give all users access to the files. Because SlimServer runs as
the user 'slimserver' you need to make sure that this user has permission to
read the files on the music partition.

Ben

thoeng
2006-10-06, 22:30
Hello there,

i tried follow the wiki and mount it but it seems all drives has been already mounted since i am able to access all my music on my former "D" on windows music are also running fine (by xmms) but the only problem is that what should i write in folder file ( i don't know linux writing format of my music folder)
i wrote /media/hda2/music but can't

thoeng
2006-10-06, 22:37
I also tried to edit the fstab file and add code as you wrote but it says that i am not the owner of the file and therefore i can't edit it :( my user is eri and i am the owner of course but it says there the owner is "root" i don't know how to log in as root to edit the file



On 10/6/06, thoeng <thoeng.2f9nen1160154601 (AT) no-mx (DOT) forums.slimdevices.com>
wrote:
>
>
> Hi and thanks again for the express reply however i tried to access
> media disc, would you mind to teach me how to mount my music folder ??
>
> however i think its already mounted because its recognized by linux and
> i can access it by GUI.


I see. I expect what you actually have is a permissions problem. See this
wiki entry here:

https://help.ubuntu.com/community/AutomaticallyMountPartitions

I suspect you may need to add these options to your vfat/fat32 mount point
in your /etc/fstab file:

user,auto,fmask=0111,dmask=0000

This will give all users access to the files. Because SlimServer runs as
the user 'slimserver' you need to make sure that this user has permission to
read the files on the music partition.

Ben

aubuti
2006-10-08, 21:07
I also tried to edit the fstab file and add code as you wrote but it says that i am not the owner of the file and therefore i can't edit it :( my user is eri and i am the owner of course but it says there the owner is "root" i don't know how to log in as root to edit the file
If Ubuntu 6.06 is like earlier versions, you just use "sudo" to gain root privileges. So you would go to a command line and type "sudo nano /etc/fstab". It would then prompt you for a password, and as long as you're the one who installed Ubuntu, you can just give your usual password and it will let you in as root. You will then be in the text editor "nano", with /etc/fstab open for editing. Be careful, because root is the all-powerful user, so it's possible to muck things up if you're not careful.

thoeng
2006-10-09, 00:36
allright sudo allow me to edit /etc/fstab file now but i still can't use slimserver (although its running and SB display clock from system's clock fine) /dev/hda2/music is said not to be valid folder.

how can i check if the problem is really permission to write on music folder? is there possibility on other problem ?

frustrate now for almost a week.


ERin.

aubuti
2006-10-09, 01:31
Please type the "mount" command and post the output here. That will tell us where your filesystems are mounted. Also, change to the directory where you think your music library is (/dev/hda2), type the command "ls -l" and post the output here. That will tell us the permissions on the top-level folder of your library.

As you're new to Ubuntu, it would be a really good idea to spend some time at www.ubuntuforum.org to learn more about it, and/or get a book on Ubuntu. Otherwise you'll be frustrated for a lot more than a week.