PDA

View Full Version : Trouble with Song Titles



jlg84
2006-10-01, 18:53
I have my Squeezebox set to access my iTunes songs (using SlimServer 6.5.0, a MacBookPro and iTunes 7.0.1), and ever since upgrading to SS 6.5.0 my song titles on many of my genres are just listed as "1", no song title at all. They look fine in iTunes, and though I have rescanned my library they continue to be listed on "Now Playing" as all being called "1", regardless of their track number, etc. Any ideas how to fix this?

SteveEast
2006-10-02, 15:21
What does iTunes say about the underlying filename? Any clue there?

Have you looked at the tags for one of the failing tracks with something other than iTunes?

Steve.

jlg84
2006-10-03, 01:15
I checked the song titles in Finder and they are all correct, though I have now removed the number that preceded the track names in each song's file (seemed to be the track order number). Incidentally, whereas I thought this was only happening with my Chinese-language tracks, it is in fact happening to all my tracks, regardless of the language that their track name is in. All are listed as "1" in the "Now Playing" dialog.

SteveEast
2006-10-03, 07:34
Selecting "Keep iTunes Music Folder organized" causes the track number to be put at the start of the filename.

Have you looked at the tracks with a tag editor?

Don't know much about Macs, but are you in a non-US/European locale?

Steve.

jlg84
2006-10-04, 16:20
I'm in China; does that have an effect on my song titles? By the way, even in the Web interface the songs are all called "1". Very strange...

jlg84
2006-10-05, 16:28
I have tried to use a tag editor but to no avail. As I said earlier, the song titles were working just fine before I upgraded to v. 6.5 of the server software.