PDA

View Full Version : Cover art files



adhawkins
2006-09-29, 09:15
Hi all,

Can someone tell me what Slimserver expects in terms of cover art files?
I've currently got a cover.jpg file in my album directories, which is
something like 300x300 or 500x500. This file shows up once I drill down all
the way into an album directory.

However, for some of my albums I don't get any cover art shown in the
'Browse Album' view of the default skin when I have it in 'Gallery View'

Can anyone tell me what I should be doing? Should I also have a smaller
dimension file for this view?

Thanks

Andy

kdf
2006-09-29, 09:26
Quoting Andy Hawkins <andy (AT) gently (DOT) org.uk>:

> Hi all,
>
> Can someone tell me what Slimserver expects in terms of cover art files?

http://wiki.slimdevices.com/index.cgi?AlbumArtwork

> I've currently got a cover.jpg file in my album directories, which is
> something like 300x300 or 500x500. This file shows up once I drill down all
> the way into an album directory.
>
> However, for some of my albums I don't get any cover art shown in the
> 'Browse Album' view of the default skin when I have it in 'Gallery View'
>
> Can anyone tell me what I should be doing? Should I also have a smaller
> dimension file for this view?

many things can happen. If you have tracks from teh same album in
different folders, various artists, etc. you can turn on d_artwork in
server settings->debugging and run a "clear library" scan to see what
is going on when teh server compiles the artwork cache. Gallery view
uses this cache, whereas browsing to an album of folder is able to
seek for artwork on the fly.

-kdf

adhawkins
2006-09-29, 09:41
Hi,

In article <20060929092636.3g8ktrzfcw8wkogc (AT) www (DOT) deane-freeman.com>,
kdf<slim-mail (AT) deane-freeman (DOT) com> wrote:
> many things can happen. If you have tracks from teh same album in
> different folders, various artists, etc. you can turn on d_artwork in
> server settings->debugging and run a "clear library" scan to see what
> is going on when teh server compiles the artwork cache. Gallery view
> uses this cache, whereas browsing to an album of folder is able to
> seek for artwork on the fly.

I'm gradually transitioning over to all my music being in FLAC files
containing an entire CD (with embedded CUE sheet). It's these that I'm
primarily interested in, the rest will hopefully sort itself out as I
re-rip.

For multi-disc sets, I tend to put all the FLAC files in the same directory,
so I'd have:

FLAC/Various Artists/Compilation/Compilation (CD 1).flac
FLAC/Various Artists/Compilation/Compilation (CD 2).flac
FLAC/Various Artists/Compilation/cover.jpg

most of my music is:

FLAC/Artist/Album/Artist - Album.flac
FLAC/Artist/Album/cover.jpg

I'll try to run a re-scan with d_artwork set and see what it gives me.

I was after more 'general' advice than anything though. Should it 'work'
with just one cover.jpg for each album, or do I need a 'smaller' one for the
thumbnails on the browse pages?

Thanks

Andy

radish
2006-09-29, 10:12
It should work just fine with a single image - that's what I have - but I've seen reports of issues with the new 6.5.0 server version.

kdf
2006-09-29, 10:13
Quoting Andy Hawkins <andy (AT) gently (DOT) org.uk>:

> I was after more 'general' advice than anything though. Should it 'work'
> with just one cover.jpg for each album, or do I need a 'smaller' one for the
> thumbnails on the browse pages?

cover.jpg is all you'll need. the server can resize the image for
sending as a smaller file for the gallery view.

-kdf

adhawkins
2006-09-29, 12:11
Hi,

In article <radish.2ewoyz1159550101 (AT) no-mx (DOT) forums.slimdevices.com>,
radish<radish.2ewoyz1159550101 (AT) no-mx (DOT) forums.slimdevices.com> wrote:
> It -should- work just fine with a single image - that's what I have -
> but I've seen reports of issues with the new 6.5.0 server version.

Ok, I'll see what happens them.

One thing I hadn't realised was that the cover art in the 'list' views is
cached as a result of a scan, whereas the image displayed when you 'dig
down' into an album is shown on the fly.

Now that my latest scan has finished I seem to be seeing coverart in both
places.

I'll keep an eye one it, thanks for the help (from everyone) thus far.

Andy

Bradley
2006-09-29, 15:23
I only see cover art on drilling down to an album. The gallery pages show nothing. I use FLAC files with a cover.jpg file in each album directory.

letalis
2006-10-02, 11:59
This is exactly the problem I wrote about in another thread
http://forums.slimdevices.com/showthread.php?t=27810

Running gentoo.

letalis
2006-10-02, 12:04
After reading this thread I deleted the entire contents of my cache directory, double checked permissions and did a rescan and voila - all covers are back!