View Full Version : Need help please SS won't start

2006-09-28, 08:58
Been working on this for the last 2 days and no luck, please help.

Here's what captured from Event Viewer:

The description for Event ID ( 0 ) in Source ( Application ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Undefined subroutine &main::init called at slimserver.pl line 32.

From command line starting slim.exe:

Can't locate Audio/WMA.pm in @INC (@INC contains: C:\Program Files\SlimServer\server C:\Program Files\SlimServer\server\CPAN\arch\5.8\MSWin32-x86-multi-thread C
:\Program Files\SlimServer\server\CPAN\arch\5.8\MSWin32-x86-multi-thread\auto C:
\Program Files\SlimServer\server\CPAN\arch\5.8.8\MSWin32-x86-multi-thread C:\Pro
gram Files\SlimServer\server\CPAN\arch\5.8.8\MSWin32-x86-multi-thread\auto C:\Pr
ogram Files\SlimServer\server\CPAN\arch\5.8\MSWin32-x86-multi-thread C:\Program
Files\SlimServer\server\CPAN\arch\5.8\MSWin32-x86-multi-thread\auto C:\Program F
iles\SlimServer\server\CPAN\arch\MSWin32-x86-multi-thread C:\Program Files\SlimS
erver\server\lib C:\Program Files\SlimServer\server\CPAN C:/Program Files/SlimSe
rver/server C:/Program Files/SlimServer/server C:\Program Files\SlimServer\serve
r) at /PerlApp/Slim/Utils/Scanner.pm line 32.
BEGIN failed--compilation aborted at /PerlApp/Slim/Utils/Scanner.pm line 32.
BEGIN failed--compilation aborted at /PerlApp/Slim/Control/Commands.pm line 40.
BEGIN failed--compilation aborted at /PerlApp/Slim/Control/Request.pm line 415.
BEGIN failed--compilation aborted at /PerlApp/Slim/Player/Client.pm line 19.
BEGIN failed--compilation aborted at /PerlApp/Slim/Buttons/Common.pm line 44.
BEGIN failed--compilation aborted at slimserver.pl line 114.
Undefined subroutine &main::main called at slimserver.pl line 58.

2006-09-28, 10:31
This sounds like a bad installation or corrupt slim.exe or something of that nature. Audio::WMA should be built in to slim.exe as far as I know. Have you possibly tried completely removing SlimServer? (Remove through add/remove programs, then ensure the Program Files\SlimServer folder has been removed) and reinstalling?

2006-09-28, 10:50
> Been working on this for the last 2 days and no luck, please help.

What server version? Update or clean install? Windows binary or
ActiveState Perl?



http://www.herger.net/SlimCD - your SlimServer on a CD
http://www.herger.net/slim - AlbumReview, Biography, MusicInfoSCR

2006-09-28, 19:40

I did that quite a few times (uninstall/reboot/clear directory). I again tried the same thing last night and for some reason it started from the command line (not the task tray) and I didn't have the chance to thoroughly test it but am keeping my fingers crossed.

2006-09-28, 22:18
I had problems with SS not starting when I first installed 6.5 on Win XP. I found that switching out the firewall solved the problem.

I then made sure that all slimserver related apps were included in the firewall permissions. I think it was down to problems with connection by the scanner to Localhost at startup.

Worth a try