PDA

View Full Version : SlimServer 6.5.1 on NSLU2 Install problem



christophb
2006-09-24, 12:46
I am using UNSLUNG V2.3R63-uNSLUng-6.8-beta and had a successfull installation of SS 6.3.1. It could be started but unfortunately it didn't scan my files with success (see German Forum http://forums.slimdevices.com/showthread.php?t=27479).

So as 6.5.0 is there I tried to install it:
- I did'nt remove or uninstall anything
- ipkg update
- ipkg install mysql (mysql starts successfully)
- install files from tarball-archive as described in WiKi
- build-perl-modules.pl (see log attached)
When I start slimserver.pl --daemon I get the following messages:
# slimserver.pl --daemon
Can't locate auto/Compress/Zlib/autosplit.ix in @INC (@INC contains: /usr/local/SlimServer_v6.5.0/CPAN/arch/5.8/armv5b-s
oftfloat-linux /usr/local/SlimServer_v6.5.0/CPAN/arch/5.8/armv5b-softfloat-linux/auto /usr/local/SlimServer_v6.5.0/CPAN/
arch/5.8.8/armv5b-softfloat-linux /usr/local/SlimServer_v6.5.0/CPAN/arch/5.8.8/armv5b-softfloat-linux/auto /usr/local/Sl
imServer_v6.5.0/CPAN/arch/5.8/armv5b-softfloat-linux /usr/local/SlimServer_v6.5.0/CPAN/arch/5.8/armv5b-softfloat-linux/a
uto /usr/local/SlimServer_v6.5.0/CPAN/arch/armv5b-softfloat-linux /usr/local/SlimServer_v6.5.0/lib /usr/local/SlimServer
_v6.5.0/CPAN /usr/local/SlimServer_v6.5.0 /usr/local/SlimServer_v6.5.0 /opt/lib/perl5/5.8.8/armv5b-linux /opt/lib/perl5/
5.8.8 /opt/lib/perl5/site_perl/5.8.8/armv5b-linux /opt/lib/perl5/site_perl/5.8.8 /opt/lib/perl5/site_perl .) at /opt/lib
/perl5/5.8.8/AutoLoader.pm line 160.
at /usr/local/SlimServer_v6.5.0/CPAN/Compress/Zlib.pm line 15

Has anybody an idea?

Thanks!

Christophb

abagos
2006-09-25, 22:11
From the logfile I see that you haven't changed the script "build_perl_modules.pl" in the way that is descibed here: http://www.nslu2-linux.org/wiki/Applications/SlimServer . You also need to put /opt/bin/perl as the path to the perl executable. Other hints to run 6.5 on Unslung can be found here: http://forums.slimdevices.com/showthread.php?t=26723

christophb
2006-09-29, 14:37
Now I have changed the build-perl-modules.pl AND renamed the SlimServer directory to /usr/local/slimserver so the perl interpreter starts and does find the which files.

But now I get a similar error already in the build process:
Downloading Compress-Zlib-1.41.tar.gz to: /root
Can't locate auto/Compress/Zlib/autosplit.ix in @INC (@INC contains: /usr/local/slimserver/CPAN CPAN /opt/lib/perl5/5.8.8/armv5b-linux /opt/lib/perl5/5.8.8 /opt/lib/perl5/site_perl/5.8.8/armv5b-linux /opt/lib/perl5/site_perl/5.8.8 /opt/lib/perl5/site_perl .) at /opt/lib/perl5/5.8.8/AutoLoader.pm line 160, <STDIN> line 3.
at /usr/local/slimserver/CPAN/Compress/Zlib.pm line 15
Uncompressing..
Configuring..

Nevertheless the build is done, but it doesn't run. I get the same error as posted in the first entry of my post.

bpa
2006-09-29, 15:02
Doe database scan finish OK with correct counts of artists, genres etc ?

Verify that each module built is actually OK by running make test.

e.g.
cd /root
cd Compress-Zlib-1.33
make test

Not all test pass in some modules - compare test results against similar build on a PC.

christophb
2006-09-30, 03:34
Now I tested:
cd /root/Compress-Zlib-1.41
# PATH=$PATH:/opt/armeb/bin
# export PATH
# echo $PATH
/sbin:/bin:/usr/sbin:/usr/bin:/opt/bin:/opt/sbin::/opt/armeb/bin
make test
<...>
All tests successful.
Files=6, Tests=305, 27 wallclock secs (21.04 cusr + 3.55 csys = 24.59 CPU)

As I saw, the make test runs in /root/Compress-Zlib-1.33 without modifying the PATH. Could there be some conflicts between the two versions of Compress-Zlib? Should I (but how do I?) deinstall the 1.33 version?

The Server doesn't scan anything because it does not start because of the error with autosplit.

I attached the build script and a list of the installed packages.

bpa
2006-09-30, 03:48
The Compress-Zlib was an example - you should try "make test" with EVERY module built by build-perl-modules but start with the DBI and DBD ones.

The "make test" knows about possibility of other versions and only uses the one in the directory.

Can you post the log (plenty of lines before and after as well) with the error that you see about "autosplit".

christophb
2006-09-30, 04:23
Thanks for your assistance!

I did the build again and attach the log.
(Does the script log it on disk or must I always copy/paste from telnet window?)

Finally it displays: All done!

But when I start the slimserver I get the same error:
# cd /usr/local/slimserver
# ./slimserver.pl --daemon --prefsfile /etc/slim-data/slimserver.pref --cachedir /etc/slim-data
Can't locate auto/Compress/Zlib/autosplit.ix in @INC (@INC contains: /usr/local/slimserver/CPAN/arch/5.8/armv5b-softfloa
t-linux /usr/local/slimserver/CPAN/arch/5.8/armv5b-softfloat-linux/auto /usr/local/slimserver/CPAN/arch/5.8.8/armv5b-sof
tfloat-linux /usr/local/slimserver/CPAN/arch/5.8.8/armv5b-softfloat-linux/auto /usr/local/slimserver/CPAN/arch/5.8/armv5
b-softfloat-linux /usr/local/slimserver/CPAN/arch/5.8/armv5b-softfloat-linux/auto /usr/local/slimserver/CPAN/arch/armv5b
-softfloat-linux /usr/local/slimserver/lib /usr/local/slimserver/CPAN /usr/local/slimserver /usr/local/slimserver /opt/l
ib/perl5/5.8.8/armv5b-linux /opt/lib/perl5/5.8.8 /opt/lib/perl5/site_perl/5.8.8/armv5b-linux /opt/lib/perl5/site_perl/5.
8.8 /opt/lib/perl5/site_perl .) at /opt/lib/perl5/5.8.8/AutoLoader.pm line 160.
at /usr/local/slimserver/CPAN/Compress/Zlib.pm line 15
#

bpa
2006-09-30, 05:25
In this case the missing autosplit.ix should be part of your system perl and not part of slimserver. Try to locate it using

find /usr/local -name autosplit.ix

as it may hold a clue to some path problems. I guess your starting directory but it may be different.

To eliminate build-perl-module as possible source of your 6.5 problem you MUST run the "make test" on each module that you build i.e. on each of the following:
Compress-Zlib-1.41
DBI-1.50
DBD-mysql-3.0002
Digest-SHA1-2.11
HTML-Parser-3.48
Template-Toolkit-2.14
Time-HiRes-1.86
XML-Parser-2.34
YAML-Syck-0.64

Although the DBD ones will mainly fail because no MySql server running - the errors message may still help.

fth
2006-09-30, 13:16
I had the same problem, missing autosplit.ix, and I tried quite a few different things before I finally solved the problem as follows:

cd /etc/slim-data/Compress-Zlib-1.41
perl Makefile.PL
make
make install

After this, build-perl-modules.pl finished without errors.

Now, if I only could figure out how to set the correct rights for the "slim" user I have created for slimserver...

Anyway, I hope this helps!

/fth

christophb
2006-10-02, 03:19
Thanks to fth the error in build-perl-modules.pl is gone.

When I start slimserver I don't get the error anymore, but it seems to do nothing. I don't find a slimserver process with ps.
Where can I find some error log?

And:
How to create a user account with its user rights?
How to start slimserver under this account?

Thanks in advance!

christophb

fth
2006-10-02, 05:56
> When I start slimserver I don't get the error anymore, but
> it seems to do nothing. I don't find a slimserver process
> with ps.Where can I find some error log?
This is probably because you can't start slimserver with root anymore. Try starting slimserver without the --daemon parameter, this way you can see all the error messages (look for mysqld errors concerning "root").

> How to create a user account with its user rights?
I created a user called "slim" using the usual NSLU2 management web page. You can also do this from the command line.

> How to start slimserver under this account?
Add the parameter --user slim (or whatever you called your slimserver account)

Now for the tricky part: granting the correct rights to the slimserver account. This is where I am stuck... I have managed to get slimserver to start by chown /etc/slimdata to the slim user, but I can't get slimserver to find any music.

I have unslung my NSLU2 to a 1GB flash drive in USB2, and I have two 300GB Maxtor OneTouch drives connected (via a hub) to USB1. The shares for the Maxtors are /share/hdd/data/HDD_1_1_1 and HDD_1_2_1, but when I enter this in the "Music catalogue" setting, slimserver doesn't find any music. I have also tried placing a symlink to my music on Maxtor #1 in the /public catalogue, but slimserver doesn't interpret this as a directory.

Could any of you Linux experts write a short guide on how to set up a slimserver account with the correct rights, and how to get slimserver to find music on another drive?

/fth

christophb
2006-10-04, 14:24
Now, as the build is without errors (only warnings), I executed the "chown -R slim <directory>" on /usr/local/slimserver and /etc/slim-data.
Then I started slimserver with "--user slim" and get the following error:
2006-10-04 23:11:30.7575 ERROR: MySQLHelper: startServer() Couldn't find a executable for 'mysqld'! This is a fatal error. Exiting.

But mysql is installed and running!!

Any ideas?

christophb

abagos
2006-10-04, 22:30
Now, as the build is without errors (only warnings), I executed the "chown -R slim <directory>" on /usr/local/slimserver and /etc/slim-data.
Then I started slimserver with "--user slim" and get the following error:
2006-10-04 23:11:30.7575 ERROR: MySQLHelper: startServer() Couldn't find a executable for 'mysqld'! This is a fatal error. Exiting.

But mysql is installed and running!!

Any ideas?

christophb

You have to make sure that the "mysqld" executable is found by the slimserver. It can be found in /opt/libexec which is not in the PATH. So you have to options:

a) Add /opt/libexec to the PATH
or
b) Symlink mysqld to a directory which is in the PATH (/opt/sbin for example)

Any of the two will do.

And by the way, you don't need to have mysql running because slimserver will start its own instance (you don't want it to consume your valuable RAM). So you can stop it and disable it in /opt/etc/init.d (remove the exec bit from the scripts).

christophb
2006-10-06, 14:23
Thanks for the advices!

I did the following:
1. stopped mysql with ./opt/etc/init.d/S70mysqld stop
2. Added /opt/libexec to the PATH
3. chown -R slim /usr/local/slimserver
4. chown -R slim /etc/slim-data
5. started slimserver with the following results:

# ./slimserver.pl --user slim --prefsfile /etc/slim-data/slimserver.pref --cachedir /etc/slim-data --d_server --d_scan
2006-10-06 23:11:38.6189 SlimServer OSDetect init...
2006-10-06 23:11:38.7386 SlimServer OS Specific init...
2006-10-06 23:11:38.7461 SlimServer saving pid file.
2006-10-06 23:11:38.7879 SlimServer settings effective user and group if requested...
2006-10-06 23:11:38.9682 SlimServer settings init...
2006-10-06 23:11:39.8675 SlimServer strings init...
2006-10-06 23:11:47.9190 SlimServer Setup init...
2006-10-06 23:11:49.0661 SlimServer setting language...
2006-10-06 23:11:49.0772 SlimServer MySQL init...
061006 23:11:54 [ERROR] /opt/libexec/mysqld: unknown variable 'innodb_fast_shutdown=1'

2006-10-06 23:12:23.9135 ERROR: MySQLHelper: createSystemTables() Couldn't connect to database: [Can't connect to local MySQL server through socket '/etc/slim-data/slimserver-mysql.sock' (2)]

2006-10-06 23:12:23.9934 Got to the END.
2006-10-06 23:12:24.0034 Got sigint.
2006-10-06 23:12:24.0070 SlimServer cleaning up.
#

Anybody knows the next steps?

bpa
2006-10-06, 14:36
You need to disable the innodb shutown option in my.tt as unslung MySql does not support innoDB.

See this thread from post #15 onwards


http://forums.slimdevices.com/showthread.php?t=26723&page=2

dang100
2006-10-12, 14:14
I am having a similar problem to fth. I can get slimserver to start but cannot get it to scan my music. I am using unslung 6.8 and have only one disk connected to USB port 2.

When I click the rescan music library button from the web interface I get the following error in the log (I started slimserver with the following debug options d_server, d_mysql, d_parse and d_scan).

2006-10-12 22:06:02.8544 SlimServer done init...
2006-10-12 22:08:19.9326 Setup::rescan - initiating scan of type: [rescan]
The following modules failed to load: DBD::mysql DBI HTML::Parser XML::Parser::Expat YAML::Syck

To download and compile them, please run: /usr/local/SlimServer_v6.5.0/Bin/build-perl-modules.pl DBD::mysql DBI HTML::Parser XML::Parser::Expat YAML::Syck

Exiting..

I believe all of the perl modules built correctly but this error log implies that this is not the case. Any suggestions as to how to fix this are gratefully received.

Thanks, dang

indexx
2007-02-03, 05:00
same problem as dang 100 has here on my nslu2.

starting slimserver 6.5.1 runs fine but when i rescan the music files the log says:


2007-02-03 12:06:33.7257 Setup::rescan - initiating scan of type: [rescan]
2007-02-03 12:06:40.4224 commit ineffective with AutoCommit enabled at /usr/local/SlimServer_v6.5.1/CPAN/DBIx/Class/Storage/DBI.pm line 706.
2007-02-03 12:06:40.4205 Commmit ineffective while AutoCommit is on at /usr/local/SlimServer_v6.5.1/CPAN/DBIx/Class/Storage/DBI.pm line 706.
2007-02-03 12:06:40.6095 ERROR: DBD::mysql::db commit failed: Commmit ineffective while AutoCommit is on at /usr/local/SlimServer_v6.5.1/CPAN/DBIx/Class/Storage/DBI.pm line 706.

2007-02-03 12:06:40.6120 ERROR: Backtrace follows:

2007-02-03 12:06:41.1244 Backtrace:

frame 0: Slim::Schema::throw_exception (/usr/local/SlimServer_v6.5.1/CPAN/DBIx/Class/Schema.pm line 606)
frame 1: DBIx::Class::Schema::txn_do (/usr/local/SlimServer_v6.5.1/Slim/Music/Import.pm line 241)
frame 2: (eval) (/usr/local/SlimServer_v6.5.1/Slim/Music/Import.pm line 233)
frame 3: Slim::Music::Import::setIsScanning (/usr/local/SlimServer_v6.5.1/Slim/Music/Import.pm line 152)
frame 4: Slim::Music::Import::launchScan (/usr/local/SlimServer_v6.5.1/Slim/Control/Commands.pm line 1714)
frame 5: Slim::Control::Commands::rescanCommand (/usr/local/SlimServer_v6.5.1/Slim/Control/Request.pm line 1483)
frame 6: (eval) (/usr/local/SlimServer_v6.5.1/Slim/Control/Request.pm line 1483)
frame 7: Slim::Control::Request::execute (/usr/local/SlimServer_v6.5.1/Slim/Control/Request.pm line 772)
frame 8: Slim::Control::Request::executeRequest (/usr/local/SlimServer_v6.5.1/Slim/Web/Setup.pm line 1428)
frame 9: Slim::Web::Setup::__ANON__ (/usr/local/SlimServer_v6.5.1/Slim/Web/Setup.pm line 2893)
frame 10: Slim::Web::Setup::processChanges (/usr/local/SlimServer_v6.5.1/Slim/Web/Setup.pm line 2647)
frame 11: Slim::Web::Setup::setup_HTTP (/usr/local/SlimServer_v6.5.1/Slim/Web/HTTP.pm line 824)
frame 12: Slim::Web::HTTP::generateHTTPResponse (/usr/local/SlimServer_v6.5.1/Slim/Web/HTTP.pm line 690)
frame 13: Slim::Web::HTTP::processURL (/usr/local/SlimServer_v6.5.1/Slim/Web/HTTP.pm line 536)
frame 14: Slim::Web::HTTP::processHTTP (/usr/local/SlimServer_v6.5.1/Slim/Networking/Select.pm line 238)
frame 15: (eval) (/usr/local/SlimServer_v6.5.1/Slim/Networking/Select.pm line 238)
frame 16: Slim::Networking::Select::select (./slimserver.pl line 492)
frame 17: main::idle (./slimserver.pl line 445)
frame 18: main::main (./slimserver.pl line 1071)

The following modules failed to load: DBD::mysql DBI HTML::Parser XML::Parser::Expat YAML::Syck

To download and compile them, please run: /usr/local/SlimServer_v6.5.1/Bin/build-perl-modules.pl DBD::mysql DBI HTML::Parser XML::Parser::Expat YAML::Syck

Exiting..

can anyone help?

indexx

slimnick
2007-03-08, 11:40
Hi Indexx

It might not help, but I'm currently playing around with installing 6.5.1 on the NSLU2 and I too get the same error as you when trying to scan my library of FLACs.

I'll let you know if I find a solution. Otherwise I hope someone out there has some pointer on what to try next.

Nick.

geir pettersen
2007-03-22, 01:44
I have the same problem (Commmit ineffective while AutoCommit is on..) Has anyone found a solution?

slimnick
2007-03-22, 14:51
After some research I did get SlimServer 6.5.1 running on my NSLU with an external USB hard-drive. However, once running SlimServer and MySQL use way more memory than the NSLU has on-board, and I found the swap file was thrashing so much that it was unusably slow.

I am now attempting a similar installation on a brand new LinkStation pro and expect it to work much better due to it having 4 times the memory of the NSLU and a faster CPU. Anyway, for the curious, here is my installation log from setting-up SlimServer 6.5.1 on the NSLU:

INSTALLING SLIMSERVER 6.5.1 ON DEBIAN ON NSLU
==============================================
1. Install Debian using these instructions:
http://www.cyrius.com/debian/nslu2/

Partitions:
1. Primary: 7.0Gb - /
5. Logical: 256Mb - SWAP
6. Logical: Remainder - /home

Set-up region details, root password, and standard user.

When prompted for package selections, chose 'File Server'.

Enter Samba workgroup as 'mshome'.
Modify smb.conf to use WINS settings from DHCP? - Yes

Reboot and log-in over SSH as root

mkdir /home/music
mkdir /home/music/flac
mkdir /home/music/playlists

chmod 777 /home/music/flac
chmod 777 /home/music/playlists

mv /etc/samba/smb.conf /etc/samba/smb.conf.bak
vi /etc/samba/smb.conf

<-- SNIP -->
[global]
# workgroup = NT-Domain-Name or Workgroup-Name
workgroup = MSHOME

# server string is the equivalent of the NT Description field
server string = Samba Server

# Security mode. Most people will want user level security. See
# security_level.txt for details.
security = share

[Shared Files]
path = /usr/local/music
writeable = yes
browseable = yes
guest ok = yes
<-- SNIP -->

/etc/init.d/samba restart

At this point, the SAMBA share appears on my Windows PC as a shared folder and I can copy some music onto it.

Install slimserver 6.5.1:
=========================
cd /home
wget http://debian.slimdevices.com/pool/main/s/slimserver/slimserver_6.5.1_all.deb
wget http://debian.slimdevices.com/pool/main/libf/libfile-bom-perl/libfile-bom-perl_0.11-1_all.deb
wget http://debian.slimdevices.com/pool/main/libr/libreadonly-perl/libreadonly-perl_1.03-1_all.deb
wget http://debian.slimdevices.com/pool/main/libe/libenum-perl/libenum-perl_1.016-1_all.deb
wget http://debian.slimdevices.com/pool/main/libt/libtie-cache-lru-perl/libtie-cache-lru-perl_0.21-1_all.deb
wget http://debian.slimdevices.com/pool/main/libt/libtie-llhash-perl/libtie-llhash-perl_1.003-1_all.deb
wget http://debian.slimdevices.com/pool/main/libt/libtie-cache-lru-expires-perl/libtie-cache-lru-expires-perl_0.54-1_all.deb
wget http://debian.slimdevices.com/pool/main/libd/libdata-vstring-perl/libdata-vstring-perl_0.000-003-1_all.deb
wget http://debian.slimdevices.com/pool/main/libx/libxml-simple-perl/libxml-simple-perl_2.15-1_all.deb
wget http://debian.slimdevices.com/pool/main/libx/libxml-xspf-perl/libxml-xspf-perl_0.5.1-1_all.deb
wget http://debian.slimdevices.com/pool/main/libm/libmpeg-audio-frame-perl/libmpeg-audio-frame-perl_0.09-1_all.deb
wget http://debian.slimdevices.com/pool/main/libn/libnet-upnp-perl/libnet-upnp-perl_1.2.1-1_all.deb
wget http://debian.slimdevices.com/pool/main/libd/libdbix-migration-perl/libdbix-migration-perl_0.05-1_all.deb

dpkg -i libdata-vstring-perl_0.000-003-1_all.deb libdbix-migration-perl_0.05-1_all.deb libenum-perl_1.016-1_all.deb libfile-bom-perl_0.11-1_all.deb libmpeg-audio-frame-perl_0.09-1_all.deb libnet-upnp-perl_1.2.1-1_all.deb libreadonly-perl_1.03-1_all.deb libtie-cache-lru-expires-perl_0.54-1_all.deb libtie-cache-lru-perl_0.21-1_all.deb libtie-llhash-perl_1.003-1_all.deb libxml-xspf-perl_0.5.1-1_all.deb libxml-simple-perl_2.15-1_all.deb
apt-get install mysql-server-5.0
dpkg -i slimserver_6.5.1_all.deb
apt-get -f install
dpkg -i slimserver_6.5.1_all.deb

Upgrade MySQL to fix library scanning bug (this takes 24 hours!):
------------------------------------------------------------------

apt-get gcc make libncurses5-dev g++

wget http://www.mirrorservice.org/sites/ftp.mysql.com/Downloads/MySQL-5.0/mysql-5.0.37.tar.gz

tar -zxvf mysql-5.0.37.tar.gz
cd mysql-5.0.37
./configure;make;make install

mv /usr/sbin/mysqld /usr/sbin/mysqld.old
cp /usr/local/libexec/mysqld /usr/sbin/mysqld

rm *all.deb

[Reboot]

Now point your browser at the following location to set-up the SlimServer using the browser-based interface:

http://LKG2C2BD2:9000/

Done!