PDA

View Full Version : Scans forever without finding music files on installation



KGemmell
2006-09-24, 10:16
I am trying to upgrade to 6.5, but everytime I try it starts scanning my files for hours before finally reporting no songs, albums etc. If I try to browse during the scan nothing shows up either. I've read the other posts about scanning issues, but I don't know SQL at all and am not sure what I can do. I reinstalled 6.22 and everything is fine again.

I am running Windows XP Home with about 18000 files all in flac format, streaming to 2 Sqeezebox 3's. The only third party program I am running is Music Magic 1.7

Any suggestions would be really appreciated!

gandt
2006-09-24, 10:57
a) delete the music folder location entirely - leave it blank just "use musicmagic" - it should be faster anyway
b) make sure that musicmagic reload time (on the musicmagic menu) is set to ) - no reload. Im pretty sure the reload doesnt work properly anyway
c) make sure musicmagic is finished processing
d) make sure there are no symbolic links anywhere being accidentally "picked up" by slimserver includes playlists folder


I cant say all the above is scientific but they are all things I ended up doing to get my system working properly and all or some of them may work for you


good luck

finally this sould work within 10-15 minutes tops if you are not seeing entries by then then i think it will turn out to be some "paths" issue which others are better qualified than me to explain

CouchPotatoe
2006-09-24, 11:14
Hmm - I might have the same issue then... How quickly does the
Settings> Information>Library Statistics plugin info now update and do
you have to leave and re-enter the plugin for updates ? I know my
library scan takes huge amounts of time - 36 hours or so - but it has
generally worked eventually in 6.3. I have just upgraded to 6.5 and it
is indexing and has been for 4 hours or so but my library stats are all
still zero, as are the web pages. I can see the network activity as it
accesses my NAS so I am thinking it's still working ... Is it not
possible to update the plugin library stats in (near) realtime as before
? I used to be able to leave the plugin on screen on a player and see
the number of songs increasing so I knew it was getting somewhere and I
could estimate how long it was going to take as I knew how big the
library was.

gandt wrote:
>
> finally this sould work within 10-15 minutes tops if you are not seeing
> entries by then then i think it will turn out to be some "paths" issue
> which others are better qualified than me to explain
>
>
>

gandt
2006-09-24, 12:37
which is pretty quick - without it id say it can take nearly an hour before i start to see anything on my 23,000 song library

KGemmell
2006-09-24, 14:32
Thanks for your help. I'm afraid I have some basic questions about your response -sorry for my ignorance. I know how to delete the music folder location, but where do I tell it to "use musicmagic"? Also, what musicmagic menu are you referring to to set the reload time? I see where you can do these things with ITunes, but not musicmagic.

Thanks!



which is pretty quick - without it id say it can take nearly an hour before i start to see anything on my 23,000 song library

gandt
2006-09-24, 14:50
are you running the api service information musicip? its under preferences services i think then
a start slimserver
b on server settings general there should be a use musicmagic button to tick after this clear and rescan
c you should also find a musicmagic option on the server menu - above plugins i think- thats where you can disable the reload

KGemmell
2006-09-24, 16:11
That solved all the problems. I had the API checked, but either didn't start it in the right order or something. It seems to be scanning my files at a reasonable rate, and I can access those already scanned. Not to mention all the increased functionality with the increased communication with MusicIP. Before I was just making mixes and playlists and then sending them to Slimserver.

Thanks for your help.