PDA

View Full Version : playlists missing after upgrade to v6.5



kremersl
2006-09-24, 02:46
I uninstalled v6.3 and installed v6.5. I cleared cache from firefox browser and most things works as previously. The only issue left is: about half of my playlists i used to have in v6.3 are missing. Any idea what may cause this ?

Claus-DK
2006-09-24, 05:46
I uninstalled v6.3 and installed v6.5. I cleared cache from firefox browser and most things works as previously. The only issue left is: about half of my playlists i used to have in v6.3 are missing. Any idea what may cause this ?

I have the same problem.

After an upgrade all playlists are found but the content in the playlists is not.

Could this be a bug?

Regards
Claus

pechspilz
2006-09-24, 06:25
Same here. Although some playlists have some content but they're not complete. I already rescanned the whole collection.

Claus-DK
2006-09-24, 06:36
I just submitted a bug report:

http://bugs.slimdevices.com/show_bug.cgi?id=4211

I hope not that giving it a P1 priority is seen as too much. I did it because my three SB3s almost only play streaming radio and since all my radio steams are saved in playlists they are no longer available.

Regards
Claus

Siduhe
2006-09-24, 06:41
A few questions to try and pin the problem down ?

What OS ?
What format are the files that are missing ?
Are they music files or just radio streams ?
What format is the playlist - how did you create it ?
Can you see the files (that are missing from the playlists) in the Music Library ? Can you play them independently of the playlist ?
Are you using Itunes or MusicMagic (MusicIP) to manage your music library ?
Are any of the files in a different place to the box where Slimserver is installed ?


Basically anything that could identify why some files are affected and not others.

lostboy
2006-09-24, 06:51
SS 6.5 build 9916 on both win 2000 and XP.

.pls playlists appear in the browse playlists window, but appear to have only one entry (the first) or none. I've tried this with both file and stream entries - same behaviour.

.m3u playlists seem OK, both basic and extended types.

BTW I converted my .pls playlists to .m3u using winamp (media library) - provided a workaround for my lists of streams.

Chris

kremersl
2006-09-24, 07:23
In my case:

What OS ?
-windows 2003 server

What format are the files that are missing ?
-flac

Are they music files or just radio streams ?
-music files, no radio streams

What format is the playlist - how did you create it ?
-m3u; all created in slimserver v6.3. that makes it so weird, i see NO difference whatsoever in what i have done to a set of playlist that DOES appear now in v6.5 and the ones that DONT.

Can you see the files (that are missing from the playlists) in the Music Library ?
-yes

Can you play them independently of the playlist ?
-yes

Are you using Itunes or MusicMagic (MusicIP) to manage your music library ?
-no

Are any of the files in a different place to the box where Slimserver is installed ?
-yes, my music library points to an external harddisk connected with usb to pc. But again: this applies to all my playlist (all in the same subdirectory) so doesn't explain why some do and some don't work.

btw, the playlists that don't work show 'empty' on the squeezebox display once selected

kremersl
2006-09-24, 07:35
decided to open my playlists with notepad to see what is inside.
i think i've found the issue (though not sure if that is slimserver issue or not). It seems each track has a 'hardcoded' path in the m3u list (for example D:\bla\bla). As these points to a previous location (d-drive) i had selected on my pc (i have since changed the location of the music archive to an external harddisk which is f-drive) it makes sense why they don't work anymore.
The only reason some still work is that I kept some albums as backup on my pc in the 'old directory' on the d-drive, so while i thought these working playlists pointed to my f-drive, they still manage to find the backup songs on the d-drive.

So, as far as i'm concerned no bug in v6.5.
However, now my next question is: how can I make sure when I create playlists in slimserver v6.5 that somehow they are not pointing to a 'hardcoded' f-drive ? is there an option for that. Because it means that every time i decided to change the location of my music archive, all my playlists are useless?

anotherron
2006-09-24, 11:54
I am having the same problems with a .pls file that just contains radio links. The complete contents of the file are:

[playlist]
NumberOfEntries=3
File1=http://216.235.81.103:15036
Title1=WMNF
Length1=-1
File2=http://mp3.wusf.usf.edu:8000
Title2=WUSF
Length2=-1
File3=http://wusfhd2.wusf.usf.edu:8064
Title3=WUSF2
Length3=-1
Version=2

This file worked under 6.3.1.

Ben Sandee
2006-09-24, 13:38
On 9/24/06, anotherron <
anotherron.2enk9n1159124101 (AT) no-mx (DOT) forums.slimdevices.com> wrote:
>
>
> I am having the same problems with a .pls file that just contains radio
> links. The complete contents of the file are:
>
> [playlist]
> NumberOfEntries=3
> File1=http://216.235.81.103:15036
> Title1=WMNF
> Length1=-1
> File2=http://mp3.wusf.usf.edu:8000
> Title2=WUSF
> Length2=-1
> File3=http://wusfhd2.wusf.usf.edu:8064
> Title3=WUSF2
> Length3=-1
> Version=2
>
> This file worked under 6.3.1.


Could be this bug:

http://bugs.slimdevices.com/show_bug.cgi?id=4092

Playlists with multiple embedded URL's are not completely supported from the
playlist folder. If you use the 'tune in' or the My Picks OPML plugin
instead it works fine.

Ben

Siduhe
2006-09-25, 02:04
It seems each track has a 'hardcoded' path in the m3u list (for example D:\bla\bla). As these points to a previous location (d-drive) i had selected on my pc (i have since changed the location of the music archive to an external harddisk which is f-drive) it makes sense why they don't work anymore.

So, as far as i'm concerned no bug in v6.5.

However, now my next question is: how can I make sure when I create playlists in slimserver v6.5 that somehow they are not pointing to a 'hardcoded' f-drive ? is there an option for that. Because it means that every time i decided to change the location of my music archive, all my playlists are useless?

Playlist files aren't dynamic. They are just a set of hard links to your music. So if you create a playlist file in an application that sees the file path as F:\, that's how the path will appear in the playlist. If you move your music library around the only think I can suggest is to find and replace the old file path with the new one. You can either do this in a text editor or a playlist manager. I use this one: http://www.joejaworski.com/m3u/

You just point it at a playlist file and tell it to replace "F:\Music\Media" with "D:\My Music", save the new file and do a Rescan Playlists only scan in slimserver.

bernt
2006-09-25, 04:34
Same problem here.
Playlist shows up empty in SB.

OS Windows XP

Playlist made with notepad. File extension pls.
Radio streams only.

Worked fine in 6.3.1.

Marc Sherman
2006-09-25, 05:35
kremersl wrote:
>
> So, as far as i'm concerned no bug in v6.5.
> However, now my next question is: how can I make sure when I create
> playlists in slimserver v6.5 that somehow they are not pointing to a
> 'hardcoded' f-drive ? is there an option for that. Because it means
> that every time i decided to change the location of my music archive,
> all my playlists are useless?

Vote for this bug:
http://bugs.slimdevices.com/show_bug.cgi?id=781

In the interim, you'll have to write a script to fix up your playlists
next time you move your music folder.

- Marc

Siduhe
2006-09-25, 05:46
Same problem here.

Playlist made with notepad. File extension pls.
Radio streams only.

Worked fine in 6.3.1.

See Ben's post above. Playlists with multiple URL's don't work in 6.5. A good alternative is the MyPicks plugin.

http://bugs.slimdevices.com/show_bug.cgi?id=4092

anotherron
2006-09-26, 06:20
Thanks, I'll try it

ipodscool
2006-09-26, 11:49
For the record, and after numerous installs / upgrades, I now expect difficulties to some degree. To soften the potential devastation to my precious music & playlists I've compiled a reinstall pack.

This pack, although personal to me, includes all the prerequisite settings such as:

Playlists location;
Plugins (beware of any reinstalling any redundant plugin when changing versions);
lame encoder;
mplayer.exe (although not essential since AlienBBC now includes this for v6.5)
backup of all playlists;
plugin logins / passwords;
player formatting

This list is by no means exhaustive but it may help others to know that this generally serves me well. I intend to compile a definitive list of necessary files & settings soon & post in the forums. Good idea?

The most common filepath which I tend to forget is that to my iTunes music & playlists. A fresh reinstall usually points to

C:\Documents and Settings\ADMINISTRATOR\My Documents\My Music\iTunes\.....

In my case, these files are in:

C:\Documents and Settings\OWNER\My Documents\My Music\iTunes\.....
I strongly suspect that this has caught many others out also!

Simon