PDA

View Full Version : sleep function with SlimServer 6.5.0



edc1
2006-09-23, 15:00
I've just upgraded to SlimServer 6.5.0 - 9916 and my Squeezebox is now running version 64 of the firmware. In the change log for this release there is change to the way the sleep function works. (Change 2151.) You can now set the Squeezebox to sleep at the end of the current song.

The problem I have with this is that lots of my MP3 are 2 hours long or more. The 'sleep at end of song' works fine if your playing files that are only a few minutes in length. But if I start a file playing that's 2 hours long. When I use the sleep button the Squeezebox tells me it'll go to sleep in 120 minutes. And that's the only time delay that it'll do.

Is there any way to enable the old pre-6.5.0 sleep behaviour? Or have the ability to switch off 'sleep at end of song' so it switches off mid-song?

Ben Sandee
2006-09-23, 15:23
On 9/23/06, edc1 <edc1.2elyeb1159049101 (AT) no-mx (DOT) forums.slimdevices.com> wrote:
>
>
> The problem I have with this is that lots of my MP3 are 2 hours long or
> more. The 'sleep at end of song' works fine if your playing files that
> are only a few minutes in length. But if I start a file playing that's
> 2 hours long. When I use the sleep button the Squeezebox tells me it'll
> go to sleep in 120 minutes. And that's the only time delay that it'll
> do.


For me, the first option is sleep at end of song but then it goes to 15 min,
30min, 60min, 120min, etc. Maybe there's a problem that only manifests if
the current song is longer than 15min,30min,etc.? Does sleep work right for
you for a 3min song?

Ben

edc1
2006-09-23, 16:08
sleep works as you describe for a song that's shorter than 15 minutes. end of song, 15 minutes, 30, 45, 60, 90 then sleep canceled. If I start playing a track that is say 22 minutes long I get. sleep in 22 minutes, 30, 45, 60, 90 then sleep canceled. With a track of 65 minutes I get sleep in 65 minutes, sleep in 90 minutes then sleep canceled.

So it seems like I can't get the Squeezebox to go to sleep after a time that's shorter than the time remaining on the currently playing song.

Seems like it shouldn't behave like this to me. I'd have thought if you have say 22 minutes left on the current track, it should go sleep in 15 minutes, sleep at end of song, 30, 45, 60, 90 then sleep canceled. I think that would make more sense.

Ben Sandee
2006-09-23, 17:10
On 9/23/06, edc1 <edc1.2em1en1159053001 (AT) no-mx (DOT) forums.slimdevices.com> wrote:
>
>
> sleep works as you describe for a song that's shorter than 15 minutes.
> end of song, 15 minutes, 30, 45, 60, 90 then sleep canceled. If I start
> playing a track that is say 22 minutes long I get. sleep in 22 minutes,
> 30, 45, 60, 90 then sleep canceled. With a track of 65 minutes I get
> sleep in 65 minutes, sleep in 90 minutes then sleep canceled.


Yes, sounds like a bug to me. I searched bugs.slimdevices.com but didn't
come up with any hits, I would file a new one if I were you. I'm sure
they'll fix it up quick.

Ben

edc1
2006-09-24, 02:00
Thanks Ben. I've done that:

http://bugs.slimdevices.com/show_bug.cgi?id=4205

I played around a bit more last night and found that if I pause the currently playing song. Then hit sleep. I get the old SlimServer 6.3.1 behavior.

Sleep in 15, 30, 45, 60, 90 then Sleep canceled.

So the problem only happens when a long song is actually playing. I can live with that for now.

Jerryacg
2006-09-24, 02:26
Thanks Ben. I've done that:

http://bugs.slimdevices.com/show_bug.cgi?id=4205

I played around a bit more last night and found that if I pause the currently playing song. Then hit sleep. I get the old SlimServer 6.3.1 behavior.

Sleep in 15, 30, 45, 60, 90 then Sleep canceled.

So the problem only happens when a long song is actually playing. I can live with that for now.

Where on the UI is the sleep option located?

edc1
2006-09-24, 02:54
I was talking about the sleep button on the Squeezebox remote control.

You can set the sleep time-out through the UI though. I'm using the Fishbone skin. When a track is playing you get the sleep option in the top right corner of the UI. You get:

Sleep / Settings / Undock

in the top right corner. The sleep option here behaves the same way as the sleep button on the remote.

edc1
2006-09-25, 10:41
The bug report I setup has an update on it now. It changes the following line in Slim/Buttons/Common.pm:

my @sleepChoices = $remaining ? (0, $remaining, 15,30,45,60,90) : (0,15,30,45,60,90);

to read:

my @sleepChoices = $remaining ? sort(0, $remaining, 15,30,45,60,90) : (0,15,30,45,60,90);

so that the sleep time options are numerically ordered.

Rather than downloading a nightly build of Slim Server I thought I'd be able to put this change into Slim/Buttons/Common.pm on my Slim Server installation and then I'd have the fix. I tried restarting the Slim Server but it doesn't seem to make any difference. Am I missing something here? Do I need to do something else for this change to work? I'm running Slim Server on a Windows machine if that make any difference.

Thanks.

WSLam
2006-09-25, 10:43
There is also a new Sleep button on the Transporter remote. =)

kdf
2006-09-25, 10:53
Quoting edc1 <edc1.2epboz1159206301 (AT) no-mx (DOT) forums.slimdevices.com>:


> Rather than downloading a nightly build of Slim Server I thought I'd be
> able to put this change into Slim/Buttons/Common.pm on my Slim Server
> installation and then I'd have the fix. I tried restarting the Slim
> Server but it doesn't seem to make any difference. Am I missing
> something here? Do I need to do something else for this change to work?
> I'm running Slim Server on a Windows machine if that make any
> difference.
>
The change isn't in a nightly, as it is only posted to the bug report.
When the changes make it into a nightly, you'll get a notification
from bugzilla that mentions the revision levels and that the bug is
fixed.

Making changes on your local copy will work, but ONLY if you run
slimserver.pl. Slim.EXE (aka the installed service) is pre-packaged
so that all core modules are already part of the EXE. Only changes in
Plugins will have any effect.

In order to run slimserver.pl, you can install ActiveState's
ActivePerl, available from activestate.com.

-kdf

edc1
2006-09-25, 11:04
Ahhh. Fantastic. That's what I was missing.

Thanks for your help.