PDA

View Full Version : How do I see a USB drive connected to my QNAP



Seineseeker
2006-09-23, 06:56
I've connected an iomega external HDD to my QNAP via the USB. The QNAP knows it is there, because I can see it if I go into Administration/System/USB disk, but I can't see it from my PC.

Is this a similar disk mapping problem? How do I get to see it from my PC?

ultra238a
2006-09-23, 09:00
You'll have to map the drive using the utility.

If you want to use it for extra SlimServer storage then you can't at the moment, though we are working on a patch that will sort this issue out and should be ready soon.

Seineseeker
2006-09-23, 09:12
If by utility you mean the install wizard, mine doesnt work as it asks for a password I haven't got. You helped me out mapping the public folder on the QNAP in this thread
http://forums.slimdevices.com/showthread.php?t=27097

So I think I have to do it via windows, what would the IP address of a USB drive connected to the QNAP be?

\\192.168.1.103\ ????

Its not to extend the capacity (at the moment!).

happyfishman
2006-09-24, 00:05
The Qnap utility should allow mapping with the default user name & password (administrator: admin, I think), unless you've changed it...


If by utility you mean the install wizard, mine doesnt work as it asks for a password I haven't got. You helped me out mapping the public folder on the QNAP in this thread
http://forums.slimdevices.com/showthread.php?t=27097

So I think I have to do it via windows, what would the IP address of a USB drive connected to the QNAP be?

\\192.168.1.103\ ????

Its not to extend the capacity (at the moment!).

Seineseeker
2006-09-24, 00:39
Paul said it might be firmware issues causing this password problem for me.

Anyway, I haven't changed any passwords, I can't use the utility to map a drive, so I need to do it via windows.

happyfishman
2006-09-25, 14:59
Paul said it might be firmware issues causing this password problem for me.

Anyway, I haven't changed any passwords, I can't use the utility to map a drive, so I need to do it via windows.

I might have had the same problem as you. It was solved by removing any existing Qnap mapped drives (including the public), then use the utility to remap them starting with the public. This should be mapped under a different user name i.e. the same username and password as the others. If you haven't changed it the 'administrator:admin' should work now.

Seineseeker
2006-09-26, 03:49
I solved it. I did need to demap the QNAP public, but the main thing was to find the name of the USB drive. I bit of fiddling around with the QNAP set up and I found it: USB Disk 1

So to map I had to do it via windows with:
\\192.168.1.103\USB Disk 1

Seineseeker
2006-09-26, 03:51
Oh no! I spoke to soon! When I click on the USB drive in Explorer I get the message "Too many connections to a server or a resource shared by the same user......"

What now?

Paul_B
2006-09-26, 04:08
This is because you are mapping with two different account. Probably your first mapping is to Public which allows anaonymous or guest acces, whereas the USB drives requires authentication. You can't authenticate to the same server with different credentials, follow the advice of happyfishman

Seineseeker
2006-09-26, 04:42
This is because you are mapping with two different account. Probably your first mapping is to Public which allows anaonymous or guest acces, whereas the USB drives requires authentication. You can't authenticate to the same server with different credentials, follow the advice of happyfishman

This is driving me mad!

I can't use the utility because it asks for a username/password that I don't have / doesn't exist. It has never worked. So I am doing it via windows, and I can't map both drives at the same time.

I don't quite understand this use a different password stuff. I don't have any passwords except for the original QNAP administrator password, and that doesn't work!

happyfishman
2006-09-27, 14:27
This is driving me mad!

I can't use the utility because it asks for a username/password that I don't have / doesn't exist. It has never worked. So I am doing it via windows, and I can't map both drives at the same time.

I don't quite understand this use a different password stuff. I don't have any passwords except for the original QNAP administrator password, and that doesn't work!

Again... Disconnect all Qnap mapped drives. Then use the Qnap utility. Map drives from there. Map the 'Public' drive first and select "connect using a different user name" and "reconnect at logon". Enter the Administrator/Admin username and password. All the other drives should also map fine without selecting the "connect using..." option and stay mapped.

Trust me (and Paul_B)... you have EXACTLY the same problem I had...

Seineseeker
2006-09-28, 00:27
I trust you Happyfisherman and I'm very grateful for your help, but....

I don't have any passwords set, and I only have 1 user (the administrator account) and it does not have a password. So when I say connect with a different user it asks for a username and password which I don't have. Whatever I put in, it won't map using the utility.

The Public will map via Windows without connecting as a different user, but if I try and connect with a different user I get the same problem as with the utility. In any case I then can't map the USB drive.

If I am still being stupid I apologise. Do I need to set up another account on my PC?

happyfishman
2006-09-28, 04:40
The 'administrator' user name comes with the 'admin' password set as a predefined default which you can subsequently change in the Qnap administration page. So even though you don't think you have any passwords set, you really do.

I'm not an expert, but I understand that Windows doesn't like single devices to connect to networks with multiple usernames and passwords. The Qnap seems to kind of come that way, though. The 'Download', 'Multimedia', 'Webserver' and 'Usb' partitions/drives come with the administrator/admin user & password combination set as default, but the 'Public' drive, as the name suggests, comes with no username and password. Windows, however, sees this as just a different username and password and doesn't like it. One solution - which is what I have done - is to change the 'Public' drive access to the same as the others i.e. the same username and password for everything. This just means that, after mapping, when you first start your computer and click on any of the drives - now including the 'Public' drive - it will ask for the user and password. Once entered, all the drives are available.

In my experience you need to do this cleanly i.e. disconnect ALL of the previously mapped Qnap drives in Windows Explorer, especially the 'Public' drive, even though that may be the only one that you can currently gain access to. Then start the Qnap utility and map the 'Public' drive first as I've previously described. Next, do the others in sequence. I can't remember, but you may be asked to enter the default username and password (administator: admin) before you can map the first non-public drive. All the 'drives' should now be accessible and working.

I am currently on my second Qnap - the previous one suffered a hardware failure. Strangely, I didn't have this problem when I installed the first one, so perhaps this is something to do with a Qnap firmware change...



I trust you Happyfisherman and I'm very grateful for your help, but....

I don't have any passwords set, and I only have 1 user (the administrator account) and it does not have a password. So when I say connect with a different user it asks for a username and password which I don't have. Whatever I put in, it won't map using the utility.

The Public will map via Windows without connecting as a different user, but if I try and connect with a different user I get the same problem as with the utility. In any case I then can't map the USB drive.

If I am still being stupid I apologise. Do I need to set up another account on my PC?

Seineseeker
2006-09-29, 02:15
Thanks for all your help Happyfisherman. Now I know why the QNAP asks me for a password for the public on the QNAP, and why I don't have one.

I haven't managed to get it working yet though. How do I set the password for public on the QNAP? I can't find it in th QNAP admin stuff.

happyfishman
2006-09-29, 06:56
Thanks for all your help Happyfisherman. Now I know why the QNAP asks me for a password for the public on the QNAP, and why I don't have one.

I haven't managed to get it working yet though. How do I set the password for public on the QNAP? I can't find it in th QNAP admin stuff.

Covered that above...

Run the Qnap utility (after reconnecting all Qnap drives), use "map drive" select "public", then "map network drive". Click on "connect using a different user name". you will get a "connect as..." popup window. Enter the "administrator" and "admin" as user name and password respectively (assuming you have not changed the default password in the Qnap administration pages), tick "Reconnect at logon". You can now map the other drives, but these don't need the "connect using a different user name" option as they are by default set to the above user name and password already. You should tick the "Reconnect at logon", though. All the dives should now be mapped and working in Windows Explorer (you might need to select "refresh" (or F5) to see them.

I would advise you to change the password in the near future, though, because if you have set up web access to your drives anyone could stumble on them and and have a bit of a play...

Seineseeker
2006-10-02, 09:52
Happyfisherman,

Finally I have done it. It took a while, but once I managed to change the password of the QNAP to administrator:admin I could do it.

Thanks so much I couldn't have done it without you (especially since Paul was ignoring my PMs, maybe he thought it was outside his remit. EDIT he did come back to me in the end and said he had been busy to be fair, but I had sorted it by then. I guess its better to leave people like me to try and sort things out themselves first).

Happy Seineseeker

happyfishman
2006-10-03, 02:01
Happyfisherman,

Finally I have done it. It took a while, but once I managed to change the password of the QNAP to administrator:admin I could do it.

Thanks so much I couldn't have done it without you (especially since Paul was ignoring my PMs, maybe he thought it was outside his remit. EDIT he did come back to me in the end and said he had been busy to be fair, but I had sorted it by then. I guess its better to leave people like me to try and sort things out themselves first).

Glad you got there in the end... I lived with it for maybe six months before someone else suggested a solution (thanks Paul_B)!