PDA

View Full Version : Re: Another Try---Using an Existing Mysql Server - MySqlVersion



BigBirdy
2006-09-22, 10:20
Excellent...I think I am almost there...and thanks to everyone that responded. Now I am currently running MySql 4.1.10 and donít really want to upgrade yet as this is a large db with many other services using it and I need to test all sorts of other applications before upgrading, so is there a way to resolve this issue..below is the /tmp/slimserver.log entry after pointing to the existing db and trying to restart ss.

Carp::Clan::__ANON__(): DBI Connection failed: DBI connect('hostname=127.0.0.1;port=3306;database=Sli mserver:mysql_socket=/var/lib/mysql/mysql.sock','stork',...) failed: Client does not support authentication protocol requested by server; consider upgrading MySQL client at /usr/local/slimserver/CPAN/DBIx/Class/Storage/DBI.pm line 652



> -----Original Message-----
> From: hickinbottoms
> [mailto:hickinbottoms.2ejkin1158937801 (AT) no-mx (DOT) forums.slimdevices.com]
> Sent: Friday, September 22, 2006 8:07 AM
> To: discuss (AT) lists (DOT) slimdevices.com
> Subject: [slim] Re: Another Try---Using an Existing Mysql Server
>
>
> Johnny Stork;138430 Wrote:
> > Ok, my last post didnít generate any replies so maybe a different
> > subject. This cant be a unique situation, but I would like
> to use my
> > existing mysql server which just happens to run on the same
> server as
> > slimserver. Are there any howto's on how to move to a
> single, existing
> > mysql server. This should be simple, export, import and
> change some db
> > id/password/port/host settings somewhere.
> >
> > Thanks for anyone that can help
> >
> > __________________________
> > Johnny Stork
>
> Funny you should say that, but I wrote one last night:
>
> http://wiki.slimdevices.com/index.cgi?ExistingMySQLInstance
>
> Useful thing, that wiki.
>
> Stuart
>
>
> --
> hickinbottoms
>
> -"Never put off until tomorrow what you can put off until the
> day after
> - with 'Lazy Searching'
> (http://hickinbottom.demon.co.uk/lazysearch)!"-
> --------------------------------------------------------------
> ----------
> hickinbottoms's Profile:
> http://forums.slimdevices.com/member.php?userid=255
> View this thread: http://forums.slimdevices.com/showthread.php?t=27728
>
>

Steve Bernard, Jr
2006-09-22, 11:41
On 9/22/06, Johnny Stork <stork (AT) openenterprise (DOT) ca> wrote:
> I thought it best to start a new thread now. I upgraded Mysql to 5.0.24a standard...so far so good. But trying to start ss I still get these errors?? Is this just a DBI.pm issue/upgrade?

I'm seeing these same errors. I just deleted server/CPAN/DBI.pm and
it started just fine. Actually, my YAML::Syck is the wrong version,
too, so I have had to delete server/CPAN/YAML/Syck.pm whenever I
upgrade, too.

As long as you have the CPAN packages installed for yourself, it
should work right without the Slim-provided ones.

-Steve